Bangle 2 button no longer works - feels soft when pressing

Posted on
of 4
/ 4
Last Next
  • I've had my Bangle 2 since November and all as been working fine up until now.

    But I've just noticed that when pressing the button, the watch no longer responds to button presses any more (so I can't access the menu/apps etc). The button also feels much softer when pressing now, and no longer has a tactile feel.

    I have tried wiggling the button a little as suggested in the following thread, which has had no effect:­370487/#comment16290141

  • I'm really sorry. I hope the problem gets resolved.

  • Hi - sorry to hear this. I guess it's possible the flex PCB has somehow lifted out of alignment with the button.

    I'll drop you a personal message and we'll arrange a replacement

  • Any news on possible fixes? It seems one of my two bangle2 now has the same issue. Happened during testing performance improvements on reload so several long presses in a few minutes. Suddenly no click, only soft resistance. Wiggling the button around and slight "percussive maintenance" didn't change anything. The other one is still going strong :)

  • Any news on possible fixes?

    I'm afraid not... Here's what it actually looks like.

    The button is on a tiny daughterboard, and sits in a little slot in the case (pointed to by some tweezers in the pic below).

    So I imagine what's happened is it has fallen out of that cup. So if you could get in easily then it'd be a trivial fix, but getting in requires removing the display, which is a pretty painful job (heat gun, suction cup, lots of patience).

    If someone were so inclined they could drill a small hole directly above the button and then poke a pin in and use it to fiddle the button down again I guess.

    "percussive maintenance"

    To be honest this is about the only option right now - if you imagine the PCB has risen up, I guess you need to have the Bangle face-up and then bash that edge down onto a table, and it might re-seat the button. I've got one that was returned here and I don't have any success with that though.

    So it might be I need to arrange a return

    2 Attachments

    • IMG_20220214_151722.jpg
    • IMG_20220214_151529.jpg
  • Hey. You asked me on kickstarter to put it here. I have the exact same issue. The button feels soft and is not responding. "Percussive Maintenance" did not help either.

  • The first image is the correct placement, or is it already lifted out of place on the picture? Is the button itself made from magnetic materials? Maybe a strong magnet could pull it back in place. I only have tiny neodymium magnets, those seem to do nothing.
    I could try opening the watch to verify the problem, but my success rate getting sealed devices back to being sealed is not that great :)
    The idea of drilling a hole seems a bit dangerous to me, since the position of the button board is not known, so damaging something is quite possible. If not during drilling, then presumably during poking around in the device with something solid enough to manipulate the button back into position.

  • My wife's watch button has always been a bit mushy but for now it works fine. She uses it more often now, should we start worrying? :(

  • Hi @UCas thanks - KickStarter comments are really useless (I couldn't get from your post there back to your user easily). I'll drop you an email now about sorting out a return.

    @halemmerich it's already a bit out of place in that picture (it's a watch I disassembled and hastily re-assembled for the pic). It doesn't seem to be magnetic either I'm afraid. I'll get you a replacement out too.

    @Alessandro I really wouldn't worry! It always seems worse when you see stuff together on the forum but there are over 3000 watches out there now, and I think this makes 4 button issues - so it's like a 0.1% failure rate for the button, which really isn't such an issue.

  • @Gordon hi. It seems like the button on my watch is gone also. It was strange behavior the last couple of days when I had to click twice to unlock the watch then this morning it stopped reacting to press at all. There is no clicking sound. Is it possible to replace the button by myself? I have some small experience and quite straight hands lol.

  • Sorry to hear that - are you a KickStarter backer, or did you buy yours through the shop?

    As shown in the pictures above, if you can get inside the watch it's trivial to fix. The problem is getting inside - I believe it's much like replacing an iPhone screen - you have to heat the screen up for quite a while and then use a suction cup to pull it up and off.

  • @Gordon I am a kickstarter backer. Well, I thought the back panel should be removed not the screen. I feel less certain at the moment. The whole button with a small board and ribbon cable should be replaced? Do you know how to find exactly the same model? Just thinking about options if I can find the replacement button here.

  • The whole button with a small board and ribbon cable should be replaced?

    I think most likely the button board is fine, but has just become dislodged such that it's no longer being pressed in the right place by the button.

  • @Gordon could you please check PM regarding the button issue. Thank you

  • Yes, I'll get back to you shortly. I don't generally work at the weekend and it took me pretty much all of yesterday to catch up with messages, so I didn't get around to replying

  • Since a few days my Kickstarter Bangle 2 has the same problem. The button doesn't work anymore and feels soft when pressing. Wiggling the button didn't help.

  • Hi, sorry to hear that. I'll send you a PM

  • Just a note on this: I just dismantled one of the Bangles with a dead button that I got back, and at least in that case the button PCB had not come out of the 'pocket'.

    It looks like the actual button itself had come to pieces. Fixing it would still be possible - the button could be unsoldered and replaced - but it's some way from being as easy as pushing the PCB back into the hole.

    1 Attachment

    • banglejs2_button.jpg
  • Mine has had a kinda flimsy button as well, it seems I need to press it at an angle for it to register. It's been doing this since I got it from the Kickstarter but otherwise works as advertised, maybe I got a lemon :)

  • Same problem here with my Kickstarter Bangle 2. The button worked fine until a few minutes ago. Then suddenly out of the blue there was no longer any perceptible pressure point and the button stopped working. 😟

  • Sorry @Gordon, I have bad news from my bangle :-(

    Same problem here with my Kickstarter Bangle 2. The button worked fine until a few minutes ago. Then suddenly out of the blue there was no longer any perceptible pressure point and the button stopped working.

    Same here. The button worked fine until last night. Suddenly no click, button dead :-(

    My wife's bangle seems ok although its button is a bit mushy (seldom her bangle still freezes but at least the button works (for now))

  • Hate to add onto this, but I'm having the same problem @Gordon (and mine's a kickstarter banglejs 2 if it helps), went to click the button this morning and no click, just a soft press.

    I also ended up with the contacts problem, but that was manageable. Definitely need a replacement/fix for this though since I'm not tempted to try and open the thing up, and it's not really usable in it's current state.

  • Ok, thanks - I'll message you later today and we'll sort something out.

    Got to say I'm a bit surprised to see so many failing in just a 48 hour period though.

  • @Gordon Did you see my PMs?
    Also another question: my Bangle turned off after the battery was discharged. I was hoping it would turn on again when connecting it to the charger but it didn't. Is this expected?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle 2 button no longer works - feels soft when pressing

Posted by Avatar for krytten @krytten