Bangle 2 button no longer works - feels soft when pressing

Posted on
of 4
/ 4
Last Next
  • Would it be possible to use a swipe gesture on the watchfaces, so that you can access the launcher menu without having to click the physical button, in order to save its life?

    Just an idea :)

  • You could put something into a widget to do that generally, or if you have a personal watchface that you use you could put code right on there. I just tested putting this at the bottom of 93dub to go to the launcher with a tap at the top of the watch:

    Bangle.on('tap', tap => {
      if (tap.dir == "top") load("");
  • I had that idea, too :)
    It is possible to do that with the Pattern Launcher.
    I did that but it only worked until the Bangle hang (maybe an infinite loop). The Bluetooth connection didn't work anymore in that state, and without the button it was not possible to restart the watch and make it work again. So the battery discharged and now the Bangle is unusable.

  • Hi @ChrisS - sorry, no, I didn't see those. Will reply now.

    so that you can access the launcher menu without having to click the physical button, in order to save its life?

    Yes, it exists right now - it's called Swiper Clock Launch :­klaunch

    Needing a button press to boot was an attempt at ensuring the Bangle could always be powered on even if the battery was completely flattened, but yes, if your button is totally dead it effectively bricks the watch (unless it's rebooted with the SWD pins which isn't an option for most people).

  • Out of curiosity: is there a reason for having "Hold BTN to reload" instead of "Touch to reload"?
    I mean the label that appears after install/update/remove an app from the store.

  • Well, the button to reload bit is in the firmware. It reloads everything when you hold the button. Some code could be added in addition to the Hold BTN to reload message that makes touch work though, it'd just have to be careful that it got removed next time you tried to upload an app.

  • Using the button less often may prevent it from damage.
    I wonder if a button could be added to the Bangle apps page to send a reload command to the watch?

  • While it may make the watch somewhat usable if the button has already gone, I feel it is unlikely to make a difference to overall longevity if the buttons really are prone to failure (hopefully it is just an unlucky few). I for one (button thankfully still fine) don't consider reloading after using the app loader to be anywhere near my main use of the button.

  • I received the replacement for my broken watch (Kickstarter edition) today. One thing I noticed is that the button of the new watch feels different when pressed and it is also considerably less noisy. It feels much more similar to my Amazfit Bip now.

    Nevertheless, I will try to use the button less by unlocking the screen with a wrist movement and using "Swiper Clock Launch".

    Also kudos to Espruino support (Christine) for the swift and professional handling of my issue!

  • Sorry @Gordon, but I now also have this problem with my Kickstarter Bangle 2.
    My button has not worked since this morning. I wore the Bangle overnight and yesterday everything was still ok.

  • Can you still feel a 'click' when you press it? Or is there now no feeling to it?

    And just to rule out a software issue, is the clock on the watch still updating? And if you hold down the button for ~30 seconds, does nothing happen at all?

  • Yes, I can still feel a click, but it is much softer than yesterday and I have to press the button deeply with the tip of my fingernail for it to work at all. That I can still press the button with my fingernail, I just found out.
    The Bangle itself still works and I can still reboot it if I press the button longer with my fingernail.

  • Ok, thanks. Do you think it's too hard to press now to be easily usable?

    I wouldn't want to have to replace a watch just because the feel of the button changed from what you were used to, but if it's just not usable any more then I'll get a replacement sorted out

  • Hi @Gordon, I've almost gotten used to it.
    So far, the button is still working slightly.
    I'll get back to you when it's completely broken!

  • Thanks!

  • Unfortunately, but my button stopped working today as well. (Kickstarter Bangle.js 2)

    Is there any way to get a replacement?

  • Ok, sending you an email...

  • Mine is starting to have issues. I have to push it much further in for the button hit to register. I think it might have gotten dislodged. Is there any documentation on how to open it for repair?

  • @CountMurphy it is probably best to send you a replacement. Could you send me an email to with your details?

  • Hi, sad day today as it 's SpringBroken for me too
    This morning, i noticed the button was soft, not doing anything.
    And I thought i could do without it, at least to backup the watch, but nothing, i just managed to get it stuck.

    Not sure if it s (still) possible to get a replacement, but i miss already my favorite watch

    It s a kickstarter one (can't even use the past)


  • Ok, I'll ask @Christine to sort out a replacement - it'd be good if you can send the old one back though.

  • sure thing ! and thank you

  • My second button (v2.1) just went, this time I could actually feel/hear movement inside the watch and the "springyness" of the button was gone. Will try to fix it myself this time. How hard can it be


  • Just a tip on a way to lessen the wear on the button: Light Switch Widget has a feature for tapping a side of the Bangle to unlock.

    Personally I prefer this to the other standard alternatives to pressing the button to unlock. The app is really neat in other regards as well!

    I also use Quick Launch for opening the launcher with swipes to save some button presses there. Another alternative is of course Pattern Launcher.

  • I got the screen removed and the button was about 2/10 of a mm out of position. Moved it back and for now its working again. Not exactly as clicky as before, but usable.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle 2 button no longer works - feels soft when pressing

Posted by Avatar for krytten @krytten