Bangle 2 - Button stopped working

Posted on
  • Hi. The button of my Bangle 2 suddenly stopped working (Sadly, I can't recapitalize the actions I did when it happened). I already tried to reinstall everything and I also restarted it using "E.reboot()" in the IDE, but it didn't help.
    Could this be a software issue? Is there anything I can do?

  • Well, so far I've seen:

    I've just had a play with the one that got sent back here and while it didn't work initially, I pressed the button (normally, not hard) and then wobbled it side to side and back to front a little (there's a little bit of play in the button) and it started working again pretty much immediately.

    So maybe you could give that a try?

  • Yeah this happened to me too. At first it was working fine and there was some deliberate "clicking" feels akin to breaking a needle-sized bone but after only a few mins of use the button got stuck feeling. Felt mushy and no click at all, no presses detected even when it was off. It took some occasional retries over a few hours and then the click came back. I think there was one more time during that night when the mushiness returned but after that point I've been happily using it reliably.

  • Thanks for the suggestions. I've been playing around with it a bit with no luck first, but suddenly it started working again. It still doesn't simply work, and I have to wobble it a bit or press in some specific way to react, but that's a lot better than just nothing. I hope this will also be fixed after a while of use. Thank you very much :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle 2 - Button stopped working

Posted by Avatar for DeMa @DeMa