Having some issues with my Bangle.js 2

Posted on
of 2
/ 2
  • I turned on the watch and it seems fine, but I had to manually set the time. I’ve downloaded the “WebBLE” app and it will connect to my watch, but I can’t figure out how to update the watch. I’ve gone to the Banglejs App Loader site and selected the Bangle.js 2. If I click on the icon to upload a file to my watch I first get a message to go to the App Store to get the WebBLE app, (even though I already have the app). I click on the app and since it was open already and I had already connected it to my watch, it’s still showing it’s connected, but not showing that it’s uploading any files.
    I’m pretty much lost here as to how I’m supposed to get files from the app loader website through the WebBLE app to the watch.
    Additionally the watch only shows time and date. I can set alarms or countdown timers, but the watch doesn’t “beep” when they go off despite the fact that in the settings I have it set to “beep” when the timer finishes or the alarm goes off. And finally the health app doesn’t do anything, I’m guessing that’s an update issue???

  • And finally the health app doesn’t do anything, I’m guessing that’s an update issue???

    The health App needs to be setup from the settings menu in the health app. It will take a day to record a days data. After an hour you should be able to select Steps and see what steps you did in the last hour.

    I'm not familiar with WebBLE - you need an Apple user to support you.

  • Well, unfortunately I’ve had the watch for two days now and I set up the health app the first day. It doesn’t show anything. The green lights are also not coming on. However, the other day I was looking at the files on the watch via the WebBLE app and I clicked to run the file named “health.boot.js” the lights do come on, but the message “loading” pops up on the face of the watch over the time display and doesn’t go away. The “loading” message just stays there until I push and hold the side button, then the lights go out again.

  • Try the following in the left hand window of the IDE with the watch connected to the IDE.
    Type the lines after the >
    The lines starting = are the responses.

    >  var data = new Uint16Array(31);
    =new Uint16Array(31)
    >  require("health").readDailySummaries(new­ Date(), h=>data[h.day]+=h.steps);
    new Uint16Array([0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 80, 0, 0, 0, 2294, 0, 0, 0, 0, 0, 0, 0, 0, 0])

    Here you can see step data for the last few days this month.
    What version of the firmware are you using ?

  • The version I have is shown as:

    I tried the strips you showed above and it’s not showing any steps right now.

  • Ok, so it sounds like you have the Bangle.js App Loader working ok now?

    To actually get data off, you go to 'My Apps' in the app loader, and then apps like Health that have downloadable data have an icon next to them that you can click to download the data. For some reason on Android I'm only seeing the icon as a box right now, but I'll look into fixing that.

    Also, to get heart rate values you must enable in in health's settings.

  • What does it show?
    Can you do a Screenshot.
    Aldo for steps have you been wearing the watch and walking around more than 8 steps in a burst?

  • I’ve tried to upload apps from the app loader, but when I do I get the message:

    “To use Web Bluetooth on iOS you’ll need the WebBLE app. Please click OK to go to the App Store and download it”

    Problem is that I already have the app, AND it’s already open AND connected to my Banglejs2. Whether I click OK or not, the little icon next to the app starts the circling motion as if it’s uploading, but it’ll stay like that for hours.
    In the WebBLE app I can see files on my watch, but I can’t upload any files unless I can get them into the WebBLE app first.
    By the way, I have an iPhone 12 with iOS 15.1 currently.
    What’s confusing to me is that it seems everyone can upload files directly from the App Loader to their watch, mine won’t and insists that I get WebBLE first, (which as I mentioned I already have).

  • When I’m in the App Loader and I click on “My Apps”, there’s nothing in that tab/file.

  • To auto-set the time on the watch I used/loaded the GPS TIME app, then used the
    "Locale" within settings to set the time zone (+6 in my case, CST).

    I also had to set to the 24 clock (I think that is in the SETTINGS).

    Note: when you first fire up the GPS app(s) you must be outside and wait a bit (it took 10 minutes to synch with a GPS satellite).

  • Are you using the bangle app store on your iPhone to try to upload the apps? I'm pretty sure web Bluetooth only works in the Chrome web browser. That may be why you are getting the error about WebBLE.

  • I used the Bangle App store in Chrome. The app loader in Chrome (on my Mac) worked fine.

  • Okay, so it is working for you now?

  • Yes, my watch is working as is the Bangle App store / loader.

  • Great! By the way, I saw you said something about having to manully set the time. You can get it automatically through the app loader if you go to the 'About' page and click the "Set bangle.js time" button near the bottom.

  • It doesn’t matter if I use the safari web browser or chrome, I get the same message about needing to get the WebBLE app. And as I’ve stated before I will have the WebBLE app already open and connected to my watch, but I still cannot load apps this way. I was trying to use my Desktop Mac at home, but the Bluetooth on that computer doesn’t see my Banglejs 2 watch. And yes, I did check the computer settings and it shows that it is set to connect through BLE as well.
    Is there Any other method I can use to connect to my watch? I’ve even tried to use the charging/data cable connected to my Mac and it doesn’t show up.

  • I don't think Chrome on iOS supports web Bluetooth either, you need to use the desktop version. Also I believe the Bangle js can only be connected to one device at a time, so try to disconnect it from the WebBLE app.

  • I’ve tried to disconnect before, and when I do the watch disappears from the list of connected devices on my phone’s Bluetooth listing. Is there changes I can make in my iPhones Bluetooth to make sure it can see the watch? Seems like it only can through that WebBLE app.

  • AH, thanks for the hint on setting the time from the IDE/appstore.

  • @user136917 I'm not sure if I'm understanding, but just to be clear:

    You need the WebBLE app running, and to have visited https://banglejs.com/apps from inside the WebBLE app itself.

    It's not enough to just install the WebBLE app and then visit https://banglejs.com/apps in Safari or Chrome, which it sounds like you were doing?

  • Ok, I finally figured it out. I did not know that I needed to open the App loader website IN the WebBLE app. Looking at what you said made me realize that the WebBLE app is actually a sort of combination App & Web Browser itself. As soon as I cut and pasted the App loader web address into the WebBLE app/browser, it took me to the app loader website where I found I was able to connect to my watch and even upload a new click face.

    Now my question would be to find out how to get my health app working again and what GPS app do I need for location.

  • I also noticed that some apps require the beta firmware 2v11. My watch only has 2v10.219. How do I get the 2v11.

  • Ok, I made some more discoveries. First, I noticed in the WebBLE app, (being on the App loader website), that when I selected the “my apps” tab that I had some updates. When I clicked to update the apps, my watch updated then reloaded and the green lights then came on on the back of the watch. So it seems the Health app is now working. What I’m curious to figure out now is why my watch doesn’t “beep” even though I selected to option for it to beep in the settings!

  • Do you mean an actual, audible beep? Because it can't do that, there is no speaker. In the emulator "beep" shows in settings as undefined, I guess it shouldn't show at all?

  • Because it can't do that, there is no speaker.

    Bangle v2 is able to make a beep, v1 only some devices. On Both devices nearly inaudible in normal environments.


    In IDE works.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Having some issues with my Bangle.js 2

Posted by Avatar for Paladin316 @Paladin316