You are reading a single comment by @jgDev and its replies. Click here to read the full conversation.
  • I’ve tried to upload apps from the app loader, but when I do I get the message:

    “To use Web Bluetooth on iOS you’ll need the WebBLE app. Please click OK to go to the App Store and download it”

    Problem is that I already have the app, AND it’s already open AND connected to my Banglejs2. Whether I click OK or not, the little icon next to the app starts the circling motion as if it’s uploading, but it’ll stay like that for hours.
    In the WebBLE app I can see files on my watch, but I can’t upload any files unless I can get them into the WebBLE app first.
    By the way, I have an iPhone 12 with iOS 15.1 currently.
    What’s confusing to me is that it seems everyone can upload files directly from the App Loader to their watch, mine won’t and insists that I get WebBLE first, (which as I mentioned I already have).

  • Are you using the bangle app store on your iPhone to try to upload the apps? I'm pretty sure web Bluetooth only works in the Chrome web browser. That may be why you are getting the error about WebBLE.

  • It doesn’t matter if I use the safari web browser or chrome, I get the same message about needing to get the WebBLE app. And as I’ve stated before I will have the WebBLE app already open and connected to my watch, but I still cannot load apps this way. I was trying to use my Desktop Mac at home, but the Bluetooth on that computer doesn’t see my Banglejs 2 watch. And yes, I did check the computer settings and it shows that it is set to connect through BLE as well.
    Is there Any other method I can use to connect to my watch? I’ve even tried to use the charging/data cable connected to my Mac and it doesn’t show up.


Avatar for jgDev @jgDev started