Malformed JSON Error

Posted on
of 2
/ 2
  • So I'm getting this error message in both the app loader and in gadget bridge: "malformed JSON from Bangle.js: No value for t."

    I can't reconnect to the app loader to erase all apps and start over, so I'm uncertain of what to do here.

    Also, when did the Bangle develop the capacity to assign value to things like tea and coffee? ūü§£

    Any help is appreciated!

    1 Attachment

    • Screenshot_2021-11-17-09-21-47-563.png
  • That'll be an error that Bangle.js is reporting I think.

    But I guess the question is...

    I can't reconnect to the app loader to erase all apps and start over, so I'm uncertain of what to do here.

    Why? What happens? If you can't connect to the app loader it's probably a sign that something is broken, which could explain this problem

  • That doesn't sound fun.

    It says Device connection failed: invalid JSON

  • Ok, please could you try connecting with the Web IDE? At least with that you might be able to see what's being output to the console that is causing issues

  • What worked for me eventually:

    1. cleared Gadget Bridge cache/data in android - settings - apps
    2. ensured it wasn't paired/hooked to any other device already, namely my laptop in the other room.
  • Interested to find this as I was searching for a similar Gadgetbridge error connecting to the Bangle.js2. Mine says 'Malformed JSON from Bangle.js: No value for status'. This appears on connection.
    My firmware and Gadgetbridge version are up to date, and message connection works OK (I can run most of the tests for connecting, e.g. call and message handling). But the data viewing options show now data (though the watch has plenty!) and the live measurement (heart icon) just spins the wheel with 'MEASURING' message.

    I've tried suggestions above, but all the resets and reloads don't seem to do anything.

    Grateful for any ideas! Thanks.

  • I got both messages from time to time (not always, but frequently).

  • Hi - it looks like the No value for status error is from the recent GPS addition to Gadgetbridge - unfortunately it looks like the Gadgetbridge GPS functionality really wasn't tested at all well before it went in :(

    @halemmerich had actually done a fix for this which I wasn't merging because it contained a few other things I wanted to look at in more detail, but I've just merged it and pushed it live, so if you update android now I think that one is fixed.

    and the live measurement (heart icon) just spins the wheel with 'MEASURING' message.

    I just checked and the live measurements weren't implemented, but I've just added that too sp hopefully it'll work ok now.

  • Wow! Thanks for the quick response and extra effort. Will try this later.
    Just to be clear: I think you mean update the 'android' app on bangle.js? I guess when I do a general update this will happen.
    Or should I be updating the Gadgetbridge software? Apologies for newbie questions!

  • Ok, so tried the update of Android app on my js2. I'm now error free in terms of connection and everything Gadgetbridge does, but I can't see any data in the app or get the live measuring to work.
    It looks like no data syncing is happening, is there a way to trigger this?
    Have done all other updates: reinstalled Gadgetbridge from F-droid update all bangle.js2 apps, restarted phone and watch.
    I've tried this on a Huawei phone and Samsung tablet.
    Am i missing something or still a glitch in the software?


  • Am i missing something or still a glitch in the software?

    Ok, sorry - yes, it looks like there's still some problem in the Gadgetbridge Android app :(

    So - you can go 'Activity and Sleep', then scroll right over and click on 'Live Activity' and this then works (albeit the default update interval for 'live' updates is really slow). I have fixed this for the next Gadgetbridge release though.

    However looking at the code in Gadgetbridge, it seems someone added that live HRM measurement icon in a really broken way - it has never worked for Bangle.js (or I imagine most other watches) since the icon was added.

    I was going to try and implement it, but it's broken enough that after you click the button there's no way to even turn the HRM off when you close the window... so for now I have just removed the icon.

  • Thanks. I can certainly see some data loading intermittently but not getting a lot from it!
    I've since realised the app loader allows manual retrieval of logs so that's probably my best bet. Following the general rule to get the raw data into a spreadsheet as fast as possible!
    Maybe at some point ill write some js to retrieve the files automatically. :-)
    Thanks again for your help, really lovely system and community building round this!

  • I also get "no value for t" every time I update an app on any of my 3 Bangle.js 2's, and occasional random other invalid JSON popup errors. It doesn't seem to actually cause anything to not work, but it's annoying and I don't know how to make it go away.

  • Seems we have two issues in here:

    1. Malformed JSON from Bangle.js: No value for t
    2. Malformed JSON from Bangle.js: No value for status

    I get the 2nd "Malformed JSON from Bangle.js: No value for status" too. Version Bangle.js Gadgetbridge 0.72.0-banglejs. As far as I can see it is rather a cosmetic issue. I hope it will be fixed by an app update.

  • I think the nightly version already does not have those anymore, at least I have not seen them for a while now. Nightlies can be found in the GadgetBridge nightly repo:¬≠oid/repo/. This is of course for somewhat adventurous users :)

  • Yes, sorry - there's been an issue with updating the Play Store app (Google changed policies so I have to bump the API level to put out an update now) so a new release of it has been delayed a bit, but hopefully I'll get it fixed soon

  • Just a note to say this PR on codeberg exists, if it would be useful:¬≠etbridge/pulls/2924

  • Thanks! I never spotted that! I've just posted on that issue

  • Sorry to reopen this quite old post,

    but I do experience several, different malformed json errors, too quick for me to read the pop ups. Additionally (or corresponding???) there is some very strange behavior. No activity is downloaded except for the past few minutes but the app loops into "fetching activity" for ever (tried 24h...) and is unstoppable. Even if I try to force terminate the app, it keeps going. Need to restart the phone to end this, as soon as I open the app it starts over again.

    This is going on for a few months now, I was hoping some update might deal with the problem, which it didn't, so I decided to post.

    -Bangle.js Gadgetbridge 0.79.1 (F-Droid)
    -I'd love to post Bootloader and Firmware version but right now the watch won't connect at all (although I states to be connected in the app, as well as 'fetching activity').
    To the best of my knowledge both are up to date.
    -Fairphone FP2
    -Lineage OS 18.1

    Any help is very much appreciated.

  • Strange. I don't have any suggestions right now. But I wanted to mention this newly opened issue to Gadgetbridges codeberg repo:¬≠etbridge/issues/3601

    Also, if you store the Gadgetbridge logs (there's a setting in the app) you can look at them after the fact.

    Edit: this could be related too,­etbridge/issues/3600

  • @Ganblejs do you know if Fetching Activity is just the 'health' info or if it's related to downloading tracks (I guess that's not enabled by default?).

    @user156090 maybe you could enable writing to logs in Gadgetbridge and then send us the log you get when connecting to Bangle.js and getting the issue?

  • @Ganblejs do you know if Fetching Activity is just the 'health' info or if it's related to downloading tracks (I guess that's not enabled by default?).

    I'm almost certain it's just info from health. I'll take a quick look at the code.

  • Excellent, thanks!

    But we're saying that Gadgetbridge on the phone gets stuck showing Fetching Activity? It seems odd as fetchActivityData should just return immediately? I'm not sure what would stop the phone from mentioning it?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Malformed JSON Error

Posted by Avatar for PlaidFox @PlaidFox