Bangle 2 button no longer works - feels soft when pressing

Posted on
Page
of 3
First Prev
/ 3
  • Sorry to hear that... Thanks for the update, and glad you got the watch apart fine @halemmerich.

    After the first batch, we haven't had many reports of issues with the buttons at all. Is it possible you're pressing the button in a slightly odd way (like pressing it in but also rocking it to the back of the watch) and that is somehow managing to lever the button out of position over time?

  • That is quite possible, both buttons went while the watch wasn't on my wrist. The first defective button was on a watch that was mainly on my wrist, but it was an early bangle. The v2.1 defective button was on a watch used practically exclusively off my wrist for developing and testing, so a lot of handling it in different ways.

  • I seem to have hit the button failure problem on a Kickstarter edition bangle.js2. Thought it might have been a software bug, so I updated firmware and apps, which lands it in the "Hold button to reload". Whoops :-(

    How feasible is removing the screen to fix it? What sort of adhesive should be used to reattach it?

  • @halemmerich it's still surprising if it was one you're not wearing - it feels like you wouldn't have been using the button that much.

    @user149670 can you still feel a 'click' when you press the button?

    It's definitely doable to dismantle the Bangle.js 2 - someone posted up their experience here: http://forum.espruino.com/conversations/­373434/#comment16674380

    The most important thing is to not overheat the LCD (which means being really patient) - if you do heat it just a bit too much, this happens: http://forum.espruino.com/conversations/­379510/#16683325

    And it's really easy to overheat - I've messed up two so far by being too impatient!

    After the first post I tried here with a SMD reflow plate set to 100-degrees C (ideally it'd be less but that's the minimum mine would do) and I've had great success... But reflow plates are quite specialised :)

  • I don't think I feel the click; it's hard to tell because I didn't pay enough attention to what it's supposed to feel like when it was working, but I'm leaning towards no click.

    I don't think I have the tools to remove the screen readily available, so I'll look into getting a new one. The post-Kickstarter batches are much less prone to this?

  • The post-Kickstarter batches are much less prone to this?

    They appear to be, yes. It looks like @halemmerich has had issues with his new one, but it was one of the things I specifically told the manufacturer to look into and I haven't seen anywhere near the amount of failures.

  • @Gordon Today was my day. I can no longer press the button. It used to not work sporadically, but now it does not work at all anymore. My Bangle2 was also a Kickstarter one. Can we please find a solution for this together?

    Thanks in advance!

  • @Raik can you still feel a 'click'? Or is there no feeling there at all?

    About all I can do is what I've offered for others: I can send a replacement watch body to you if you send the old one back after?

    While you may be able to fix it yourself, there's a very high likelihood of completely destroying the watch LCD in the process and it's not something I can really suggest.

    However I should add a warning here: I can only offer a full replacement for this kind of thing for the first year's worth of ownership (which you're within). It seems pretty much every manufacturer only offers 6 months for issues like this (after 6 months, legally, it's up to the buyer to prove the issue wasn't due to wear and tear). I'm doubling that at 12 months, but as a small company I can't afford to go completely above and beyond.

    If someone does have issues with the button between 12-24 months of ownership I'll offer a pretty decent (almost 50%) discount on a new Bangle though.

  • Or is there no feeling there at all?

    No feeling at all. The button now is very light to press and does not click at all anymore. It used to work sometimes to press "at an angle" but that doesn't work either anymore.

    By new watch body you mean the watch without straps right?

    I'll be happy to send back the old one even in advance and I am willing to compensate for shipping costs and other expenses, just name a reasonable price. :-)

    Maybe we'll continue via PM?

    Many thanks!

  • By new watch body you mean the watch without straps right?

    Yes, that's right.

    But yes - Christine usually handles sending out replacements - I'll ask her to get in touch with you over email

  • @Gordon I hate to bother you again. The replacement of my Bangle2 through @Christine worked just fine. But now I got another issue with the new Bangle2.

    It does not seem to charge anymore. I only had to charge it about three times until now, which worked fine.

    I checked the pins on the cable, it shows 5.09 volts across the outer two pins. But the watch does not vibrate upon connecting the cable. Also Bangle.isCharging() shows false.

    I updated to 2v16 before it completely drains. I turned it off so to save some juice. Is there anything else I could be checking?

  • I guess you might've tried already, but what happens if you install a battery widget and leave the bangle with charger connected?

  • I left it plugged in over night, nothing happened. Battery widget still low and E.getBattery() still shows 7%

  • Gordon,
    Has there been a determination what is causing the button problems, and has the manufacturer found a way to stop this from happening? Perhaps an improved mounting "pocket", or a different button manufacturer? This type of thing might make people nervous about buying the watch.

  • @Raik sorry to hear that - do you still have the tap over the middle two pads?

    Also, have you tried a different USB charger? I've had a few cases where users have had problems like that then they changed their charger and it was fine (I think some chargers require some resistance across the middle two pins or they never provide any real current).

    @Max_S I've contacted the manufacturer and they've added extra testing steps during watch assembly to ensure that the button PCB is seated properly and that the gromits for waterproofing are in there and lubricated. After the initial KickStarter batch there really haven't been many button failures at all - most of the rest appear to be water damage.

    The issue is that 90% of all failures I come across get reported publicly on the forum. Around 6000 watches have shipped so far, and regardless of how good quality a device is there will always be some failures especially on a device that is worn every day.

    Right now we're seeing well under 2% failure rate, which as far as I can tell is actually quite good for something like this (of course someone like Apple would never publish any stats). The problem is you go to a thread like this and see a bunch of reports, and because I'm trying to be open with what I do, I don't delete them :)

  • do you still have the tap over the middle two pads?

    Also, have you tried a different USB charger?

    I pealed off the sticker for testing purposes but to no avail. I tried several charges, all of which worked just fine with the previous Bangle2. Still no luck. I probed the outer pins with my bench power supply, the watch does not draw any current. :-(

    The battery has completely drained now and I can't get the watch running again. I even tried the jump start method mentioned here.

    I guess luck is not on my side...

  • I guess I'll have to arrange another replacement then :(

    Did you ever force the charger onto the pins the wrong way round? (against the magnet's force). There isn't reverse voltage protection on the pins (because the manufacturer assume the charger would never go that way unless it was deliberately pressed on) so that could have broken the charge IC I guess.

  • Did you ever force the charger onto the pins the wrong way round?

    No, I have a charging cradle and the watch only goes in one way. I did not touch that when switching from the old Bangle to the replaced one. I am really sorry for bothering you again with this. Maybe third time's the charm... :-/

  • Ok - Christine will be in touch. It would be interesting to get the broken one back and see what's wrong with it though :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Bangle 2 button no longer works - feels soft when pressing

Posted by Avatar for krytten @krytten

Actions