Can't connect to BangleJS 2 Watch

Posted on
of 2
/ 2
  • ...or the bluetooth stack on the device you're using to connect to the watch is stuffed up and needs resetting. Happens far too often on my Sony Xperia phone and even a couple of times on my laptop. Have to turn the whole thing off and on again before anything works.

  • I'm at PRECISELY the point @rkoutnik reached. I'm about ready to throw this in the bin that's already full of 'smartwatches' that fail me. It's lovely lightweight comfortable battery life, but nothing I can do will get a connection and I'm still convinced it's me doing something wrong or using incompatible android or whatever. Is there a super-simple babysteps do-this-then-that for actually getting the first connection and what to expect at each step if it's being done correctly?

  • @CliveBagley

    1. Do not pair your device with the watch from the Bluetooth menu! If you've done so, remove it and try again directly from the web browser or the Gadgetbridge app.
    2. Make sure the watch is connectable (it's in the settings app).
    3. Use a Web Bluetooth-capable browser (so pretty much Chrome or other Chromium based browsers, I use Vivaldi on my Android device). If one doesn't seem to work, try another. Only one I've managed to get working on my Linux laptop is Chromium. If you're using iOS use the WebBLE app to open the App loader.
    4. Go to and click the connect button.
    5. Pick your device in the window that opens up and click pair.
    6. That should be it and if connected you can manage the apps on your Bangle.

    That's exactly what I did with the watch coming straight from the box and it worked without any hiccups.

    Things to try if you still can't get things working:

    1. Make sure no other devices are connected to the watch already. Only one connection at a time.
    2. Make sure you haven't paired the watch to your device through the Bluetooth menu. If so, unpair and try again.
    3. Reboot the device you're trying to use to connect. Bluetooth stacks can sometimes need a bit of a refresh.
    4. Try connecting with a different device.
    5. Try different browsers.
    6. Check if you can connect in DFU mode (firmware update mode). Follow the instructions here (although the instructions reference BTN3 @Gordon, and I've never had to press any button when the update is complete since the watch reboots by itself). If you can find the DfuTarg device in the list when selecting devices Bluetooth works.

    I'm sure I've missed something, but that's somewhere to start at least.

    Edit: updated the list with info from the posts below.

  • HEY! Whatever you did there worked. Stupid as it sounds I thought I had covered everything and after carefully reading your post it now works. Whatever you did I'm grateful for!

    It might be worth going to babysteps like this in the official documentation. Point out that it's not connectable by USB (as I had naturally assumed) and that it only seems to work on some BlueTooth hardware (certainly not the CSR dongle I have in my workstation) and that when using an android phone you absolutely should not try to pair it in any conventional sense and if you did (or tried to) then delete it all and reboot both devices before you try again.

    Thanks a million for helping!


  • I also struggled to get my watch to connect for the first time. I tried reading through as much as I could find and eventually figured out I had made an unintuitive mistake.

    The first thing I did when I got my watch was try to pair it through the bluetooth menu of my android phone. Apparently this is enough to block connections with the Gadgetbridge app. I had to go into my bluetooth menu and manually unpair the watch, and then Gadgetbridge found it immediately.

  • Glad you got it sorted! I've tried to update the FAQ in the wiki at­iki

  • It took me some time to get the Bangle.js 2 to connect to my devices. Here is what I did (maybe these are a few more things to try if your watch cannot connect):

    To connect the Bangle.js 2 to my Desktop computer (with Debian Bullseye) I followed the steps in the documentation (­n+Linux) but the watch didn't show up as an option to connect to. In the end the solution was simple: Put the watch next to the computer (within a range of a few cm) and it shows up and everything works.

    Next I tried Web Bluetooth with an Android device. It didn't work at first. The device only showed up after connecting the watch once via the Bluetooth system settings and then removing it again. Since then it works well.

  • Hi @Gordon

    I tried everything to connect to my BangleJS 2 Watch.

    App Loader: iOS (iPhone and iPad) with WebBLE
    App Loader: MacOS with Chrome
    App Loader: Windows 10 with Chrome
    Espruino Web IDE: Windows, iOS, Mac

    I checked afterwards if I could find a bluetooth device with the DfuTarg tag, via the "nRF connect" and the "nRF toolbox" app on iOS. There are devices listed but none with the tag or the Bluetooth mac address of my watch. I tried this also with the watch in DFU mode.

    I rebooted the Watch in-between these steps and also the devices. I turned Bluetooth off on the other devices, to be sure, that they wouldn't connect and block the connection.

    I really hope that I am missing something here.

  • Thanks for trying all that! When the Bangle is running normally,is the Bluetooth icon in the top right blue, or grey?

    When you checked for the 'DfuTarg' device, had you put the Bangle into bootloader mode?

    If you move your phone really close to the Bangle, do you get any connection?

    Obviously if there is an issue I will replace your Bangle, but it does seem unlikely to be a hardware problem since we specifically test the Bluetooth before sending them out.

  • Thanks for your quick reply!

    The Bluetooth icon is grey the whole time. And I turned bluetooth off on the other devices, while trying to connect.

    I tried to "find" the watch in DFU mode as it is mentioned here­ware-updates , which is the bootloader mode right? The display then only shows two lines

     BTN1 = REBOOT

    I was then pressing the refresh button in the "nRF toolbox" or "nRF connect app" to make sure that I am really searching for the watch while it is in DFU mode, but it wont show up, nor the tag or the Bluetooth Mac address from my watch.
    I laid the watch directly on the front and also the back of my phone and my iPad without success.

    I wanted to check later if i could see the watch with the WEB IDE running on a raspberry pi zero w as mentioned here­b+IDE

    If there is something else that I can try I will happily do it.

  • Ok, not sure if this was mentioned above because TLDR ;-) but I just stumbled upon this:

    If you connect GB app the first time, Android will ask whether to pair to the watch (at least for me it did). Now from that point on GB will work, but the phone will also appear in Androids list of BT devices as paired.

    If you some reason you reset or reinstall the GB app on the phone, you will not get it connected again to the watch unless you explicitly remove the pairing in Androids list of BT devices. Maybe that helps out someone.

  • There's a setting for that in Gadgetbridge: "Ignore bonded devices". If a device is already paired it won't show up when scanning. Enabled by default.

  • @johan_m_o thanks - that's really interesting - do you know the reasoning behind that? It feels like it'd be quite confusing for most people.

    @user137465 I'll drop you an email and arrange a new device - definitely seems you've tried everything, I'm just amazed this is happening. I've shipped 20,000+ bluetooth devices with nRF52 chips in, and these Bangles are the first where Bluetooth has just spontaneously stopped working on some devices.

  • @Gordon I have no idea... Only discovered this setting myself a couple of days ago.

  • I tried the above suggestions, but they didn't help me fix the Bluetooth on my Bangle js 2. Any new ideas?

  • Can you explain what's not working for you? If you follow the steps for DFU mode at­#nrf52 can you see the bangle appear as a device named DfuTarg in the DFU app?

  • It just says "The requested URL was not found on this server."

    1 Attachment

    • IMG_3373.PNG
  • I believe you need to download the firmware update zip on your phone first?

    I guess maybe the first step might be to install the 'NRF Connect' app on your phone and see if that can see a define named DfuTarg when the Bangle is in bootloader mode (showing the large, blocky text on its screen)

  • I can't see DfuTarg on NRF Connect on my iPad

  • I can't see DfuTarg on NRF Connect on my iPad

    And is the Bangle definitely in bootloader mode (saying something like the following on the screen):

    BL 2V20

    Bear in mind it will reboot after 30s so if you don't have NRF Connect scanning while the watch is showing that screen, it won't show up...

  • yes, except it only says


    it doesn't say BL 2v20

  • Ok, in that case it does sound like a hardware issue. How long ago did you purchase your bangle?

  • My mum gave it to me for Christmas in 2022 (purchased 15/12/22)

  • Ok, thanks - I'll send you an email in a few minutes

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Can't connect to BangleJS 2 Watch

Posted by Avatar for rkoutnik @rkoutnik