Can't connect to BangleJS 2 Watch

Posted on
of 2
/ 2
  • Whatever I do, I can't get any of my other devices to find my new watch.

    I've tried:
    Gadgetbridge on Android 12 (Pixel 6)
    App Loader (MacOS 11.6.1 (20G224), Chrome 95.0.4638.69)
    Web IDE (MacOS 11.6.1 (20G224), Chrome 95.0.4638.69)
    App Loader (Windows 10, Chrome 96)

    In all cases, the watch never shows up as an option to connect to. The bluetooth icon is grey (so nothing's connected and blocking new connections). I've selected "Make Connectable" more times than I can count. I've tried rebooting and/or resetting the watch.

  • Hi,

    Wow, that's extremely surprising - for every Bangle we connect via Bluetooth when testing so Bluetooth definitely was working.

    Please can you try­tting-without-loading-any-code ?

  • Got to the screen with the logo and MAC address, tried to connect again (from the apps page), no luck.

    It could be a case of PEBKAC, here's what I'm doing:

    • On watch: Settings > Make Connectable
    • Leave watch on the "Connectable" screen
    • Browse to
    • Click "Connect"
    • Browser dialogue pops up, scans, finds nothing

    Is there some way I can test the Bluetooth on the watch?

  • Is there some way I can test the Bluetooth on the watch?

    you may try nrfConnect­ls?­=US and check if you see it in the scan

    you can also follow the guide linked above but at the step
    "Keep pressing the button while ==== goes across the screen"
    you can release button when in the middle.
    This should stay in firmware update mode for a minute or so. Again check in nrfConnect, you may see it as DFUtarg device. This may work even if there is something wrong with Espruino firmware.

  • Good call, installed nrfConnect on my Pixel 6, found lots of devices but was unable to see the BangleJS (going by the bluetooth debug addr in the header bar). Same when in firmware update mode.

  • the nrfConnect scan times out and won't search for new devices after that so if you entered dfu mode after scan ended you may not see it, so close and restart app again or click scan on the top again. Also if you really see lots and lots of devices then moving to some other area might help too. Otherwise this really looks like something may be wrong with the watch.

  • Yup, hit rescan after entering DFU mode, didn't show up.

    Argh, was hoping this was something on my end.

  • Could your Bangle already be paired to any other device (your phone for exemple), avoiding the others (webIdE, gadgetbridge, …) to connect to it ?
    I’ve had the same case with mine, as my phone was paired to the Bangle without i noticed it. I had to turn off BT on my phone for it unpair… and then only i could connect to webIdE

  • Wow, ok. Does NRF Connect see any bluetooth devices, or does it see a bunch, but just not the DfuTarg one?

    As I say, we actually upload test code to them via Bluetooth here so if it's not working all I can assume is it has somehow broken in transit. It'd be the first time in over 7000 watches this has ever happened as far as I know :(

  • @nicoboss I believe the bluetooth icon changes to blue when it's paired, it's consistently grey for me.

    @Gordon yup, it sees other BT/BLE devices, but not the Bangle.

  • in my case, it wasn't

  • No luck there either, BT off on phone, couldn't find it with the app loader

  • Leave watch on the "Connectable" screen

    you should get a Yes / No dialogue to make the watch connectable.
    Once you have responded Yes. You can exit the settings app.

    Its also worth checking that the watch has not paired with GadgetBridge.
    Go into the watch settings app. Select App/Widget settings.
    Select GadgetBridge and check that it says Connected NO.

  • If every other component works (including display, gps, touchscreen) then mechanical damage during transit looks unlikely, well maybe if antenna fell off, that could happen (didn't see inside of this watch, is there short wire?). Can you try to put it directly next to the phone? Also I'd let the battery fully discharge, that sometimes helps in strange cases. Still, this doesn't look normal at all.

  • @HughB I haven't been able to install the GadgetBridge app

    @fanoush Display/Touchscreen work, haven't been able to install an app to test GPS & other sensors. Shipping damage doesn't sound likely, it was packed well.

    I'm still half-convinced I'm doing something wrong.

  • if you see the DFU START message after releasing button before the bar goes fully to the right and you don't see it in nrfConnect scan as DfuTarg device and see other devices then it indeed looks like something is wrong with bluetooth signal transmission because otherwise the software thinks everything works. and this is Nordic DFU bootloader, Espruino is not running at this time. If e.g. the 32khz crystal (that provides bluetooth timing) was broken or missing it would not even start.

  • Here's the watch at reboot time, nothing shows up starting with C1 (the Bluetooth MAC) in nRF

  • Sorry - I don't see a screenshot there...

    As @fanoush says, getting the phone and the watch right next to each other would be a good idea. Even if the antenna somehow came disconnected in transit (there is a string contact from the PCB to the antenna) you should be able to see it with your phone (just at very low signal strength).

  • Screenshot shows the watch displaying:


    No luck placing it directly on top of the phone. Tried it with my laptop too and accidentally discovered the magnet in the watch can trigger the "Lid is closed" sensor on my laptop! No signal in either case.

  • Trying to eliminate possibilities here. The header bar on the BangleJS watch says c1 b6, I've been assuming that's the first/last of the Bluetooth MAC address. nRF does now show any devices that start with c1 - that's been my assumptions, is there any possibility I'm mistaken?

  • Those are the last two tuple of the MAC address. It's from the Bluetooth ID widget.

  • good to know, I checked the MAC address in the About app, and c1 is both the first tuple and second-to-last, odd coincidence.

    In any case, the MAC doesn't show up in nRF.

  • Ok, thanks for looking into all this. As odd as it seems, I guess maybe there is some kind of bluetooth issue with your device. I'll drop you an email and we'll arrange a return

  • @Gordon
    I'm having the same issue as @rkoutnik, I have sent you an email with the details.

  • Hi - email sent. To anyone else looking at this, please try some of the things mentioned above - we test the Bluetooth connection of every device before sending it out, so it seems amazingly unlikely that a problem with Bluetooth would have developed during shipping.

    Also: If you've been able to connect to your Bangle in the past, and now can't it is hugely unlikely to be a hardware problem. It's much more likely that you have some other device that is staying connected to Bangle.js and is stopping you connecting with the device you're trying to use.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Can't connect to BangleJS 2 Watch

Posted by Avatar for rkoutnik @rkoutnik