Bangle.js 2 can't charge?

Posted on
of 2
/ 2
  • So my Bangle.js 2 ran out of battery this morning. No biggie, except now it doesn't seem like it wants to charge anymore.
    I tested the contacts on the charge cable, and I see 5.25V across the 2 outer ones.
    No voltage across any of the contacts behind the watch, and the third one (counting from the button side) is slightly corroded.
    Watch has a black screen and is unresponsive when I press the button.

    Any way I can force it to charge?

  • Had you been able to charge it properly in the past?

    I'd say make sure you give the contacts a wipe with something to ensure they are clean. Also, just in case, put the Bangle in your pocket for a half hour or so before charging so the battery warms up.

    It may be you need to press the button to make it start up after you've charged it for a while.

  • Had you been able to charge it properly in the past?


    Contacts seem pretty clean, except the one that's a bit corroded. I was wearing the watch this morning, so it wasn't cold either, and my office is at 23°C; I don't think the temperature is an issue.

    How long should I press the button? I've tried holding it for 30+ seconds, to no avail. Watch has been plugged in for the last ~4 hours or so.

  • Ok, that's an odd one. Just 1 second should do it, or if the watch had crashed, 10+ seconds would reboot it.

    However you say there's no voltage across the watch contacts? What about the middle two? That actually seems to be a good way of seeing if there's power on the watch - if there is no voltage there then the CPU isn't powered at all and it could be some kind of battery failure.

    Did you see the watch battery level getting low? I'm just wondering whether something other than the battery running flat caused the display to go blank... Had you got the Bangle quite wet at some point earlier?

  • Yeah, the battery was getting low over the last few days, I was planning on charging it yesterday.

    No voltage across the middle 2.

    I did take my shower with it, but it was far from the first time (did it almost every day for the past ~month since I got it), and the watch wasn't submerged. I searched the forum about that, and my watch seems to have the white membrane in the hole under the wrist strap. I really hope it's not water damage, any way I could try to rule that out?

  • Sorry for the delay - honestly it's hard to know, but I'd find it hard to believe that a shower would cause it to get wet inside.

    If there's no voltage on the middle contacts then it sounds like a battery issue, since even if the Bangle CPU wasn't working you'd expect to see 3.3v there.

    If you haven't already, please could you try giving the contacts a wipe over with a cloth? It might be some of that corrosion is stopping it being powered properly - also just trying to get it properly warm (like 40°C or so) might make the battery more willing to take charge. You could also try a different USB charge just in case for some reason that wasn't supplying enough current.

  • Thanks for the tips, but none of them worked. I don't have a separate cable to test charging with, but as I mentioned in the first post, I looked at it with a multimeter and it seemed fine.

    I did try another USB power brick, and still no luck.

  • Ok, thanks for trying to fix this. Looks like you might need a new Bangle then. I'll drop you an email.

    It may well be another week or two before I can send one out as I'm waiting for a new batch though.

  • Hi, i am having the exact same issue. Doesn't seem to be charging. I am getting voltage through the wire but nothing on the watch. I am going to leave it on overnight. its been on the charger 3 hours already.

    i can give you my email if needed.

  • Hi @kenp was your Bangle charging in the past, and now it's not? Or has it never charged properly?

    What do the contacts on the rear of the watch look like? Are they clean, or do they seem corroded slightly?

  • No corrosion.
    Left on the charger all night. I will try some additional time with another charger block.

    1 Attachment

    • 16421720238282919717580286562059.jpg
  • As @Gordon said, did it charge previously and now stopped? Or has it never charged?

  • o the contacts on the rear of the watch look like? Are they clean, or do they seem corroded slightly

    1 Attachment

    • bangleback.jpg
  • ...also, it has charged twice since I received it. No problems then.
    No corrosion. I was getting low on charge and was deleting some clocks and playing around with my own clock face that I'd been working on.

    I haven't actually worn it for more than a hour or 2 as I'd been trying to learn the IDE and how to code a watch face. Mostly its been sitting on my desk.

  • @kenp What's the result if you connect to the Web IDE while connected to the charger and enter Bangle.isCharging() on the left side?

    Or is it completely dead?

  • Is it me, or is this pin slightly shorter? Maybe it's gripping?

    1 Attachment

    • 2022-01-14_14-09_1.png
  • Good eye! Maybe it's not reaching the charging pad... Would definitely be causing problems.

    Let's hope it's that easy.

  • I will check that and post a reply later today.


  • Sorry for the time delay, Iwas on vacation for a week.

    Pin does seem to be not "springy" enough to come out as far as the others.
    but, I think its still making contact and the watch is still not charging.

    Were these guaranteed for some amount of time? If so how do I get a replacement?

  • @kenp yes, I am guaranteeing them. I'm finally expecting the new shipment of Bangles on Thursday so I'll get in touch soon after about getting a replacement out

  • Thank you so much!

  • I'm having the same issue with mine. Charged fine the first couple of times but it's been connected for an hour now and no juice.

    Checked the contacts and everything is clean. Could it be a battery issue?

  • Is the Bangle completely off now?

    Have you tried holding down the button for several seconds? There have been a few people recently complaining of issues, and it's just been because when the Bangle is flat and power is applied it no longer automatically boots. You need to hold the button down for get it to turn on.

  • Yes it's off now. I've tried holding the button for almost a minute and still no boot.
    Could it be the cable?

  • It's possible... Do you have a volt meter? If you could check the outside connections on the cable to see if there's a voltage...

    How long have you had your Bangle? Sounds like not that long?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js 2 can't charge?

Posted by Avatar for user137752 @user137752