Bangle.js 2 can't charge?

Posted on
of 2
/ 2
  • I don't have a volt meter unfortunately. I bought the watch in March and I was able to charge it at first. I then powered it off when not using it but since then I haven't got any charge.

    I've tried different power bricks but all the same.

  • Ok, so basically you powered it off a while ago, and now it won't power back on at all?

    Or did you have it at a point where it was actually running, but not charging at all?

    I've just been trying with some devices here that got returned as having the same issue you have, and I've found it's possible to 'bootstrap' them. Please could you peel off the tape that's over the middle two contacts on the back of the Bangle?

    It's possible that just applying the charge cable with those contacts showing will be enough to bring the Bangle back to life (maybe try some different chargers now those contacts are uncovered), but if not please can you try this?­B7Q

    Sorry for the inconvenience. I'm still not sure what causes the issue, but if it can be solved at your end pretty quickly it'll save all the effort of having to sort out a return.

  • Still no luck. I tried with a 3 volt battery from a remote and it didn't boot it. Also tried charging with the tape removed and all pins exposed and with different chargers, but still nothing.

  • Ok, I'll ask Christine if she can sort out a replacement for you.

  • Thanks, I appreciate the help and quick responses.

  • Had the same issue, it was not charging.
    Jump starting the watch did the trick. Thank you so much.
    I was so sad that my bangle was broken. I'm loving this watch!!
    Thanks @Gordon. ❤️

  • Great! Glad that fixed it for you! I'm still not 100% sure why this happens - I haven't had call to do it since making that video - but at least it works in some cases :)

  • The watch turns on, but it's not charging anymore :(
    When I remove the power cable it runs for some seconds, but then it dies :(
    Is there any trick to revive the battery?

  • Argh, that's a shame. What do the contacts on the rear of the watch look like? Are they corroded?

    Have you tried using a different USB charger?

    Also, if you have a volt meter it'd be worth checking that there's voltage on the outer two contacts of the cable - it might be that the charge cable is broken?

  • The contacts are not corroded, I already cleaned them.
    The usb cable is ok, I can read 5V on the pins. I also have used a different cable, connected it directly to 5v and still not charging.
    E.getBattery() returns "2" and analogRead(D3) returns values around "0.25".
    Any idea what can be wrong?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js 2 can't charge?

Posted by Avatar for user137752 @user137752