Battery drain after factory reset

Posted on
  • Greetings!
    Recently, I made a post here regarding a problem with booting, which was solved by factory reset. But, following that, the battery started draining very fast (it would drain completely in less than a day). As, after factory reset, I installed apps I usually used, I thought that some of them might be the cause. However, even after a second factory reset, after which I only installed Gadgetbridge, the battery issue persisted. As you can see in the attached screenshot, the battery discharged down to 20% in just about 16 hours.
    @Gordon, do you know what can cause this? Thanks!

    1 Attachment

    • 0-02-0a-c03000b27478502bde60c5b4af0a0aea131f7a7d81e18bb4952d8efec3c16850_1f80abb864f711.jpg
  • There's an option to 'Calibrate battery' under Utils in the settings on the watch, have you tried that?

  • I have tried that after fully charging the battery, but it didn't do anything, unfortunately.

  • Can you post your list of installed apps? The apploader shows it on the bottom of the More... tab when it is connected to the bangle.

  • Here are the apps installed:

    health, widlock, widbat, widbt, widid, welcome, sched, alarm, boot, launch, antonclk, about, setting, messages, android

    As I've said. after the last factory reset I've only installed "messages" and "android" apps. But I don't think that the problem is with the apps, as before that factory reset everything worked fine, and the battery would last for 2 weeks for me.

  • That is a strange one - and after the factory reset, did you leave all settings on the device the same?

    To flatten the battery in 16 hours the Bangle has to be drawing 10mA average, which is quite a lot. Do you see the screen spending a lot of time turned on? I know for some people the Wake on Twist setting (on by default) can end up lighting the screen up a LOT and reducing battery life.

    If your Bangle isn't connected to Gadgetbridge, do you see the same low battery life?

  • Hi, yes, I tried leaving all the setting the same, I tried turning off both "Wake on Twist" and "Wake on Touch", and I also tried removing all the apps except for boot, launcher, and info without connecting to the watch with bluetooth - the result is the same - it's very strange indeed. One thing I have noticed is that, while the watch is at 15% currently, E.getAnalogVRef() shows about 3.305 V. I don't know how low it should get, but shouldn't it get lower than that at such a low charge percentage?

  • I can confirm that this is happening to me as well.
    I charged 27th october and it lost all of its charge overnight and was down to 3% saturday morning.
    I recharged saturday and it was on the high 90's yesterday and was on approx 97% last night.
    92% this morning and is now draining quickly as of 13:00 on 69%.
    I've disconnected from Gadgetbridge to try to conserve power but it makes the Weather Clock a lot less enjoyable.
    fw version is 2v15.78

  • E.getAnalogVRef() is a bit confusing as that's the voltage regulator voltage - so it'll stay more or less constant 3.3v until the battery completely dies (although I believe the cut-off for the battery is ~3.3v) . analogRead(D3) is what you need, but that doesn't give you a value direct in volts so it's not that handy.

    What I'm starting to wonder now, is did the watch originally stop working after something in particular? The only other time high power draw would happen is if the watch has got water inside it (especially salt water) - and that would explain it stopping working in the first place too.

  • Nope, the watch never had any contact with water or anything else at all. It just randomly froze in the middle of the day, after which I did a factory reset.

  • Hi @Chasolla - can you remember if anything changed? Did you update watch firmware? update apps?

    And have you tried resetting it back to factory defaults to rule out an issue with the apps? You can do a 'backup' from the app loader first to ensure you keep everything as you had it.

    @user150445 please can you try disconnecting from Gadgetbridge, connecting with the Web IDE, pasting the command Bangle._PWR into the left-hand side and seeing what it says? It may just be ={ } but if there's anything in there, that would be very interesting.

    It'd also be good if you could try leaving the Bangle disconnected from Gadgetbridge and see if the power still runs down as quickly

  • Bangle._PWR is undefined for me. Do I have to enable it somehow?
    And I tried leaving the watch disconnected from everything—didn't change anything.
    Also, I seem to have misremembered when exactly the battery problem started; I checked the battery log (relevant part is attached as a screenshot), and it seems that

    1. I was charging the watch the day the issues started
    2. After I disconnected the watch from the charger and until it froze, the battery was also rapidly discharging
    3. After I rebooted the watch the discharge rate was normal, and, even after the factory reset, it was normal for more than a day; only the night between 22.10 and 23.10 it started rapidly discharging—seemingly randomly.

    1 Attachment

    • battery.png
  • Bangle._PWR is undefined for me. Do I have to enable it somehow?

    No, that's fine. It just shows that no apps have requested that any hardware is enabled on the watch.

    Thanks for the battery log - that is very strange indeed. It does seem like there may be some internal hardware issue then - outside of the GPS and backlight being on there's not much that could draw power that quickly.

    I'll ask Christine to get in touch about a replacement.

  • I am a Kickstarter backer so my watch is one of the original batch.

    A few days ago my battery graphs looked just like those posted by user 150445.

    I have a very old laptop with no bluetooth so can't use the web IDE on that. One day I'll get to grips with it on my phone but it doesn't seem to like my browsers of choice, more likely user error. I'll have to try a browser that is more vanilla but I try to avoid Google's spyware as much as I can.
    Brave might be worth a try.

    Since then I have updated to 90, removed all apps and reinstalled my old favourites,
    Since charging on 1st November things have returned to normal and the Bangle is currently showing 90%.

    So I'm happy again.
    I'm pretty sure that it was one of the apps causing the excessive battery drain.
    I haven't a clue what it was so I apologise for this less than helpful post.


  • @Chasolla yes, in 99% of cases, excessive power drain is going to be some app or setting that's been changed. Either having GPS on all the time, backlight on, or some apps which may scan constantly for bluetooth devices.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Battery drain after factory reset

Posted by Avatar for user150445 @user150445