Frozen on first day

Posted on
  • Hi,
    a couple months ago, my son has developed the wish to buy a fitness tracker. As I don't like the concept of closed tracking devices I told him about Bangle.js 2 and he was fascinated. Since then, he was saving money and was finally able to order the watch a couple days ago. When he saw the parcel deliverer, he ran straight to him and was very happy. He unpacked it immediately and proudly started exploring his new smartwatch... :-)

    Unfortunately, the watch froze on the first day and I couldn't help him yet. It always shows the screen I attached. I tried to reset but it did not work. I also measured the current between the middle pins and it is 3.3V. Current between outer pins is 11.3mV.

    I tried to connect it to my phone but that also failed.

    Any ideas on how to proceed?


    1 Attachment

    • 20220823_211818.jpg
  • Did you try a long press (press button for ~10sec).
    Release immediately after you see the "watchdog" screen - before the <==== appear (if you are too late, no problem - just repeat).
    That should reboot the device.

    If you run into the same problem again, you may check the "more" tab at . There you can remove all apps and install default apps.
    You can always install apps again later after you see hardware running ok with the basic apps.
    If you search for "firmware" in the library tab at above link you can also find the firmware updater there.

  • Thanks, but nothing happens when I press the button for 10 seconds.

    When I open I can not connect to the watch. So I guess that updating firmware is not possible...

  • According to the picture the battery was very low. Did you charge it since then?

    But sorry then I am not expert enough to help here.
    The ultimate expert @Gordon is in vacation right now (­376356/#comment16540081),
    but hopefully somebody else has advice earlier.

  • Sorry, forgot to mention that we tried to charge multiple times.

    I even warmed up the watch to around 40 degrees before attaching the charger once. Also tried multiple charging devices. Current between both charger pins is 5V.

  • One thing of course is to wait for the battery to run out, then connect the charger and power on the bangle. That seems like the only way for you to reboot it and hopefully it will not freeze again. Maybe don't charge it too much in case you have to do the same thing again.

    Then when it's up and running I would try what @Mi suggest regarding apps and firmware via the app loader.

    Maybe you can find some useful tips from @Gordon in this thread as well.

  • Is it really frozen, i.e. the clock shown does not change over time? If button does not work then it looks like button may be broken as holding it should cause reboot. This cannot be prevented (by e.g. some software bug/lockup) when the button hardware works.

  • When I open I can not connect to the watch.

    You are trying this from android phone or PC with Chrome? If PC then try also from phone. Do you see 'bangle.js wants to pair' pairing/scanning dialog when you click connect and nothing is shown or the watch is shown in the list but you cannot connect to it?

  • Hi - sorry to hear this - that's an extremely strange fault... And the screen never changes at all? Is the backlight on?

    Was there anything that you can think that happened that might have brought this on?

    The really odd thing is that the firmware includes a watchdog timer, so virtually nothing should be able to stop the watch restarting when the button is held down.

    All I can suggest right now is to try running the battery down fully - if the backlight is on that should only take an hour, but without it on it could potentially take quite a bit longer.

    I'm on holiday this and next week, but of course I will ensure that if we can't get the watch working it is replaced.

    1. The screen is really frozen. It never changes and the backlight is off.
    2. Pressing the button does not change anything. No matter how long I press it.
    3. I tried connecting from my android phone but my mobile does not detect the watch. Only a progress spinner is shown when I click on connect.
    4. When my son received the watch, he was using it to measure his heart rate. He later changed the theme to a black background and also charged the clock for an hour or so. After some time, it froze. He tried to press the screen and button afterwards. But nothing changed since then. I did not observe him the whole time but the clock looks perfect. I also asked him if he fell on it or so but he did not.

    We will wait until the screen turns black and try to charge it, then.

    Gordon: No worries, things like that happen. Enjoy your holidays! We bought it from berrybase as we live in Germany. We can return it there in case it is broken...

    Thanks all for your kind help!

  • Hi @map

    would you please send me an email to We can sort out a replacement directly.


  • Sure, I will. Thanks a lot!

  • Just wanted to report back that the watch turned off in the mean time. After charging for two hours, it works again. What puzzles me a bit is that the button seems to work fine now. A long-press also leads to a reboot... :)

  • That's great - thanks for the update!

    It's a very odd fault, but it looks like somehow the CPU totally locked up (to the point where even the internal watchdog timer wasn't working). I can't remember ever seeing that before.

    Hopefully it's a one-off, but let us know if it happens again and we can get it replaced.

  • the CPU totally locked up to the point where even the internal watchdog timer wasn't working

    could be it rebooted and bootloader then faulted into neverending loop before starting watchdog again (spurious interrupt, cpu fault?) or it was started but still there could be some hang and watchdog reboot loop in bootloader before screen is initialized. Anyway, hard to reproduce such thing.

    Maybe the watchdog initialization­b/master/targets/nrf5x_dfu/main.c#L206 could be moved earlier, the nrf_dfu_enter_check may be called late at startup. Could help or could just cause watchdog reboot loop without helping much.

  • could be it rebooted and bootloader then faulted into neverending loop before starting watchdog again

    Could be - it's possible that if the battery was basically flat it could have dropped out (resetting the Bangle) then come back and then the CPU locked up because of the low voltage.

    It's a good point about moving the watchdog init code - I think I didn't have it earlier because I didn't want it to interfere with Nordic DFU's usage of it, but in a way it doesn't matter.

    I'd be a bit worried about changing it because of one potentially freak event, but if this happens again - to @map or anyone else - I'll get it changed

  • Just wanted to report back that my son is using the watch now since two weeks without any problems. He is very happy and is still exploring and trying out apps.

    His friends also like it! It looks like the bangle.js is a perfect gift for tech-savvy kids from 8 years old or so.... :-)

    @Gordon thanks again. What you are doing here together with Christine and also the community is perfect customer care!

  • looks like the bangle.js is a perfect gift for tech-savvy kids from 8 years old or so

    I hope it can bring some of them to programming. Coding the app in javascript is relatively easy and you can see the results quickly. I hope they can have a fun while being creative and learn something at the same time :-)

  • That's great, thanks for letting me know! It's great to see this stuff inspiring people to play more with technology.

    I've got a Bangle.js 1 with a Smartibot and my son (5) enjoys using it as a remote control for the robot - but he's not yet too interested in the watch itself. Hopefully soon!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Frozen on first day

Posted by Avatar for map @map