Can no longer connect to my bangle.js 2

Posted on
of 3
/ 3
  • Ok, thanks - If you can't see DfuTarg when in bootloader mode in NRF Connect I guess it's likely broken hardware. I'll ask Christine to see about getting a replacement out to you.

  • Replacement arrived and connected without issue. Thanks for the fantastic service. (I also checked the bootloader steps above on the new one and that also worked) so must have been a hardware issue.

  • Ok, great - glad you're sorted out anyway!

  • Hello,

    I have now a similar problem...
    right now i'm on vacation, so a bit time here and thereto play around and rule stuff out, but cornerpoints are:

    • Without noticable reason no bluetooth connection possible
    • booting into dfu/no code mode most of the tries does not help
      dfu mode and updatefrom 2.14 to 2.15 finally worked using the web ide, but was not visible in NRF toolbox/NRF DFU thingy

    • sometimes a factory reset helped, and sometimes gadgetbridge was at some time able to get a more or less long connection (noticable because time got synced)

    • i got it so far working that I could use the apploader to upload my apps (LCARS, android/messages quitemode and some others)
      it worked for a bit but is broken right now, not visible in any case/mode at the moment

    • will try tomorrow again with different phone which I used for succesful firmware upgrade

    • i'm away from home,so tomorrow I will disable any devices we have with us and have bluetooth, but if I understand right the only critical would be devices which were at some time paired to thewatch using BT oder gadget "just have bluetooth enabled" devices...

    right now my only explanation for this erratic behaviour is a hardware error, but I'm willing to try a more systematic approach if you guys have ideas others than go in to DFU/no software mode...

    the watch of my wife currently is still working

    another point:successrate was better after reboot of the phone used for flashing, but also no consistent results using reboots to get a connection *sigh *

    so long greetings,

  • Hi - sorry for the slow update - I was away the last 2 weeks.

    Any success? And when did you get your Bangle? Recently, or from the KickStarter?

    It's a hard one to pin down, but in general if you:

    • Restart the watch into DFU mode
    • Start the NRF Connect app and scan for advertisements
    • Don't see CONNECTED on the watch screen (and it hasn't rebooted)
    • Can see other Bluetooth devices listed on your phone, but no DfuTarg

    Then it's probably a hardware error. If you're doing this and you squeeze the top right of the watch and then it appears in the list of bluetooth devices then it's almost certain it's a hardware error

  • Hello Gordon,

    thanks for the reply.
    No, no improvement yet...more the other direction. I will try again the squeezing a bit later. But right now it did not connect or show up anywhere. When I wrote the post above there were some chances to get at least half a connection every now and then. Right now it was completely dead.

    But what you say with the squeezing matches with my obersavations back then. If there is a chance I can squeeze bluetooth on, this would explain why it worked so erratic.

    Can you explain a bit more how/where I should sqeeze to get better chances?

    As for the other question: It was one of a "2-watches", blue Kickstarter Bangles which got sent later to Germany because of the customs problem, and has also all 4 pins exposed (ok, mine right now with a bit partly removed nail polished on the center two :o) ).
    So I would say a rather early bangle js 2.


  • Can you explain a bit more how/where I should sqeeze to get better chances?

    Just pinch between the top right of the screen and the back of the watch - so conveniently where the bluetooth icon normally is!

    But thanks - this definitely looks like another hardware failure that we'd replace for you.

  • Has anything new been found on this
    I have a watch in the same situation
    when booted blutooth grey
    does not seem to show up on BT scans
    but on boot shows blutooth and bt macaddress

    I also tried factory reset

  • Hi,

    can you enter the settings menu and double check if the Bangle is connectable
    (Settings->Bluetooth->Make Connectable)


  • Yes I tried the above before posting.

    Was working fine last week i noticed when i tried to sync the time at the beginning of the week.


  • Do you have a Bangle.js v1 or a Bangle.js v2?
    Gordon is on holiday at the moment. Maybe he has another idea when he returns next week.

  • V2

  • I paid more attention to the "pinching" thing
    on this page
    seems to help
    must be a HW problem

  • I understand. Can you send me an email to Then we will sort this out for you.

  • I am having a similar issue with mine. Interestingly, I was able to connect to vanilla gadgetbridge but unable to download apps from the web interface. With banglejs gadgetbridge the watch shows the bluetooth symbol but my phone doesn't see it. This is after about 2 months of use.

  • Hi @itsjpb,

    Sorry to hear that - but if you can connect via Gadgetbridge and it's showing the bluetooth symbol as blue, I'd be pretty sure you have something like Programmable set to Off in the Bangle.

    Maybe you could check Settings -> Bluetooth -> Programmable is set to On and then exit back to the clock. You could also try Settings->Bluetooth->Make Connectable as Christine suggested above

  • Hi !
    Same here, I just got my bangle js 2 yesterday and was never able to connect to it. Make connectable stays off in settings whatever I do (reboot, reset factory, squeeze...). I see a bluetooth icon on the clock screen (white/ grayish).

  • Hi,

    Make connectable isn't a checkbox, but tapping it will allow the Bangle to be connected to (although it is enabled by default), and launches a menu asking if you want to leave the Bangle connectable (which you should ideally tap 'yes' on).

    What device/app are you trying to connect to it from? Generally you can't just pair from your OS's bluetooth menu. By default the Bangle isn't providing any service your OS is interested in so it won't display it in the list of devices.

    To start, it's best to go to - check out the steps at

    If you're still having trouble, maybe try connecting from a different device?

    While it could be a hardware problem, that is extremely unlikely - we test bluetooth on every single device before we send it out. More than likely it's just some issue getting your PC to see it

  • I tested from Android device, and 2 Mac devices, all working fine with other BLE devices over web ble. Actually I was able to have a very unreliable connection squeezing very hard at the top right between front and back. Squeezing very hard I can see the bangle js advertisement but the connection fails most of the times or disconnects quicky after established.
    I really suspect some hardware failure / cold solder or something like this...

  • Wow, ok. Thanks - that does sound like a hardware issue then. But as above that is extremely rare - we test before sending them out and apart from the very first batch that had a few failures after a few months, subsequent batches of Bangles haven't tended to have many Bluetooth issues.

    Please can you email and reference this thread and where you ordered the Bangle, and we'll sort out a replacement?

  • Mine stopped connecting, too. I suspect I got water inside. I'll buy a new one, but, how would I open it to see if I can dry it, maybe?

  • There's a thread on doing this but it's much like opening up an iPhone - you need to warm the display up so the glue melts and then pull it away with a suction cup.

    But it's super important not to go above (ideally) 70 degrees C, definitely not 100 or the LCD will suffer permanent damage. It makes it quite tricky to do - if you're lucky enough to have a PCB reflow hotplate then I've found those work great - but most people wouldn't have anything like that!

  • I am not affected, but won't a 3D printer's printing bed do the job? You could easily set it to 70°c preheat (without printing) and set the watch with the display down on the bed for some longer time.
    Just an idea...

  • I'll try that and report my success.

  • I am not affected, but won't a 3D printer's printing bed do the job?

    That's a fantastic idea! Yes, that would be perfect.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Can no longer connect to my bangle.js 2

Posted by Avatar for TheDod @TheDod