Can no longer connect to my bangle.js 2

Posted on
of 3
/ 3
Last Next
  • One of the two bangle.js 2 watches we have can no longer be connected via BLE from Chrome, and no longer appears on BLE scans (I've also tried with Adafruit's "Bluetooth Connect" android app). I can see the other bangle.js 2 and connect to it without a problem.
    How can I debug and/or fix this?

  • When was it working last?
    Can you remember if you changed anything inbetween?

  • Last time I connected via web was about a month ago. I think I was upgrading apps that needed upgrading. I don't remember changing anything since then.

  • Stating the obvious a bit, but I assume you've gone into the bluetooth settings and clicked the "Make connectable" button, and that you don't have whitelisting enabled?

  • True and true

  • Someone a few days ago had somehow ended up with "Programmable" set to off, so that is worth checking separately too. I just checked and "Make Connectable" on my watch doesn't toggle that value (I assumed it would).

    Is there anything that could be connecting to the watch automatically and beating you to it? A phone or something?

  • Is it related to having multiple of them, perhaps same name isn't allowed? I dont know cos i've never had two before. Did you ever have 2 bangle's both advertising in past? Btw, try putting the Bangle that doesnt' show in list, very close to the bluetooth adapter, just to rule out range/power issues, because there was a post recently about someone who had such issue.

    Do this, then you can isolate if its an app specific problem. Bluetooth is enabled in this state.

  • Hi,

    As above:­tting-without-loading-any-code

    If the Bangle says '-> Bluetooth' on the screen before you try and connect then the issue is that some other device nearby is connecting to it automatically - it's possible it's paired in the OS of your phone/PC.

  • So I now have exactly this problem too. I'm using exactly the same method of connecting through the browser as I have before, and all I get is the orange bar and "Device connection failed,".

    I did the reboot and the Bangles shows '-> Bluetooth', however the BT widget is grey, the phone (to which it's usually connected, and the only device other than the browser to which it's ever been connected) has BT switched off - so it's not connected to any other BT. I have forgotten the iPhone pairing, but can't find a way to forget the browser pairing. (Update: forgot the pairing in the System Preferences instead of the browser.)

    As I say, I've done nothing different from what I always did (phone BT off, connect through the browser), but can't get Bangle connected in the browser. It does connect just fine with the phone.

    Thoughts @Gordon?

    UPDATE: Solved the issue, but not sure how. I had deleted the pairing from both phone and computer. When I tried to repair with the computer, it asked for a "passcode shown on remote Bluetooth device" but there was no indication of a code on the Bangle. Without closing that window, I opened a new window with the Apps loader page, and it connected.

    I tried to repeat this connection method, but it has failed again. Still getting the orange "Device connection failed," bar. Clicking Cancel returns to the orange bar.

    I've never had this connection issue before.

    UPDATE UPDATE: In order to be able to connect, I have to hold the button in through the <====> screen, until it boots to the logo and just ">" bottom left. Then I can click Connect on the App Loader page and it connects.

    1 Attachment

    • Screenshot 2022-03-10 at 11.10.54 PM.png
  • And now I can't re-pair to the phone as it's looking for a pairing code on the Bangle (which isn't showing one...)
    UPDATE (in case anyone else has this at any point): the Passkey can be found under Settings-Bluetooth-Passkey (6 digits, which are selectable, but shows the existing setting).

  • I did the reboot and the Bangles shows '-> Bluetooth', however the BT widget is grey

    You noticed this but if you follow the steps properly there should be no Bluetooth widget shown - just the Bangle.js logo.

    So it looks like the issue was just that you'd changed the settings and added a Passkey?

  • Hi Gordon,
    Nope - I hadn't (and haven't) changed anything.
    What I was saying was that I followed the reboot instructions and saw "-> Bluetooth" at the bottom corner of the logo screen. Even with that implication that there was a BT connection, the BT widget on the main screen showed grey (so no connection) and there was no device connected to the Bangle.
    I don't remember having to use a BT pairing password originally, so was foxed when it was required for re-pairing after forgetting the connection on Mac and iPhone. I later found that Bangle refers to it as the "Passkey" - when other devices refer to the BT "Passcode" - and having found that, I was able to re-pair to the phone.
    I think the major issue is that, with no change of things on my end, Bangle refused to connect to the App Loader webpage, where it had had absolutely no problem before. (The process I had used in the past was to switch off the iPhone BT and then just connect on the webpage. This did not work - hence all the messing around (and commenting) to find a solution. Hopefully, we won't encounter that in the future.)

  • Hi.
    Sorry for the delay.
    Just tried and I don't see "bluetooth" there (see image).
    After a normal reboot, the bluetooth widget is grey and not blue (see image).

    2 Attachments

    • IMG_20220312_195051.jpg
    • IMG_20220312_194959.jpg
  • @TheDod Ok, thanks - and when it's showing the Bangle.js logo as in your picture, you're saying you don't see the Bangle listed in any Bluetooth scans?

    What about if you reboot it to the bootloader? Do you see 'DfuTarg' in any scans then?

    @ajkm yes, lets hope it doesn't happen again. But it seems to me that passkey pairing got turned on - I'm not aware of any app that would automatically turn that on for you, so I wonder whether maybe it got turned on (even accidentally) which I think can happen if you just go into the passkey menu and then exit again

  • and when it's showing the Bangle.js logo as in your picture, you're saying you don't see the Bangle listed in any Bluetooth scans?

    No, I don't.

    What about if you reboot it to the bootloader? Do you see 'DfuTarg' in any scans then?

    No. No DfuTarg when in bootloader mode (and I do see DfuTarg when the other watch is in bootloader mode).

  • Ok, thanks. In that case, it sounds like somehow Bluetooth has stopped working on your Bangle.

    I'll ask Christine to drop you an email and arrange a replacement

  • Thanks. That's extremely cool.

  • In case this is useful to anyone else: I had what looked like the same connection issues @TheDod had, fixes outlined above didn't help, no other devices were connecting to my watch. Rebooting the laptop does seem to have fixed the issue, though!

  • It has arrived. Thanks 🙏

  • Hi, am just having the same issue. I clicked the disable Passkey and it paired but asked me to enter the passkey which seems to be in Passkey option one digit at a time...
    It worked, but not sure exactly what this means - it also says something about Beta passkey

  • It looks like you went into settings and enabled the passkey?

    If you enter the menu and then go back, that's enough to set the passkey. You need to go into the menu and choose 'Disable' to disable it. You need to at minimum exit the Settings menu and go back to the clock to reload settings, but it's possible that right now you may even have to reboot your Bangle to get it to disable the passkey.

    It says 'Beta' because passkey is something that got added due to popular request but which I feel probably isn't ready for general use because some people had reported connection problems.

  • Hi Gordon, I'm also encountering this issue. Even after a factory reset, I cannot get my Bangle 2 to show up for pairing (tried multiple laptops / phone). It happened a week or so ago and previously had been pairing fine.

    Have tried pairing when the watch is running normally, and also when booted to the bootloader

  • Have tried pairing when the watch is running normally, and also when booted to the bootloader

    You wouldn't be able to pair when it's in bootloader mode anyway, but maybe you could try running the NRF Connect app on your phone and see whether the Bangle appears as a device called DfuTarg when it's in the bootloader mode?

  • Hi Gordon,

    Thanks for the reply. I've tried NRF Connect and don't see the Bangle show up there either I'm afraid. Tried another factory reset and repeated test but to no avail.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Can no longer connect to my bangle.js 2

Posted by Avatar for TheDod @TheDod