Status of the "Android Integration" app

Posted on
of 5
First Prev
/ 5
  • While tinkering with the http example posted before, I've stumbled over my Android-version not allowing unencrypted communication. When I try to access my NodeRed-Instance:

    Bluetooth.println(JSON.stringify({t:"htt­p", url:"" }));

    I get: CleartextHTTP traffic to not permitted.

    While this is sensible in internet-communications, it complicates my internal setup and would also need t:https, I suppose. Quick searching shows this as default in Android 8+ and only being avoidable by changing the Manifest of the app.

    Any chance, this might happen, or any workarounds for this?

  • So what's the best way to get updates on the app? I've been checking these forums occasionally, but generally only when I do an update of my watch, which I only do every few weeks due to the hassle of closing Gatgetbridge, enabling Chrome (I normally use Firefox,) going through the update routine, disabling Chrome and then re-enabling Gadgetbridge. Is there any way that people could sign up to receive an e-mail or something when the first stable version of the Android app is available for download?

  • For those who asked for example code, I pulled it out of the gadgetbridge Java-Code:

    // to create an intent for other android-apps to react to:

    // to make a http-call:
    Bluetooth.println(JSON.stringify({t:"htt­p", url:"",xpath:"­/html/body/p/div[3]/a"}));

  • I'm finding it a bit hard to keep track of everything that happened in the last week, and if I try and go through and follow up in one big message it'll be a total mess.

    I've tried to add some info to the Gadgetbridge page on­/blob/master/info/­js-gadgetbridge-app but if you have anything extra to add (examples, etc) then a PR would be great.

    So if you still have an issue, please can you file it on­ge

    Even better, if you can fix it, send a PR :)

  • Hi @Gordon,

    I hope it's the right place to report Gadgetbridge issues.

    Just installed gadgetbridge beta from google play store. I'm trying to configure which apps are causing phone notification, and most of the apps are missing from the app list.

    Notification settings -> Per app settings -> Application list

    Apps like whatsapp/signal/calendar are totally missing. Previously I was using vanilla gadgetbridge and these apps were there. Any suggestions?

  • As I'd mentioned above, it's best to report on­ge now I think - I'm just getting swamped with issues on this thread and can't keep track.

    But if you look back in the thread history I think others have had similar issues. It might have been a permissions thing?

  • I just created a new conversation for the Topic with the app not correct listed:­376836/

    also i opend a github issue:­ge/issues/2

  • I tried Bangle.js GadgetBridge and encountered a problem. I use the Android app "Kleine Wettervorschau Deutschland" (F-Droid) to get weather data on the watch. It works with the original GadgetBridge app, but not with the Bangle.js GadgetBridge version.
    In the app you can set a package name (default is "nodomain.freeyourgadget.gadgetbridge") in case you use a forked GadgetBridge app. Unfortunately, I couldn't figure out what to enter in there to make it work with the Bangle.js GadgetBridge app.
    Does anyone have any ideas?

  • "com.espruino.gadgetbridge.banglejs" works fine for me :)

  • I'll add this to­ther - if there are other gotchas, maybe you could help to contribute some changes to that page? the source is on­/blob/master/info/

  • @PeerDavid, thank you very much, this works great.
    I just looked a bit more, this is probably because it is defined this way in the product flavor(­ge/blob/master/app/build.gradle)

  • this is probably because it is defined this way in the product flavor

    Yes, I think it has to be this way really, because otherwise people who have the original Gadgetbridge and the Bangle.js one could find conflicts. However I guess we could listen out for those particular Gadgetbridge intents anyway.

    Personally I think now the Bangle.js Gadgetbridge app can access the internet, it'd be nice to build the weather support into it. PRs welcome ;)

  • Hello,
    I got a

    "INSTALL_FAILED_CONFLICTING_PROVIDER: Scanning Failed.: Can't install
    because provider name (in package
    com.espruino.gadgetbridge.banglejs) is already used by

    when trying to install it from AuroraStore on a GS9 with /e/os

    Does it mean I should remove GadgetBridge first ? I d like to keep both apps though, but if it s impossible, i ll try Gordon's later as I still need the original GB.

    Thanks for any feedback

  • Thanks for the detailed error message, that really helps!

    Do you have any way of knowing what app version you're trying to install? Because that could have happened with earlier Bangle.js Gadgetbridge builds but I was pretty sure that the current ones are fine, because of this line:­ge/blob/master/app/build.gradle#L156-L15­7

    ... but maybe the 'release' build type overwrites the 'banglejs' flavor

  • Hi and thanks for the reply Gordon

    On Aurora store (that is supposed to be a google's clone with more privacy concern) the version shown is :

    Bangle.js Gadgetbridge Espruino 0.67.1b-banglejs (216)

    with installation of the following files :

    com.espruino.gadgetbridge.banglejs.216.a­pk. (4MB)
    config.xxxhdpi.216.apk (104KB)
    config.arm64_v8a.216.apk (41KB)

    It also says those files were updated on June 15 2022

    Probably worth waiting for a few days more for it shows the latest one with the corrected lines

    Disable pebble provider to allow Bangle.js Gadgetbridge to coexist with Gadgetbridge resValue "string", "pebble_content_provider",­ovider"

    I'll retry after the weekend and I'll let you kow

  • 0.67.1b-banglejs (216)

    Thanks! Well, I'm afraid that is the latest one, so it should have those lines in already.

    If you're able to build your own it'd be interesting to see if you have any success changing build.gradle

    I wonder if there's a way to statically analyse the apk, so I can be sure pebble_content_provider is set correctly.

  • If you're able to build your own it'd be interesting to see if you have any success changing build.gradle

    I'm afraid I don't have this talent

  • I have issues with the http request function. I have created an issue here­ge/issues/7. Not sure that this is the right place @Gordon?

  • @rullen, this is certainly the error that is described here:­379050/

  • Thank you @ingo. It was the same issue and the suggested fix did solve the issue

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Status of the "Android Integration" app

Posted by Avatar for jgDev @jgDev