Espruino 1v91 released

Posted on
  • Just a quick note to say that Espruino 1v91 has been released.

    Changes in this one are:

    Bugfixes on ES6 features

    • Fix error handling in promises (returning pre-rejected promises)
    • Allow arrow functions inside nonexecuting functions

    General improvements

    • Fix potential bugs with saving code to flash memory
    • Allow HTTPS to work without a certificate specified
    • Remove some global variables that were defined in devices that didn't support them
    • BBC Microbit: Update Espruino with pin polarity, so saved code gets loaded without BTN1 pressed
    • ESP8266: Fix regression that stopped 1v90 from working
    • Added Global built-in objects like SPI1/Serial1 and Bluetooth to the index of the reference
    • Ensure tab complete/others include the Object proto even on functions/strings
    • Allow implicit conversion of hexadecimal strings to numbers

    Puck.js improvements

    • Add NRF.setLowPowerConnection(bool) to allow low power continuous connections to Puck.js
    • Making getPrimaryService more robust, with better error messages (for connecting to other pucks)
    • Added NRF.getAddress() - to get our own MAC address
    • Increase custom UUID count from 3 to 10 (when reading devices like Awox that use lots of custom 128 bit UUIDs)
    • Tweak battery percentage calculation to try and make it more linear
    • Adjust Puck.light() levels based on battery voltage
    • Fix E.hwRand()
    • Add NRF.restart() to force the restart of the Bluetooth Softdevice if required
  • Add E.setLowPowerConnection(bool) to allow low power continuous connections to Puck.js

    Nice!! That didn't take long.

  • Hi,

    I tried re-flashing my Puck.js with this newest firmware using the nRF Toolbox app on iOS and after the flashing process is completed (successfully, it seems), I can no longer see my Puck.js. I tried scanning with many different apps and my laptop, and it just doesn't show up.

    If I re-flash with version 1v90, everything works as normal.

    I tried three times, even re-downloaded the file, but it seems it just doesn't work. Any ideas?

    Thanks a lot for all the great work on Espruino btw, it is truly an amazing project! :)

  • I just flashed on my Puck and it works very nicely, no problem. Uploaded from the same app.

    Very nice update, I like the NRF.setLowPowerConnection (note that the announcement above wrongly says E.setLowPowerConnection() ), and the hwRand fix especially! Thanks! Also the getAddress() is very nice, I needed that for some kind of self organization of a swarm of puck. So far I configured this in the boot code, but being able to ask for it is great!

  • Nevermind, managed to flash it correctly in the end. weird, but better this way :)

  • Great! @stevie4711 thanks, I changed the post above.

    @h3rald did you figure out why it was failing when you updated before? It might help others

  • Hi Gordon!

    Well basically I just repeated the process:

    1. Go to the binaries folder with Safari on my iPhone.
    2. Click the file and from the share menu import it into NRF Toolbox app.
    3. Put the Puckjs in flash mode and flash.

    I am now running the latest version on My Puck and it's working perfectly! I got it to advertise sensor data as manufacturer GAP data and basically it now works as a "smart" beacon the periodically advertises fresh sensor data.

    I may post about it in another section of the forum later on, it may be interesting to someone.

    Thanks again for building such an amazing little thing!

  • On the Android, upload file seems only to be via Dropbox (causes me a little delay as I forgot my Dropbox password)

  • upload file seems only to be via Dropbox

    Not at all! Did you look at the video?­-updates

    You can just download the file via your web browser first

  • Hi Gordon
    Kindly advise me on this error
    I am using v1.91.66 on mini leaf stm32 board
    when sending a sample code there always a strnage p character sent to the chip ascii 254 before the code and I get this error:
    "uncaught SuntaxError got ?[254] expeted EOF"
    Please advise

  • I don't know what the problem could be - and I'm afraid I don't have time to offer support for non-Espruino boards.

    The best I can suggest is to make the first line a statement like 0; that won't cause problems if it fails to execute.

  • thanks

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino 1v91 released

Posted by Avatar for Gordon @Gordon