[Solved] Not able to connect

Posted on
  • Well, 1.5 times I was able to connect through https://banglejs.com/apps/, using Chrome on a Win10 machine.
    Once everything worked amazingly fine and I was able to upload apps to the watch.
    The 0.5 means it started to download the app list but got disconnected.
    I've tried probably over 100 times and sometimes I'm able to pair the watch in the window that pops up when clicking , after that the status bar Getting app list is shown but not proceeding.
    Same problem on another Win10 computer.

    Also, no beeps are heard, the one time when I was able to connect, I uploaded Manic Monday Tone, when starting that I get a message on the watch but nothing happens when pressing it, and no sound whatsoever. Same goes with the morse app I was able to upload.

    Debug info is set to Hide.

    Edit: The few times when I'm able to pair, I get this message after a couple of seconds: 'Device connection failed, undefined'

  • Sat 2020.03.21

    Well being one of the earliest to receive a new release @baljo has it's excitement and under some unfortunate circumstances some minor disappointment.

    It appears you may have read post #18 and #22

    http://forum.espruino.com/comments/15159­914/

    as it is indicated Debug Info set to 'Hide'

    Have the troubleshooting steps been followed?

    https://github.com/espruino/EspruinoDocs­/blob/master/info/Troubleshooting%20Bang­le.js.md


    Please post the results of process.env so that we may determine if a pattern is starting to reveal itself.

    Does anyone know how to detemine the current version of the AppLoader that is installed?

    'Also, no beeps are heard'

    Have you noticed if others have posted on this, or are you the first?

    Tried to manually sound the piezo?

    https://banglejs.com/reference#l_Bangle_­beep


    re: 'Edit: The few times when I'm able to pair, I get this message after a couple of seconds: 'Device connection failed, undefined''

    I have absolutely no idea if this pertains to Bangle.js but, I've been plagued with this type of issue (BLE) runninng Win10 using the MDBT42Q breakout board. I outlined steps in

    http://forum.espruino.com/conversations/­342204/#comment15045875

    of the only way I am able to recover when that happens to my setup. Still have been waiting to see if other have the same issue with Win10, but few (none) have piped in yet. I may have a shortcut of just selecting 'Add New Device' as under some circumstances, leaving the board powered up does sometimes work.

    Does following a combination of those steps allow recovery for the Bangle?

  • @Robin thx for responding!
    I actually was able to connect once again, and removed one app (Simple Heart Rate widget) that caused the heart rate to be measured as soon as the screen was on. After this I'm able to connect, also after restarting the watch.
    I'm not sure if/how that app could cause Bluetooth interference or issues, but I don't want to add it again in trying to replicate if it was causing issues or not.

    Yes, I've tried to manually sound the piezo, no sound at all, and yes, I'm keeping it close to my ear. Also others have reported that the piezo is not working or even missing in some case/cases.

  • For connecting, you could try: https://www.espruino.com/Bangle.js#reset­ting-without-loading-any-code

    That should stop Bangle.js loading anything that was saved to the device, so regardless of the apps that were installed it should allow connection. If you have an Android phone it'd be worth trying to connect with that and see if it was any better too.

    as for the sound, I see you already posted on the other thread so let's talk about it on there.

  • Thx Gordon! As I wrote in post #3 I'm able to connect now, but good to know about the resetting part.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

[Solved] Not able to connect

Posted by Avatar for baljo @baljo

Actions