You are reading a single comment by @ThomasVikström and its replies. Click here to read the full conversation.
  • Well, 1.5 times I was able to connect through, using Chrome on a Win10 machine.
    Once everything worked amazingly fine and I was able to upload apps to the watch.
    The 0.5 means it started to download the app list but got disconnected.
    I've tried probably over 100 times and sometimes I'm able to pair the watch in the window that pops up when clicking , after that the status bar Getting app list is shown but not proceeding.
    Same problem on another Win10 computer.

    Also, no beeps are heard, the one time when I was able to connect, I uploaded Manic Monday Tone, when starting that I get a message on the watch but nothing happens when pressing it, and no sound whatsoever. Same goes with the morse app I was able to upload.

    Debug info is set to Hide.

    Edit: The few times when I'm able to pair, I get this message after a couple of seconds: 'Device connection failed, undefined'