• Hi, I am brand new at this.

    I can't get started. Flashing seems OK, well from esptool.py point of view.

    My board says ESP-12F and ESP8266MOD on the chip.
    I have tried all flashing versions of the readme file in both espruino_1v99_esp8266.tgz and espruino_1v99_esp8266_4mb.tgz. I just do not know what more to try.

    The Espruino Web IDE says everytime I've flashed and tried connecting (using 115200 baud):
    Unable to retrieve board information. Connection Error?
    Connected to COM5 (No response from board)

    What else can I do?

  • Sat 2018.10.06

    Hello @user94635, I have limited experience with the ESP8266 but thought I'd pass along the following. I know how frustrating it may be at times and having at least someone acknowledge that their post was read makes the going a little more tolerable.

    Have you checked out these similar posts?


    Have you verified the baud rate both at the terminal end and the IDE under Settings >> Communication?

    May be a bit off putting, but have you tried an earlier version and what if any error appears?

    When I have encountered this error with the Pico, the only recovery was to disconnect the IDE, close the IDE then power down the device. Performing the reverse, then re-uploading code or in this case re-flashing may be the only option. Have been battling this for over a month now, although frequency is down to once every three days or so.

    Which IDE native, Chrome or Web and what version? As persuaded by staff have recently upgraded to native 0.70.4 and have my fingers crossed. Hasn't happened yet.

    What PC and OS is being used?

  • Try to connect firs from terminal. Eg minicom in linux

  • I am using Windows 10 and tried a serial connection in putty every time as well after flashing the device.

    Yes I verified the baud rate both in the Espruino web ide and in putty.
    And after every time I flashed the device I tried to connect with both the web IDE and a serial connection in putty and then power cycle the device (disconnect from the usb). Still nothing. I am assuming that I am getting the wrong addresses in the flashing process but I have tried every set of addresses I have seen. I have not tried to downgrade the version though. Will try that.

  • It is an AI Thinker ESP-12F (ESP8266) device. Do the flashing addresses match this device? How can I find out what the addresses should be?

  • Please provide us with your exact flashing procedure, step by step, including esptool command lines with parameters.

    If that looks ok, it could be a board problem or a communications issue.

  • I use the CH340 USB to serial driver (COM5:)

    I've installed python and esptool.py. I've used this to flash ESP8266 boards for microPython and that works fine.

    PS C:\Users\me\OneDrive\Documents\esp8266\E­SPruino> python ..\code\esptool\esptool.py --port COM5 --baud 115200 write_flash --flash_freq 80m --flash_mode qio --flash_size 32m 0x0000 "boot_v1.6.bin" 0x1000 espruino_esp8266_user1.bin 0x3FC000 esp_init_data_default.bin 0x3FE000 blank.bin
    WARNING: Flash size arguments in megabits like '32m' are deprecated.
    Please use the equivalent size '4MB'.
    Megabit arguments may be removed in a future release.
    esptool.py v2.3-dev
    Detecting chip type... ESP8266
    Chip is ESP8266EX
    Uploading stub...
    Running stub...
    Stub running...
    Configuring flash size...
    Flash params set to 0x004f
    Compressed 3856 bytes to 2763...
    Wrote 3856 bytes (2763 compressed) at 0x00000000 in 0.3 seconds (effective 123.2 kbit/s)...
    Hash of data verified.
    Compressed 509332 bytes to 340820...
    Wrote 509332 bytes (340820 compressed) at 0x00001000 in 30.1 seconds (effective 135.6 kbit/s)...
    Hash of data verified.
    Compressed 128 bytes to 75...
    Wrote 128 bytes (75 compressed) at 0x003fc000 in 0.0 seconds (effective 78.7 kbit/s)...
    Hash of data verified.
    Compressed 4096 bytes to 26...
    Wrote 4096 bytes (26 compressed) at 0x003fe000 in 0.0 seconds (effective 3647.9 kbit/s)...
    Hash of data verified.
    Hard resetting via RTS pin...
    PS C:\Users\me\OneDrive\Documents\esp8266\E­SPruino> putty

    From putty I am trying to connect to the board directly with 115200 baud and then I power cycle it and try again. After that I attempt the Espruino Web IDE with 115200 baud.

    I have also tried this esptool.py line:

    python ..\code\esptool\esptool.py --port COM5 --baud 460800 write_flash --flash_freq 80m --flash_mode qio --flash_size 4MB-c1 0x0000 "boot_v1.6.bin" 0x1000 espruino_esp8266_user1.bin 0x3FC000  esp_init_data_default.bin 0x3FE000 blank.bin

    which flashes the board, also tried this one:

    python ..\code\esptool\esptool.py --port COM5 --baud 115200 write_flash --flash_freq 40m --flash_mode qio --flash_size 4m 0x0000 "boot_v1.6.bin" 0x1000 espruino_esp8266_user1.bin 0x7C000 esp_init_data_default.bin 0x7E000 blank.bin

    but that one says: Detected overlap at address: 0x7c000 for file ...

    I have tried these versions, in order, with both working esptool.py lines above:
    1) https://www.espruino.com/binaries/esprui­no_1v99_esp8266_4mb/
    2) https://www.espruino.com/binaries/esprui­no_1v99_esp8266/
    3) https://www.espruino.com/binaries/esprui­no_1v98_esp8266_4mb/
    4) https://www.espruino.com/binaries/esprui­no_1v95_esp8266_4mb/

    Still no console in putty or the Web IDE

  • Finally got it!!! YiiiiiHaaaa!!!!

    python ..\code\esptool\esptool.py --port COM5 --baud 460800 write_flash --flash_size=detect -fm dio 0 .\espruino_1v99_esp8266_4mb_combined_409­6.bin
  • Congratulations! :) Any ideas what it was? I see you changed a few things in the end.

  • Use

    --flash_size 4MB-c1

    for all 4MB board features

  • Details can be find here http://www.espruino.com/EspruinoESP8266 in section Build Content

  • @MaBe Thats why I'm kind of curious. That setting is one that didn't work for him. The changes he made in his working final flashing seemed to be "--flash_size=detect" and "--baud 460800" and "espruino_1v99_esp8266_4mb_combined_4096­.bin", which I assume elimited the wrong address (" 0x7c000 for file ...") problem. So maybe it was the the removal of the addresses, and the use of the combined file that did it.

    I'm just wondering what the working change was. For me I always use the standard from the README file and has never been a problem for me.

    Nice page btw: http://www.espruino.com/EspruinoESP8266 -- I see its been updated :)

  • Great thanks to @MaBe (and @Gordon and many others... even though not very active anymore, like @tve and @Kolban and ... all the others I miss in this list) to keep this free-be 8266 ESP thing in good health!

  • I am having a similar problem with a NodeMCU. I tried the line in (post 8) that helped the topic starter, but to no avail.

    1. Flashing seems to go fine (see bottom of this post)
    2. I can sometimes access the Espruino prompt in Putty (1 out of 3 or 4 tries)
    3. I never see a prompt in Espruino

    When I click the connect button in Espruino and choose the COM port, then I see the following in the IDE:

    • an orange box with text "Disconnected"
    • a line with some garbage text "0 űÁ"
    • a red box with text "Unable to retrieve board information. Connection error?"
    • a green box with text "Connected to CO4 (no response from board)"

    Here is my line that I use for flashing:

    esptool.py.exe --port COM4 --baud 115200 write_flash --flash_size=detect -fm dio 0 .\espruino_1v99_esp8266_4mb_combined_409­6.bin

    And here are the flash results:

    esptool.py v2.5.1
    Serial port COM4
    Detecting chip type... ESP8266
    Chip is ESP8266EX
    Features: WiFi
    MAC: 18:fe:34:e1:a4:16
    Uploading stub...
    Running stub...
    Stub running...
    Configuring flash size...
    Auto-detected Flash size: 4MB
    Flash params set to 0x0240
    Compressed 4194304 bytes to 353773...
    Wrote 4194304 bytes (353773 compressed) at 0x00000000 in 31.7 seconds (effective 1058.0 kbit/s)...
    Hash of data verified.
    Hard resetting via RTS pin...

    I can upload any Arduino sketch that I have to this module (NodeMCU from Amica), and they all work as expected. So, I think the module is fine. I don't have any others to try right now.

    Any help is appreciated

  • If you get the garbage text in the IDE, is your baud rate set correctly? Also, did you reset the board out of bootloader mode?

    If the board itself is unstable it's possible it's just a broken board. If the power supply is dodgy (bad capacitor) the ESP8266 can just reset itself as soon as it tries to initialise WiFi.

  • Baudrate is set to 115200. I always do a power cycle after flashing, so that should qualify as a reset, correct?

    Tonight I will try to power it from an external supply and see if I can connect.

    Thank you for the hints @Gordon

  • Oh, @Gordon do you happen to know which capacitor I should look at?

  • Honestly, no idea - probably the big ones! If you have an oscilloscope then try looking at the 3.3v rail and see if the voltage fluctuates at all.

    At the end of the day though, if you spent £5 on a board there's probably a limit to how much time and money you want to spent trying to fix it :)

  • You are probably correct about that... although, it can give some satisfaction if you solve an issue like this.

    Thanks again!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

I can't get started. Flashing seems OK, Esperino Web IDE not connecting.

Posted by Avatar for Neptune443 @Neptune443