• Almost every time, after using the Web IDE with my laptop (Windows 11), my Banglejs 2 won't be able to get notifications from my iPhone.

    While I'm using the Web IDE, since it can connect to only one device, I turn off the BT on my phone. After disconnection (and remove the Bangle from BT device list on the laptop), I turn on the BT on the phone.
    On the phone it shows the Bangle is connected, but no notifications are received. So, I removed Bangle from the phone by forgetting the device and tried to reconnect but now the Bangle was not shown as nearby BT device.

    I tried to reboot the Bangle multiple times but didn't work. So, I did a factory reset and it started working.

    Am I doing something wrong?

  • Hi - I just saw you closed this - did you manage to figure out what was wrong?

  • @Gordon, I'm not 100% sure yet, but I think I know what I did wrong.
    If I remove the Bangle from the BT devices on my laptop BEFORE disconnecting the Bangle from the Web IDE, it seems to cause that problem. I will update after some more tests.

  • I tried to reproduce the issue to find the root cause, but my initial guess mentioned in previous post #3 doesn't seem to be correct.
    Here is another guess and a question:
    In the Web IDE, with loading the example code 'blink' by clicking on the UP arrow icon to RAM, Bangle shows a red dot blinking on top of the watch screen. I tried to change the blinking speed a couple times and then go back to the watch screen by long press of the button. After that, no notifications were received from the iPhone. Rebooting and reselecting to stay BT connectable seem to fix the issue. My guess is that the small app (blink) running on the RAM interferes with the BT and/or notification.
    Question: what's the proper way to stop running an app and clear the RAM area? Is long-pressing the button correct way to do it?


  • Long-pressing the button should be the best way to stop what's running in RAM. Perhaps try doing that before you disconnect

    I think the issue could be that when running code normally, the Bangle will run some code that enables ANCS (the bluetooth function that allows it to get notifications from iOS). When experimenting running the flashing LED in RAM it's possible that doesn't get called, so ANCS isn't set up.

    So then if the iPhone ends up connecting when it's not enabled, it doesn't see your Bangle providing ANCS when it connects, even if it is enabled at a later date when you long-press the button to reload the clock?

  • @Gordon, thank you for your reply.
    Last night, when my Bangle was still not receiving notifications from the iPhone, I went to the Settings > Utils and clicked on 'Rewrite Settings' to see if it repairs any corrupted data. After that, I could receive notifications but not 100%. There were some missing notifications.
    Just now, after reading your reply, I did what you suggested, the long-press the button before disconnecting from the Web IDE after running the blink in the RAM.
    Since then, it seems to be working fine. I will report back later with more data.
    Thank you, Gordon!

  • After a couple of days' tests, I can confirm that the long-press before disconnection of the Web IDE resolve the issue of no-notification.

  • For the last few weeks, it happened again a few more times that my Bangle.js 2 wouldn't connect to my iPhone's Bluetooth after using Web IDE even though I always pressed the button long before disconnection of the Web IDE.
    I was frustrated and did some more tests and finally (I think) found a solution. That is to remove the Bangle.js 2 from my laptop's Bluetooth device list and then turn on the Bluetooth on my phone.

  • That is to remove the Bangle.js 2 from my laptop's Bluetooth device list

    Great! Glad you found a solution. Yes, that would definitely cause you problems.

    Were you pairing the device using your laptop's bluetooth menu? Usually when you connect with the IDE, the Bangle doesn't get paired with the OS bluetooth so doesn't need removing.

  • Usually when you connect with the IDE, the Bangle doesn't get paired with the OS bluetooth so doesn't need removing.

    Oh, I see. Good to know.
    Thank you, Gordon!!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Banglejs 2 Bluetooth disconnects with iPhone after using WebIDE

Posted by Avatar for JeonLab @JeonLab