• Hi,

    My Bangle js 2 arrived today, but the interface is nothing like in the YT video from 6 months ago. I keep getting a disconnect with a suggestion that "programmable is set to off". But when I follow instructions to go to the settings to toggle that, my settings has only a few options. Additionally, the version is 0.6.8 which seems like a much lower number than is talked about in discussions. The interface itself, including starting from the factory reset is also very different from what's in the recent videos. I bought this over the holidays and it arrived today (4th Jan 2024). It's definitely the v2 (square) version.

    Can anyone suggest possible fixes? I can get it to be seen and 'connect' on a BLE browser, but I've tried several on Windows, Mac, and even iOS, and it just disconnects when I try to retrieve "my apps".

    Thanks in advance, Pete

  • Hi!

    I've sometimes had problems with connecting to the app loader. For me, it's often solved by clearing the website cache. Not sure it will help your situation, but worth a shot if you have not tried it already.

  • You mean this video? https://www.youtube.com/watch?v=aoNray1i­uBM

    The interface should be pretty much identical to that... Do you think you could upload a photo of what it looks like for us? And where did you find the 0.6.8 version number?

    Also, where did you buy the Bangle from? was it from the Espruino shop, or somewhere else?

  • Hi, Sure - I've attached a couple of files, one showing the main settings page and the other the "about" screen. The settings screen only has: "language", "Time8date", "Unit", "Brightness", "About", and "Return factory". I bought it from "Adafruit".

    2 Attachments

    • IMG_0792 Large.jpeg
    • IMG_0791 Large.jpeg
  • And that was the video that I was comparing with...it's nothing like what's shown there. Cheers, Pete

  • Thanks, but I tried connecting from at least 5 different browser/OS combinations, all with the same result.

  • Isn't SMA-Q3 the hardware that the Bangle.js 2 is based on? Where did you buy this, and was it advertised as a Bangle.js 2?

  • Hi - I bought it from Adafruit and it was advertised as the "Bangle.js v2".

  • This is SMA Q3 firmware, not Bangle.js 2. (Maybe) same hardware, different software.
    Either return it or you need SWD debugger dongle to reflash the firmware via 4 pins on the back.
    Not hard but you need to mess with wires and get some SWD dongle or use Raspberry Pi or Pico for that.

  • BTW can you make photo of the box it came in?

  • Thanks - I've called Adafruit and left a message with them.

  • Not sure if I can/should post the barcode stuff online, but you bring up a good point - the date on the box is 2022-07-26...so it's not exactly new :(

  • no barcode needed, just how the watch box is branded, Bangle box is black, SMA Q3 box is quite different. If the box is black and Bangle branded then maybe someone somewhere did wrong firmware upload but the watch hardware may be OK. I have older SMA Q3 and it has no hole for pressure sensor on the top where the band is attached so pressure value is wrong, otherwise it works same as real Bangle 2.

    1 Attachment

    • 17044937414364716536652244417719.jpg
  • Thanks, yes, it's a black box and is labelled Bangle js v2. Based on what you've said, I'm guessing that it's the SMA Q3 that was put in a Bangle box? Or, like you say, that someone tried to upload the wrong firmware. Either way, I bought it as a new device and it's not what I expected.

  • I bought it as a new device and it's not what I expected.

    Sure it is definitely for Adafruit to handle that. It is just that if you would have Raspberry Pico by any chance then reflashing is not that hard and if you have tiny hole on the top of the watch where band is connected then you are probably not missing anything hardware wise and it is 'just' a software issue. Still, to be 100% sure you are getting the real thing, having it replaced is the safest bet.

  • Hi @user157250,

    this is most likely me shipping a not flashed Bangle.js v2 to Adafruit. Would you please send an email to contact@espruino.com? Then I will sort this out for you :)


  • Hi @user157250,

    Sorry about this. Yes, this is a mistake on our part - the factory use that firmware for testing, and then we reflash the watch and test with the proper Espruino firmware here. Somehow there's been a mixup and we have managed to send out an unflashed device to Adafruit.

    I'll chat with Adafruit - while we're happy to send a replacement from the UK, it might be faster if Adafruit send to you, and we'll sort out the rest with them. We should hear back today and hopefully you'll get a replacement sent out one way or another in the next 24 hours.

    I'm very sorry about this - reflashing the software isn't something you should have to deal with when you buy a new device.

  • Hi @Gordon, @Christine, Thanks for the clarifications. I've contacted @Christine directly, and it's being sorted. Cheers, Pete

  • My friend had exactly the same experience, however, Adafruit refused to exchange it or support it. Their response was to get it resolved on this forum, even though we knew it had the wrong firmware. Ours came without the instruction folder or stickers. The center pins on the back were also exposed. It did come in a Bangle box. I confirmed that I could not put it into a mode where DfuTarg was published to BLE, the screens matched what I saw online at the SMA site. It also publishes itself as SMA-Q3 to BLE when you are looking to pair.

    @fanoush confirmed my suspicion that we would need a SWD programmer of some type to reprogram it.

  • That's interesting, but not the same experience I had. Adafruit were more than happy to help with the exchange when I gave them all the information (including photos). Bot @Gordon and @Chistine jumped in too and sorted it out directly for me!

  • Hi, sorry about this. I'm not sure how it happened that two of these got sent out as-is.

    I'll drop you an email and we'll make sure we send your friend a new one. If you or your friend feels like a bit of a challenge you could use an SWD programmer to reprogram it - if you have a Raspberry Pi it's even possible to just wire to the pin header.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

bangle js 2 arrived today, but perpexed about how to install apps

Posted by Avatar for user157250 @user157250