• Hello there,

    I can not get my Bangle to connect to any devices. I tried the software reset without loading code, it shows the bluetooth launching and the mac address, but nothing else. I am hesitant to fully resetting the watch since I wanted to do a backup of the content there, which lead me trying to get a Bluetooth connection.

    I have: Pixel 4a 5g, Android 13 as well as Pixel 2, Android (Lineage) 11, both with Gadgetbridge. And a Linux/Ubuntu PC with bluetooth dongle. The Pixel 4a and the PC both were able to connect to the watch X weeks prior, I only got out the Pixel 2 right now to see if it can connect to the watch.

    Any specific step by steps I can follow to further debug this?

  • Did you enable hid in the BangleJS?

  • no it is disabled, as the troubleshooting guide told me to.

  • Did you enable it before?

  • no.

  • Hi,

    When you boot it normally, is the Bluetooth icon on it blue, or grey?

    it shows the bluetooth launching

    What do you mean? The -> Bluetooth message?

    Because if you take a normal Bangle.js and reboot it while holding the button so no code is loaded, it doesn't show -> Bluetooth.

    -> Bluetooth is normally displayed when there is an actual Bluetooth connection established, so I think it's most likely that one of your devices, somewhere, is automatically connecting to the Bangle whenever it sees it.

    Best bet would be:

    • Walk out a long way from any of your devices with the Bangle, and see if the 'reboot without loading code' shows -> Bluetooth or not.
    • If not, figure out which device is connecting, or just go into the OS Bluetooth menu of each of your devices and remove/forget the Bangle in them. Gadgetbridge especially can be a problem as that will auto-connect to the Bangle once it's been added, and will stop other apps/devices from connecting too

  • Hi

    Bluetooth icon blue or grey


    The -> Bluetooth message

    Thats the one. Right under the icon and the firmware version and your name, you know, the startup screen.

    how to reboot it.

    Alright, lets clear this up. If I shut down with the Poweroff app, then press once on the button to start the watch, this is the behavior. If I follow the steps from https://www.espruino.com/Bangle.js2#reseĀ­tting-without-loading-any-code correctly, you are right, it doesn't show up (I released the button too early sorry).

    so I think it's most likely that one of your devices, somewhere, is automatically connecting to it

    Easy to do, I turned off bluetooth at all devices which ever connected to it. Doing the normal shutdown/reboot, this still shows up. Doing the resetting without loading code, it again doesn't show up, but I can also not use the watch (obviously, since no code is loaded). So uhm, not sure if that helped?

  • Make sure your whitelist option in settings app is empty, I once forgot that I setup a whitelist for mac address. Also make sure programmable is true. Double check those settings under bluetooth inside your bangle. These problems are often something silly.

    Also, you should try entering DFU targ mode and see if the NRF DFU app from play store can connect to it, I mean simulate a firmware update. This would test the hardware is working fine still.

  • Whitelist is off, programmable is true. I can definitely try the DFU mode.

    Edit: I tried, the app didn't pick up the watch.

  • Edit: I tried, the app didn't pick up the watch.

    So you put it in DFU mode, and the NRF Connect app couldn't see anything called DfuTarg? (It won't be called Bangle in DFU mode).

    If that's the case then Bluetooth could have failed.

  • Jup I know that, I flashed firmwares before the app store could do that ;P No DfuTarg shows up. Though the app has changed from nRF to https://play.google.com/store/apps/detaiĀ­ls?id=no.nordicsemi.android.dfu If the app still works for you guys, it might be that the bluetooth failed indeed.

  • Ok, thanks for bearing with me on that (I've got a few Bangles returned here that are 100% fine so it's well worth checking!). If you could see DfuTarg before in DFU mode and now you can't, that sounds like a hardware problem.

    I've just asked Christine to drop you an email about a return

  • Absolutely no problem, I very much suspected Android 13/the bluetooth dongle being the issue as well, the bangle worked just fine before.

  • New one connected right away!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js 2 Bluetooth connection troubleshooting (linux)

Posted by Avatar for Poolitzer @Poolitzer