• Bangle.JS Watch
    Original version, pre-loaded at Kickstarter purchase: 2V.05

    • I followed instructions here: https://gist.github.com/conoro/4f6d71dba­d246b2169ef5ee7d140f5f9
    • Downloaded FW from this source: https://www.espruino.com/Download
    • Chose Bangle.js from drop down menu and have tried 2.V09 and during attempts to fix issue I have tried the rest all the way back down to trying the original 2V.05
    • Connected to DFUTARG, Distribution Packet (ZIP), ect... all successful, message: "Application has been sent successfully."
    • Attempted to use both nRF Connect and nRF Toolbox, same results with both.

    Error: Infinite boot loop.
    Details: After FW update the watch remains at the following screen:
    Sw Reset
    BTN1 = Reboot

    • Waiting solved nothing. Holding any individual button solved nothing. Rebooting using BTN1 REPEATS same screen.
      Rebooting whole holding BTN1 brings me to the screen:
      DFV ZVOS
      BTN1 = Reboot


  • Fri 2021.07.23

    Hi @user132338 , Nicely outlined, smart, detailed and covers all scenarios.

    I remembered reading this has occurred before and found the last entry Gordon had made:

    I Googled: 'bangle reboots after firmware update site:espruino.com'


    Has holding down all three buttons been attempted?

    Until Gordon returns from Holiday, this was the last recovery attempt solution I had read about.


Avatar for Robin @Robin started