Stuck in a boot loop after Firmware update.

Posted on
  • Bangle.JS Watch
    Original version, pre-loaded at Kickstarter purchase: 2V.05

    • I followed instructions here:­d246b2169ef5ee7d140f5f9
    • Downloaded FW from this source:
    • Chose Bangle.js from drop down menu and have tried 2.V09 and during attempts to fix issue I have tried the rest all the way back down to trying the original 2V.05
    • Connected to DFUTARG, Distribution Packet (ZIP), ect... all successful, message: "Application has been sent successfully."
    • Attempted to use both nRF Connect and nRF Toolbox, same results with both.

    Error: Infinite boot loop.
    Details: After FW update the watch remains at the following screen:
    Sw Reset
    BTN1 = Reboot

    • Waiting solved nothing. Holding any individual button solved nothing. Rebooting using BTN1 REPEATS same screen.
      Rebooting whole holding BTN1 brings me to the screen:
      DFV ZVOS
      BTN1 = Reboot


  • Fri 2021.07.23

    Hi @user132338 , Nicely outlined, smart, detailed and covers all scenarios.

    I remembered reading this has occurred before and found the last entry Gordon had made:

    I Googled: 'bangle reboots after firmware update'­362367/

    Has holding down all three buttons been attempted?

    Until Gordon returns from Holiday, this was the last recovery attempt solution I had read about.

  • Hello,
    Thank you for the quick reply.

    That post was actually one of my links above under Troubleshooting, it was one of very few references to this exact issue I've been able to locate.
    It's unfortunate no further follow ups have been made in 3 months. I'll leave a comment and see if the user replies whether they found a solution or not.

    Holding 3 buttons did not work. The device returns through the standard sequence. Holding all three buttons through the <=====> progress bar results in either returning through the sequence or it only registers as a BTN1/BTN2 shut down. Abandoning the 3 buttons during the sequence simply enters DFU Start mode.

  • Sat 2021.07.24

    Thank you for the clarification on the results of holding down all three buttons. That tid-bit should assist others.

    The following may not lead to an immediate solution @user132338 but I'm not in sync with the statement: 'That post was actually one of my links above under Troubleshooting' as the only forum post beneath the Troubleshooting heading links to article 346380 'Can't connect Bangle.JS via Chrome' and the link I referenced to 362367 'stuck in reboot loop, after flashing' which are not one in the same. A missed link insertion perhaps?

    Yes, a bit of a nit-pick, but I wanted to make sure all avenues were made available.

    I remember seeing that some were able to resolve weird issues by just letting the battery run down, then recharge. That is a long shot, and may not even lead to a situation that will allow you to continue. But while we wait, might be something to try.


  • Hi - this is a very odd one. Did you try flashing the Cutting Edge build link that you find on­js ?

    The 'SW Reset' means the Bangle.js firmware itself rebooted when it ran, but usually if something has caused it to fail you can just hold BTN1 (top right) down during booting in order to get to the Bangle.js logo where you can then re-upload the JS and fix everything.

    What happens if you hold BTN1 down after Booting... appears on the screen?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Stuck in a boot loop after Firmware update.

Posted by Avatar for c.l @c.l