• I have flashed the Bangle.js twice with the newest FW, espruino2v08
    Now the watch boots to
    FW RESET
    DFU ZYDS
    BOOTING...
    BTN1 = REBOOT

    each attempt to reboot just brings up this screen, or one with WATCHDOG instead of FW RESET

    How can I get out of this boot loop?

  • Sat 2021.04.10

    Seems to be similar issue to what was reported yesterday (2021.04.09):

    "Turn off" function in setting now not working? 2v08.208

    Temporarily switch back to a previous version?

    https://www.espruino.com/Bangle.js#firmw­are-updates
    https://www.espruino.com/Download#bangle­js

  • ok I tried the version 2v07 and I am still stuck at booting...BTN1 = reboot

  • 'ok I tried the version 2v07 and I am still stuck at booting...BTN1 = reboot'

    So, it appears to be code other than that of the firmware itself.

    Have all four scenarios been tried beneath this heading: 'Powering-off' and

    especially heading: 'Resetting without loading any code'

    https://www.espruino.com/Bangle.js#power­ing-off

    https://www.espruino.com/Bangle.js#reset­ting-without-loading-any-code

    It would be of great help to know what was being worked on just prior, that is different enough
    to cause this anomaly.

  • to be fair, I have only repeatedly tried v08 and v07, I would be happy for the solution, but have not tried others yet.
    But the update has not worked for me.
    If someone could show that it was me I would be happy for the solution. But I don't know now.

  • Hi! Does the watch actually show DFU ZYDS (or could it be DFU 2v05?).

    I don't think this is related to that other post, as you're using standard 2v08 firmware.

    And do you know what firmware your watch had before? Was it working ok then, or were there some issues before you updated the firmware?

    What happens if you keep holding BTN1? Can you eventually get to a screen that shows the Bangle.js logo? If so, go to the app loader, and do about -> install default apps

    Also, just to check, where are you getting your firmware from? It is possible to install other firmwares (MDBT42/Puck.js/Pixl.js) which would cause the kind of problem you're seeing - to fix that all you'd have to do is install the Bangle.js one

  • The watch was working before.
    Holding BTN1 keeps me looping. If I hold BTN1+BTN2 I can get the bar going across the screen to reflash. But I haven't gotten further than trying a reflash.

  • I have been getting the Bangle.js firmware from here. And yes I could have read the DFU thing badly sorry! It may have said the version number. The watch strains my vision even with reading glasses lol

    that is a bit funny, I'm sorry if I misread!

  • When you say 'from here', where do you mean?

    Just to avoid doubt, please can you try downloading this file and flashing that?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

stuck in reboot loop, after flashing using nRT Toolbox and newest FW

Posted by Avatar for WilliamV @WilliamV

Actions