Bangle2 : Won't boot up.

Posted on
  • My Bangle2 is stuck at this.

    History: I've just used the watch "out of the box" as clock & alarm for a long time — until I decided to finally update the apps yesterday.

    I did find the website, match bluetooth with the watch, updated apps then it tried to restart and it got stuck there. My phone can't connect to the bangle. The Bangle does not boot up. All I can do is re-boot it back to this same "spot".

    What to do? =)

  • If I press for 2 seconds the 'loading' text and box appears, but it does nothing.
    Pressing for 10 seconds "works" as it restarts the Bangle, but the boot is always stuck at this point.

  • I cannot recall exactly what happened after I updated the apps. Did I try to update the firmware from the "App Loader" ? I think so, but I can't remember!

  • Hi! Have you tried the forum search field? I found this searching for 'boot': Bangle.js 2 won't boot after firmware update. Hope that can help you :)

    You can try searching for 'connect' or other related search terms as well.

  • That was a quite the rabbithole!

    The point is to quickly use the "nRF Device Firmware Update" right after the Bangle 2 displays these two lines:

    DFU Start


  • Yes. The device you need to connect to though, in the nrf app, is dfu targ which is only available while you're on that screen.

  • I'm sorry, you lost me there.

    I assume "the nrf app" is the "DFU" or "nRF Device Firmware Update" by Nordic Semiconductor?

    And what do you mean with "device ... dfu targ" ?

  • The name of the Bangle changes from "Bangle xxxx" to "DfuTarg" when it is in the DFU mode. It is what you need to select in the app by Nordic.

    Bangle.js 2

    Long-press the button for about 10 seconds until the screen goes blank
    While ==== is going across the screen, release the button (releasing it later will just boot back to Bangle.js)
    The watch should now be in DFU mode

    You can find the complete description here:­#android-ios-app

  • Woooot! It's working! (I think. Knock on wood.)
    Updating .... 45% ...

    ... And done! And the Bangle seems to be working!

    I am much obliged to those who helped: halemmerich, johan_m_o and Ganblejs ! ♥ ♥ ♥

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle2 : Won't boot up.

Posted by Avatar for user151641 @user151641