Bangle.js 2 stuck in bootloop. dfu flashing did not help

Posted on
of 2
/ 2
  • I have tested @Gordon 's idea­/384817/#16909373 and it works, github makes the build for you without having any build environment. I have forked Espruino into new patch-1 branch by trying to edit the BANGLEJS2 board file. And then it was enough to create 'fake' pull request to my own main branch (not to upstream Espruino so it does not pollute it with extra PR).

    The changes I did are here­/5/files
    and the result is here REMOVED, see bottom of edited post
    just try the "BANGLEJS2" build if you trust it.

    Basically I copied the BANGLEJS2_NOFLASH board file to BANGLEJS2 because that one is built as part of the workflow. Then it showed it actually does not build as is­ons/runs/4501570382/jobs/7922189470 so I needed to trim some stuff down in second commit.

    After you download it I will close the pull request without merging. Too bad it is not possible to abandon/delete pull request completely on github.

    EDIT: another build (third commit) here, with removed initial factory content there is 80KB more available for storage­ons/runs/4501950691#artifacts

  • Thanks, I downloaded the BANGLEJS2 build.

  • Thanks, I downloaded the BANGLEJS2 build.

    And does it work?

    If you have github account you can also make the build yourself any time in the future as I described. Before creating pull request you just need to "enable allow actions and reusable workflow" for your forked Espruino repo as per attached picture. After making pull request and letting it do the builds you can disable it again if you want it disabled. It looks like this is free service of github, not sure what are the limitations.

    1 Attachment

    • Clipboard01.jpg
  • Thanks for documenting this!

    It looks like this is free service of github, not sure what are the limitations.

    Well, if I haven't hit limitations yet, I doubt you will! It does seem 'too good to be true' really :)

  • I will try tonight, I am in London this week, forgot to bring a charge cable and yesterday the watch ran out of battery... Thanks a lot for your hep

  • It did not work, tried it a few times via the Android DFU app and got an error (see attached). Then I tried it this morning using the Web IDE but that tried to flash the default v17 automatically before I could select the file. I hit the cancel button but that was a mistake because now I the watch is not doing booting properly anymore and I get a bank0 invalid message. I cannot connect to the watch anymore, so I guess it is bricked?

    1 Attachment

    • signal-2023-03-27-111335_002.jpeg
  • Not bricked, you still have the DFUTarg device so you need to repeat/finish the DFU. Just checked and it looks like the build artefact is zip inside zip! Please unpack the and use the­ inside for DFU.

    Also if that zip would not work you can recover via some official Bangle2 zip from

  • Flashing the unpacked file worked, however it is now showing "Erasing Storage area..." for about 2 hours already and it does not seem to complete. How long should this take maximum?

    2 Attachments

    • signal-2023-03-28-112244.jpeg
    • signal-2023-03-28-103702_002.jpeg
  • I disabled bluetooth on my phone and noticed later that the watch had booted. It seems to be completely empty though. 0 apps installed.

    1 Attachment

    • signal-2023-03-28-115707.jpeg
  • Yes, it is completely empty and you need to upload stuff again. You stopped using external 8MB SPI flash storage and now you are using small internal flash - only about 480KB free. This is enough for few apps but not for much so not sure how many apps will fit.

    It even does not contain the initial flash content because you would otherwise have two copies there and I hope it is not needed(?) and everything can be uploaded via app loader(?)

    @Gordon is it OK or is this­b/master/boards/ needed to be there as the initial content is not part of the app loader upload?

    @Ocim in case the default content I removed in last build is really needed and you won't get it working with just the apploader you can take previous build which still has is (and the storage is smaller)­ons/runs/4501685793#artifacts

  • It works, I loaded 10 apps and it seems fine. more responsive even, compared to the old version

    Device Type BANGLEJS
    Firmware Version 2v17.2437
    Apps Installed boot (0.57), berlinc (0.07), launch (0.20), messageicons (0.05), messagegui (0.65), widmessages (0.04), messages (0.58), android (0.23), setting (0.59), widclk (0.07)

  • Great!

    more responsive even, compared to the old version

    And yes, it would be - internal storage is a lot faster. It's just you get a lot less of it

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js 2 stuck in bootloop. dfu flashing did not help

Posted by Avatar for myxor @myxor