• Hiya, in the last few days alerts have not appeared on my bangle2, and my (android) phone tells me the gadgetbridge app/plugin isn't on the watch.

    I was running the android app on the watch, successfully, until the last couple of days.

    For now I've 'fixed' it by shifting back to the gadgetbridge app.

    Have I messed up a setting, need to update something, or missed something easy?

  • Thats weird, it works fine for me. I just installed Android Integration, which automatically installed Messages.

    The Bangle Firmware is up to date for me, maybe you have a newer Gadgetbridge app installed? I have Version 0.63.0

  • Hi, I have observed the same issue on my Bangle.js 2. I am running:

    • Firmware 2v11
    • Android 12
    • Gadgetbridge 0.63.1

    I didn't try switching to the old GadgetBridge app yet.

  • Same firmware and android. I would blame the new gate bridge update, can you try downgrading?

  • I just tried but without success. I also tried wiping Gadgetbridge and its settings completely, doing reboots of both the watch and and Android device, enabling programmable and all with the previous version (0.63.0) as well but no luck so far.

  • I'm on GB 0.63.1. Downgrading to 0.63.0 now...
    0.63.1 has in the changelog: bangle.js: fix crashes when playing music with some players.
    So they might have tweaked a setting that makes the android app invisible, or something.

  • Success-ish - factory reset the watch, paired with Gadgetbridge 0.63.0. When I get a breather I'm going to attempt to upgrade GB and see if it still works.

  • Just installed GB 0.64 after a week or so of not using it. It works fine. I am on 2v11 firmware and latest Android app. When I tried to setup weather notfications it would not work at first. Was going to do a factory reset but then noticed after 30 mins later that it had started to work.

  • I see this error from time to time, and messages stop working. Shutting down and restarting the watch seems to fix it, at least for a while.

  • Which Bangle do you have, and is your watch firmware (both the JS and the actual watch) up to date?

    It's possible that the Gadgetbridge message is causing an error (maybe because of low memory, or a conflicting app?) and that's causing the problem.

  • I have a similar error with firmware version 2v13 and Gadgetbridge 0.66. Attaching a screenshot for some more context. Notifications (besides the calls which is getting fixed in GB 0.67) are working. With regards to the activity tracking Gadgetbridge is not working so reliable, some functions seems to be unsupported. I am not sure if it is Gadgetbridge, the Android integration or the Bangle.js 2 watch itself, any user configuration or even a combination.

    1 Attachment

    • Screenshot_20220520-114029_Gadgetbridge_s.png
  • The 'Gadgetbridge plugin not installed' error happens when some code running on the watch produces an error. It's possible that some app installed on your Bangle is producing errors.

    You could try setting debug = log in settings -> utils, then using it for a bit and connecting with the Web IDE to see if there's anything in a file called log.txt that would give you some ideas what was going on

  • I had this after installing the bangle.js gadgetbridge app on my phone. Was fixed by removing and reinstalling the android integration and messages apps on the watch.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[android app] "Gadgetbridge plugin is not installed on bangle.js"

Posted by Avatar for jimr1603 @jimr1603