RAK5010 NB-IoT Tracker

Posted on
of 3
/ 3
  • Yes that's the RAK5010, did you fork the RAK8212 board easily? will it be released officially?

  • Yes, I'll be doing an official port.

    Actually doing it properly is a bit more involved - because it's using the nRF52840 instead there's a bunch more RAM & Flash available (and USB) which I'd like to be able to expose.

  • Yes, I just flashed the .hex file and it worked except for the BG96 module.

  • Hi Gordon,
    I need to activate the GPS power supply on the Rak5010.
    The rakwireless doc says to set the pin P1.07 to activate the power supply.

    But the P1.07 pin is not included into the RAK8212 espruino version.
    How can I add the missing pin?
    Thanks in advance ;-)

  • I solved by using the poke32 to set/clear the P1.07 pin like this:

    poke32(0x50000300 + 0x518, 1 << 7);
    // set
    poke32(0x50000300 + 0x508, 1 << 7);
    // clear
    poke32(0x50000300 + 0x50C, 1 << 7);

    But the gps response was always:

    {"error": "Timeout"}

    The http get request always returns:

    {"code": -15, "message": "no response"}
  • The BG96 issue is solved by switching the RX and TX pins within Serial setup:

    Serial1.setup(115200,{tx:PINS.LTE_RXD, rx:PINS.LTE_TXD, cts:PINS.LTE_RTS});

    Now the BG96 get GPS positions and the http get request works on Rak5010!

  • Great, can't wait to do my project with Espruino, seems to be much straithforward than Arduino...

  • @Gordon any update on when you might get to having a look at this build ? Realise you are juggling a lot, just interested in an updated ETA

    I have a rak5010 sitting here ready to go !

  • Thanks - I'm a bit busy right now. Maybe next week, but I'm not sure.

    Basically the nRF52840 build didn't boot up on it so I need to figure out what the issue is. Once that's done things should progress quite nicely.

    But even if you used @LorenzoG's solution I guess you could transition to a proper build pretty easily when it became available.

  • Its ok right now as I also have a rak8212 which I am currently developing on - but having access to more flash/ram will help with new features I need to add. Will the Flash module have access to more space ? We currently use that for our logging data.

  • Hi @Gordon just another little check in for an ETA update ?

    I see that the nrf52840 has 2x UART, will those both be available ? Will be really useful to be able to debug BLE comms whie one serial port is allocated to the BG96


  • Hi - things are calming down a bit here, so I'm looking at this now.

    And yes, you'll get 2 UARTs :)

  • Ok, I have something more or less working. See the attached - I'll have to get back to this later though.

    Accelerometer/opto/gsm access. No USB yet though as for some reason that's not working.

    You should have access to the on-chip flash, of which there is more. I'll see about the SPI flash - if it's easy, otherwise there is a JS module for it

    1 Attachment

  • @Gordon thanks so much ! I have it up and running. The number of variables needs bumping up for extended RAM, will let you know what else I find

  • The number of variables needs bumping up for extended RAM

    Yes, thanks - that was just while testing, I'll get that raised :)

  • Is the flash_code_start in the correct place at 966656 ?

    On the MDBT42 I use the space between flash_binary_end and flash_code_start for the "flash" module for word level logging. But I dont want to end up going up into where the Storage module is putting things ?

  • Is the flash_code_start in the correct place at 966656 ?

    Yes, that sounds about right. On newer builds I'm increasing the flash though, so that'll change - but if you go before flash_code_start you should be fine.

    There's also a dedicated 8MB flash chip which I'd hoped would be compatible with http://www.espruino.com/W25, but sadly I'm not having any luck with that so will leave it for someone else with more time :)

  • Ahh. I'm not having success with the SPI flash because it's not installed!

  • nrf52840 has so much flash, would be good to have more allocated to Storage region, as that would be good place to store remote software updates

  • Right now I bumped it to 80k, but it could easily be substantially more

  • Ok, just merged in - so you should start to see Travis 'cutting edge' builds now

  • @Gordon I am having problems with the BG96 not accepting some AT commands eg AT+CFUN=1 and AT+CFUN? returns 5 which is not even a documented state. It seems like it is in some non-active state.

    I wondered if it is in airplane mode (LTE_WDISABLE pin) - had a quick look but that seemed OK. Did you manage to check if the BG96 was actually working ? I am just not sure if my BG96 has an issue or whether some of the signals from nrf are not in the correct state ?

  • I didn't, no. I did the modem testing bit, but that was it: http://www.espruino.com/RAK5010#modem-te­sting

    There's W_DISABLE, which seems to be an airplane mode. You could try that? The default should be enabled though.

    Also looks like GPS_EN might need modifying for GPS...

  • OK it looks like my BG96 got shipped to me still in a factory test mode - so once I got out of that things are working again !

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

RAK5010 NB-IoT Tracker

Posted by Avatar for peruperu @peruperu