• --flash_size 4MB-c1

    for all 4MB board features

    I tried

    esptool.py --port COM4 --baud 460800 write_flash --flash_freq 80m --flash_mode qio --flash_size 4MB-c1 0x0000 "boot_v1.6.bin" 0x1000 espruino_esp8266_user1.bin 0x3FC000  esp_init_data_default.bin 0x3FE000 blank.bin


    esptool.py --port COM4 --baud 460800 write_flash --flash_size 4MB-c1 --flash_mode dio 0 .\espruino_1v99_esp8266_4mb_combined_409­6.bin
  • Hm, are you connected to your local network and are without internet access?

    If yes disconnect and try the WebIDE again.

  • I have the same problem and spent 2 days for solve it, but no results at all.
    I tred

    esptool.py --port COM3 --baud 115200 write_flash --flash_freq 80m --flash_size 4MB-c1 --flash_mode dio 0x0000 espruino_2v04_esp8266_4mb_combined_4096.­bin


    esptool.py --port COM3 --baud 115200 write_flash --flash_freq 80m --flash_size 4MB --flash_mode dio 0x0000 espruino_2v04_esp8266_4mb_combined_4096.­bin

    but have the same results.
    Flashing Ok, Putty connection Ok, but WebIde connection is really bad. I have garbage text and error message :(

    Board: 2AL3B-ESP-F (RoHS ESP-12N)
    Baud rate was checked twice, I also tried to use ESP8266Flasher and FLASH_DOWNLOAD_TOOLS_V3.6.4 but the same result.

  • Tue 2019.08.13

    Hi @seometis, as you are seeing the 'Espruino' splash banner, it appears you are connected, as that text is clearly visible.

    What are the results of process.env and process.memory() after the splash banner? Please post those results.

    'Baud rate was checked twice'

    Just to confirm so we all are on the same page, what is the baud rate? WebIDE >> Settings >> Baud Rate

    What PC and OS ver are your running? Win10/Mac/Linux

    'I have garbage text and error message :('

    What is the error message?

    "boot_v1.6.bin" missing from flash command. Was the source in the correct location?

  • WebIde baudrate must be 115200

    change dio to qio

    As chip is 4016 use 4MB firmware

  • Hi @Robin and @MaBe! I use Windows 8.1 based laptop.
    I've downloaded firmware espruino_2v04_esp8266_4mb, runed command

    esptool.py --port COM3 erase_flash

    Success. Then I runed command:

    esptool.py --port COM3 --baud 115200 write_flash --verify --flash_freq 40m --flash_mode qio --flash_size 4MB-c1 0x0000 "boot_v1.6.bin" 0x1000 espruino_esp8266_user1.bin 0x3FC000 esp_init_data_default.bin 0x37E000 blank.bin

    According esptool everything is fine and flashing success and verifying is also success. After reset the board, i connected via putty and runed commands:

    What does it means FLASH: 0? I can't use storage to put my own code? :(

    Now I've tried to connect using WebIde and see the same error:

    In settings => communication, Baud Rate is 115200.

  • Tue 2019.08.13

    I'm glad our suggestions assisted in finding a solution that worked.

    Thank you for posting the baud rate confirmation.

    'What does it means FLASH: 0?'

    I'll agree that is an area to review. I did the test on a WiFi:

      "VERSION": "2v04",
      "GIT_COMMIT": "3956264e",
      "FLASH": 524288, "RAM": 131072,

    Maybe that setup script still needs an argument change? I'm not able to offer a solution as I'm not an ESP32 user. To others, the amount of free mem does appear suspicious. Is anyone able to post their output for comparison please.

    'Now I've tried to connect using WebIde and see the same error:'

    I believe you have a different situation and not the same error. How is it being determined that the error is the same? I see the board detail just isn't returned.

    I have occasionally run into that scenario. Have you attempted to just restart the WebIDE? I see the Com port is recognized.

    More detail might be obtained by reviewing the WebIDE error console.
    WebIDE >> Settings >> Console

  • Flash is ok.

      VERSION: "2v04.6",
      GIT_COMMIT: "c2087d40",
      BOARD: "ESP8266_4MB",
      FLASH: 0, RAM: 81920,
      SERIAL: "18fe34d1-8934",
      CONSOLE: "Serial1",
      MODULES: "Flash,Storage,hea" ... ",ESP8266,neopixel",
      EXPTR: 1073643644 }
      { addr: 2097152, length: 1048576 },
      { addr: 3145728, length: 262144 },
      { addr: 3407872, length: 262144 },
      { addr: 3670016, length: 262144 },
      { addr: 3932160, length: 241664 }

    Restarting the Web IDE and reconnecting the board should fix the serial connection.

  • Did you compile your own version, having Flash and Storage and in your build? Storage isn't included in the ESP8266 build, or at least it wasn't in the past.

  • Wed 2019.09.14

    Thank you for posting that test @maze1980, so it appears for the ESP8266 build that process.env does in fact return a '0' value.

    ' representing contiguous areas of flash '

    It appears this is going to take a bit of study, as I don't see how these apply when they don't agree. (WiFi board here though)

      { addr: 134234112, length: 49152 }
      "FLASH": 524288, "RAM": 131072,
    524288 / 16 = 32,768
    524288 / 12 = 43,690

    Not intending to muddy this thread with another issue, just posting an observation for @seometis to test and observe.

  • AFAIK the FLASH in process.env shows the total amount of flash on the chip. Defined in boards/BOARD_NAME.py. If I'm right, that is kind of irrelevant from the end users's perspective.

    The ESP8266 has all kinds of funky flash parts, I think that's the reason there are multiple free flash regions. For STM32 and nRF parts, the free flash area is continuous.

  • I've found a good solution to my problem. Just flash ESP8266 to standard ROM and put it into the garbage box. And then I've taken ESP-32 board and have no problem. Now I can make my first Espruino project. :)

  • ...a bit unfair to this little, cute guy: Espruino on ESP8266 ESP-09 - 1 powerful cm2

    As engineers wisely respond: "It all depends..."

  • ...a bit unfair to this little, cute guy

    Absolutely. ESP8266 was a game changer. It's almost a pity that TLS is the norm nowadays - for that is its Achilles heel.

  • Did you try Flasher.js? It's been quite bomb proof for me

  • I have the same issue, I can flashbut and connect with putty with 115200 but the IDE thinks its not connected because of the trash before the ASCII art Espruino at the start of the response.
    Could it be because i have a WIFI-ESP8266+ with 32MB flash?
    Did anyone manage to resolve it?

     ____                 _
    |  __|___ ___ ___ _ _|_|___ ___
    |  __|_ -| . |  _| | | |   | . |
    |____|___|  _|_| |___|_|_|_|___|
             |_| espruino.com
     2v04 (c) 2019 G.Williams
    Espruino is Open Source. Our work is supported
    only by sales of official boards and donations:
    Flash map 4MB:512/512, manuf 0xc8 chip 0x4016
  • @FloSax Use the 4MB image for your ESP8266 because chip is 0x4016.

  • thank you for this info.

    now i tried the other flasher tool, with the following command:

    esptool.exe -cp COM2 -cd nodemcu -ca 0 -cf espruino_2v04_esp8266_4mb_combined_4096.­bin

    it went to 100% without complaining. but in this state the device only returns garbage.

  • I recieved a different board ... but its also an ESP8266EX where i get the same issue:
    Flashes OK with different flashers and arguments, but allways spits jibberish before the espruino ASCII art and the green putty input cursor only works sometimes before the first reset.
    after any power out (also button reset) the console is unresponsive.
    Could it be the EX version or maybe something with the serial interface CP2102?

    Anyone got a working EX version?

    Detecting chip type... ESP8266
    Chip is ESP8266EX
    Features: WiFi

    here the boot output from baud 76800

     ets Jan  8 2013,rst cause:2, boot mode:(3,7)
    load 0x40100000, len 2408, room 16
    tail 8
    chksum 0xe5
    load 0x3ffe8000, len 776, room 0
    tail 8
    chksum 0x84
    load 0x3ffe8310, len 632, room 0
    tail 8
    chksum 0xd8
    csum 0xd8
    2nd boot version : 1.6
      SPI Speed      : 80MHz
      SPI Mode       : DIO
      SPI Flash Size & Map: 32Mbit(512KB+512KB)
    jump to run user1 @ 1000
    rf cal sector: 1019
    freq trace enable 0
  • output of both my devices:

    NODEMCU Amica

    ▒2r▒▒l▒N▒▒N▒d ▒▒r▒$▒$▒
     ____                 _
    |  __|___ ___ ___ _ _|_|___ ___
    |  __|_ -| . |  _| | | |   | . |
    |____|___|  _|_| |___|_|_|_|___|
             |_| espruino.com
     2v04.91 (c) 2019 G.Williams
    Espruino is Open Source. Our work is supported
    only by sales of official boards and donations:
    Flash map 4MB:512/512, manuf 0x1c chip 0x3016

    WiFi ESP8266+ 32M flash

     ____                 _
    |  __|___ ___ ___ _ _|_|___ ___
    |  __|_ -| . |  _| | | |   | . |
    |____|___|  _|_| |___|_|_|_|___|
             |_| espruino.com
     2v04 (c) 2019 G.Williams
    Espruino is Open Source. Our work is supported
    only by sales of official boards and donations:
    Flash map 4MB:1024/1024, manuf 0xc8 chip 0x4016

    hope my ESP32 will arrive soon

  • output shows ‘dio’ for spi mode


    --flash_mode qio

    check README_flash.txt for proper flash commands.

  • I finally got it to work on both ESP8266EX

    Flash with the command:

    esptool.py --port COM8 --baud 115200 write_flash --flash_freq 80m --flash_mode dio --flash_size 4MB-c1 0x0000 espruino_2v04_esp8266_4mb_combined_4096.­bin


    In Espruino Web IDE make sure baut is set to 115200

    Connected to the COM port of the device, it complains, just press connection button in the IDE to dis- and reconnect.

    now i had a working input cursor.

    Save some "known to be working" javascript:

    setInterval( "NodeMCU.D4.toggle()", 500);

    i just activated a blinking LED to see the working state

    Write the interpreter space of the device with:


    Now power-off the device or use the hardware reset button, the LED should be blinking again.

    The working state was now stable, also when deleting the saved JS code with a reset();

  • @FloSax I think you'll agree then that the post I did last month should be pinned to the top so you would have be able to play with your 8266 without waiting for weeks to get it working:


  • Which version can i use for 0x6014 chip?
    I have same problem, I can flash my ESP-01 successfully but I can't connect with IDE with ubuntu environment.

    2 Attachments

    • ide.png
    • terminal.png
  • Looks like you didn't switch baud rate from 9600 to 115200 in settings which is mandatory for unsupported ESPs devices

    1 Attachment

    • Bildschirmfoto 2020-06-03 um 10.05.36.jpg
  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

I can't get started. Flashing seems OK, Espruino Web IDE not connecting.

Posted by Avatar for Neptune443 @Neptune443