• Baud rate was the first thing i have changed.

  • Ok, so maybe another process is blocking the serial port.

  • Here is the console message.

    1 Attachment

    • Képernyőkép – 2020-06-03 10-15-38.png
  • Seems to be that the console show that connectioninfo undefined but show the usb serial adapter in the device list.

  • Have you tried the same with the online WEB IDE https://www.espruino.com/ide/

    I am running Chrome App, v0.73.7 without any problems.

  • no ports found :(

  • I try app version 0.72.1.

  • Uhhhh...this problem come from ubuntu permissions.
    Need to change serial port permissions i.e.

    sudo chmod a+rw /dev/ttyUSB0

    to enable serial port read and write.

  • It's works well :)
    Thank you for your replies :)

    Thank you, thank you :)

  • Need to change serial port permissions

    or add your user to dialout group

  • yes, working both solution

  • I tried all the appropriate commands in flashing and properly set the baud rate to 115200 but didnt connect on windows 10

    seems like i did setup using kali linux image using VM inside windows 10 , it worked like a charm and did connect without any problems

    then i uploaded this code

    var wifi = require("Wifi");
    wifi.connect("my-ssid", {password:"my-pwd"}, function(err){
      console.log("connected? err=", err, "info=", wifi.getIP());
      // Make this persistent across power cycles.

    take a note of the ip address from left console ( check attached image )

    then i setup espruino web ide to use over TCP for programming

    1.Click on the Gear icon on the top right corner of the screen.
    2.Now go to Communications on the left.
    3.In the Connect over TCP Address input box put the IP address you got when setting up WiFi. Then close the window.

    4.Now click on the Plug icon on the top left corner of the screen. Select the TCP/IP option.

    Got it working on windows now...

    So , web ide wont connect on windows 10 using serial , use linux

    1 Attachment

    • esp8266.PNG
  • For my d1-mini clone boards I discovered I have to disable the Software Flow Control in the communications settings section in order to have reliable USB connection.

  • This saved my ass. Thanks.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

I can't get started. Flashing seems OK, Espruino Web IDE not connecting.

Posted by Avatar for Neptune443 @Neptune443