espruino pico bootloader mode doesn't work

Posted on
  • Hey y'all,
    I've plugged in my espruino pico with BTN1 held down, but both LEDs light up and don't play the fading animation. I've tried everything in the troubleshooting section, as well as resetting my Macbook's USB ports. The code I put in last still works, so I think it's a USB problem, but other devices work perfectly on my Macbook.
    This all happened after i successfully reflashed my Espruino Pico and save()ed a program on it. Everything worked great until after about an hour or so.

    Help!

  • Can you connect to the Pico fine when it's out of bootloader mode?

    Do you have a USB extension lead you could try using? Also any chance you could try on another computer? All you need to do is verify that the LEDs do the pulsing thing.

  • I've tried a windows PC, same result. I've also tried using an extension cable and no, it doesn't work even when it's out of bootloader mode. The code seems to work well, it just doesn't show up as a serial port on both computers.
    I've hooked up a usb-serial converter to the UART1 pins on my Pico and while it shows output(I had a program on it that spit out a string when I pressed a button), I can't type anything to it. However the '>' prompt still shows.

  • Could you have a go at cleaning the USB connector? Just a normal eraser ought to do it, but Isopropyl alcohol is perfect.

    The fact that it runs and outputs on Serial makes me think there's unlikely to be much wrong with it - they usually work or they don't. Did you have it plugged into any other hardware, or was it just sitting there working and then it stopped?

  • I tried loading custom firmware onto the pico. The firmware doesn't work. No problem, I can just load Espruino on it, which I successfully do. I load a sample .js file and run it, and no problem, it runs just fine.
    However, about 40 minutes later, it stops working. During those 40 minutes I didn't touch the Pico at all and it wasn't hooked up to any power source.

  • How did you upload the custom firmware? Did you just use the Espruino bootloader to do it, or DFU?

    I guess it's possible the bootloader has got corrupted somehow.

  • I used the command line with the stm32loader.py script.

    python stm32loader.py -k -p /dev/tty.usbmodem1411 -evw espruino_1v99.3969_pico_1r3.bin
    

    is what I used.

    Also all I changed in the firmware was the Banner to say something else.

  • You could give this a try and it'll replace everything - including the bootloader: http://www.espruino.com/Pico#advanced-re¬≠flashing

    Use a proper release (not a cutting edge one), as I don't think the cutting edge ones contain the bootloader.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

espruino pico bootloader mode doesn't work

Posted by Avatar for user73202 @user73202

Actions