Relay not working

Posted on
  • What I'm experiencing when I use one of these­-Relay-Module-Board-Shield-For-PIC-AVR-D­SP-ARM-MCU-Arduino-/310566336050?pt=LH_D­efaultDomain_0&hash=item484f323632 is the GPIO is being forced HIGH even with a digitalWrite(A2,0); ... the relay will toggle if I physically disconnect the pin, but the micro isn't able to toggle the output of the pin... any advice? I did get the relay to work once before while using pin C9 which is 5v tolerant instead A2 which is not 5V tolerant, however the tutorial­r used a pin that was definitely not 5V tolerant and it worked so I'm assuming something else is going on...

  • Ahh, sorry, you're totally right. Pins need to be 5v tolerant, or the relay has trouble turning off. I vaguely remember that some work and some don't.

    To fix it without using 5v tolerant pins, you could disconnect the jumper that's usually on the relay board and supply 3.3v to the data side of it, but 5v to the relay itself.

  • Are there any components on the underside of that? Specifically, is there anything black with three pins? I found another picture of what I think is the same board with nothing on the underside.

    If not, there's no drive transistor. The description suggests that as well.

    It claims 15-20mA to turn on which is possible from the Espruino board, barely... When just power and ground are connected, is the "in" pin at 5v or 0v?

  • I'm now trying to wire the same relay, and am having trouble getting it to click with a 5V digital ouput signal from an Arduino UNO board. Some sources suggest connecting VCC and GND to Board 5V and GND, respectively, while other sources insist an independent 5V power source for relay VCC and GND is needed.....?

    When my intended 5V digital output pin(2,4) is 5V, relay is dead.
    When my intended 5V digital output pin 2 is 0V, relay is dead.

    I managed to get the relay to click ,(Relay VCC and GND to board 5V and GND), using signal pin TX->1 from the UNO board to Relay IN1.
    When my TX pin is 5V, relay is dead.
    When my TX is approx 2.5V, the relay clicks. Is this relay truly a 5V relay as advertised?

    3.3V? I tried powering the relay with UNO 3.3V source, and the relay power LED is still bright, but my UNO's digital output still gets no click, not even while using the TX pin.
    Relay cannot be powered with 3.3V.

    I happen to have two UNO boards, and tried both @5V in case I had fried the first, the results were repeatable using both UNO boards.

    I'll need to dig deeper into the TX pin's function, to figure out what signal this relay wants to click. It responds to my loop delay, (2sec delay gets a relay click every 2 seconds) My present understanding is that TX is a serial communication pin, which usually teams with pin RX(no click using RX) for I2C, etc serial networking. Does the TX pin push more current than the digital output? Should I try PWM? TBD.....

  • My relay now works fine, defining my pin's mode as an output fixed my issues, I had disabled it with a "//" while exploring other coding options. Note that the LOW pin state makes the relay click.

  • This you-tuber helped me find my error­oXQ

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Relay not working

Posted by Avatar for user52526 @user52526