Micro:bit v2 + neopixel - just hangs?

Posted on
  • Hi guys!

    Wanted to do some coding with my kids, and tried latest Espruino on a Micro:bit (v2.00, DAPLink firmware updated). Basic things seem to work, but when I tried a simple neopixel write, it just hangs. Even require("neopixel").write(D1, [255, 0, 0]), it just hangs.

    Tried 2.19, 2v.18, 2v.14, 2v.11, 2v.08, same behaviour.
    Did anyone use neopixels on the Micro:bit?

  • Hi - please can you give the latest cutting edge build a try?

    The nRF52 has an issue where it needs a few other pins to be set up (just to other GPIO that aren't connected) in order to make the I2S peripheral work. Those weren't set up before but I've just tried to find two unused GPIO and put a change in and hopefully that'll fix it for you https://github.com/espruino/Espruino/com­mit/072a066dcb94ab7eab775267c5d91420f86e­79f6

  • Works with the latest edge build \o/

    Thank you Gordon!

  • Great! Thanks for letting me know!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Micro:bit v2 + neopixel - just hangs?

Posted by Avatar for AkosLukacs @AkosLukacs