• I'm new here and this is my first foray into the world of Espruino.
    I'm trying to run https://www.espruino.com/ide/ on:

    Opera One(version: 104.0.4944.36)
    System:Debian GNU/Linux 12 (bookworm) (x86_64; KDE)
    Chromium version:118.0.5993.118

    But the yellow(or green) connect icon is completely missing on the top left of the screen.

    Instead of Opera I've tried Chrome on the same PC and it works fine so this seems to be an Opera specific thing.

    On Opera I've enabled the experimental & Web bluetooth flags described, but this issue seems more fundamental than that as I'd expect the connect icon to be there to allow selection of Web Serial & Emulator even if BT wasn't working.

    Reading the forum posts most problems people have seem to be to do with getting the BT bit working rather than trying to get the connect ion to appear.

    Anyone else bumped into this? Any thoughts as to what might cause it?

  • Hi - I just installed Opera on Linux here and the IDE works for me!

    One thing I noticed looking at the site was Opera advertises Ad Blocking - a while back someone else had a problem with the IDE buttons not appearing caused by and Ad Blocker, so you could try disabling it? (it wasn't on Opera though)

  • Well that was right on the money, thanks Gordon. It absolutely was the "Block social media icons tracking" option of AdBlockPlus (even though it shows "number of items blocked on this page: 0" which seems weird). There are 4 icons displayed on that top bar, the other 3 display fine. I wonder why the ad blocker picks on the connect icon in particular.

  • Have the same issue on MacOs 13.5.2. I've tried 5 different browsers: Arc, Chrome, Firefox, Opera, Brave, they all have this problem. https://imgur.com/a/fgOscHu

  • The same picture. There are no buttons or some icons in any browser on Windows 10!

    1 Attachment

    • 000.PNG
  • These are the results from the Chrome Debug Console

    1 Attachment

    • 001.PNG
  • Sorry about this - it was a recent update to secure DFU that broke it. The IDE worked for testing on its own, but when packaged up into one JS file an error in the secure DFU code stopped everything else from loading.

    I've fixed it now.

  • I've fixed it now.

    The IDE at https://www.espruino.com/ide/ doesn't work even after the fix. The https://espruino.github.io/EspruinoWebID­E/ version seems to have no problem.

  • As above - try hitting refresh

  • If you're on Chrome, it might help to press and hold the reload button, then click on "Empty cache and hard reload".

  • Now everything works, thanks! Seems like a problem with browser cache.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino IDE missing connect icon top left, Opera on Linux

Posted by Avatar for timw @timw