Bangle.js 1 - Cannot access settings

Posted on
  • I have the latest stable 2v19 firmware, but I can’t access the watch settings. When I click the menu item, the wtach freezes before the menu shows up. I have tried resetting the phone, deleting all the apps and reinstalling them, but nothing works.

    Has anyone else had this problem and knows how to fix it? :)

  • You updated the firmware, but have you updated all your apps as well?

    I just tried here on a Bangle.js 1 and it works great.

    Assuming you have updated all your apps and it still happens, can you connect with and then try and enter settings, and see if it shows any errors?

  • Thanks for your kind reply, Gordon!

    I encounter this error in the IDE while attempting to access the settings:

    Uncaught SyntaxError: Got EOF expected '}'
    at line 90 col 593 in

    and the screen gets stuck on "loading..."

  • Well, that's odd - that error's definitely in Settings but when running it here it seemed to work ok.

    If in the app loader ( you go to More... and Advanced Options do you have:

    Minify apps before upload (⚠️DANGER⚠️: Not recommended...)

    Checked? If so, please uncheck it and click Reinstall apps

  • Hi Gordon,

    That's odd, I agree. Minify apps was unchecked, but I tried removing and reinstalling everything anyways, and I'm still seeing this error in the Web IDE:

    Uncaught SyntaxError: Got EOF expected '}'
    at line 90 col 593 in

    Any other ideas / suggestions? :)

  • I'm still really struggling to reproduce this, either with or without pretokenisation.

    And you're definitely updating the apps from and not your own personal app loader?

    Please could you do a 'Backup' from the app loader and email me the zip (if you're happy to do that - it's a complete copy of what is on the watch so could contain some personal info) - I can then attempt to reproduce it here.

  • Thank you so much Gordon. I can confirm I'm using the official app store. Sending you a backup to right now, via WeTransfer :)

    Again, thank you! :)))

  • Same here with BJS2.
    Happened after update from 2.18 to 2.19.
    To resolve it I updated the apps to latest; uninstalled and installed the settings app. All System settings were gone, but I can now access the settings fine...

  • Thanks for the backup! Just installed and I can reproduce.

    But it looks like you had Translations enabled. I just tested again here - if you enable translations and re-upload it breaks, but if they are disabled it's fine - so it should be easy enough for you to get working again.

    @Hank could you have been using translations too?

    Issue reported here too:­ues/2417

  • Ok, it should be fixed now in the development app loader.

  • Thanks a lot, I can confirm everthing is working when using English :)

  • Yes, I used translations.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js 1 - Cannot access settings

Posted by Avatar for fparri @fparri