• I am a newbie who got EspruinoHub working a while ago but broke it with updates.
    I have been trying to get it working with the latest releases with too many problems to mention.
    In my use of Raspberry Pi Imager I noticed today that there are new OS options and after Googling I found...

    “New” old functionality with Raspberry Pi OS (Legacy) 2nd Dec 2021
    Gordon Hollingworth

    I am prepping my SD card now.

    What hardware is best? Zero, Pi3B+, Pi4?
    Should I even try?

    Thanks from a first time poster,


  • Hi, Sorry for the delay - I missed this!

    EspruinoHub should work fine on any of the Pi versions. A Pi Zero W makes a nice tidy installation but the install will take quite a bit longer :(

    Otherwise I believe they all use basically the same Wifi/Bluetooth chip so should all work about the same

  • Ah that link is useful. I had trouble installing EspruinoHub on a Pi Zero W recently. The issue was related to nodejs in Raspberry Pi OS stable. I might have another go with Legacy before going down the AlpineLinux route.

    Maybe having pre-prepared images for raspberry pi's would be useful?

  • Maybe having pre-prepared images for raspberry pi's would be useful?

    I guess we could suggest a specific firmware version that works.

    ... while it'd be useful, the effort of doing that vs the number of people that actually use EspruinoHub probably means it's not worth it...

  • Thanks @PuckU for this pointer. Was also having a heck of a time getting this installed, with lots of versioning errors. Legacy Raspbian seemed to work, at least with a lot fewer errors.

  • I have Espruino Hub working on both a Raspberry Pi Zero W and Raspberry Pi4.

    I prefer the Raspberry Pi 4 because it runs the python commands I am using with Node-Red faster. I am using the PuckJs to toggle on and off my TP-Link Kasa smart bulbs and sockets via Node-Red and the "python-kasa" library.
    It works a lot faster than IFFT and does not require TP-Link cloud services over the internet.

    I am still having an issue with autostart on boot...

    [Config] Config config.json loaded
    [HTTPProxy] config.http_proxy=false, not enabling Bleno/Proxy
    [MQTT] Connecting...
    [HTTP] Server is listening on http://localhost:1888
    [HTTP] www directory found at /home/pi/EspruinoHub/www. Web server at http://localhost:1888
    [History] history_path value is empty, thus not providing history.
    [MQTT] Connected
    [Discover] Re-sending presence status of known devices
    [MQTT] Write to f7:e3:xx:xx:xx:xx but not in range
    [Discover] Noble StateChange: poweredOn
    [Discover] Starting scan...
    [Discover] Scanning started.
    [Discover] Scanning stopped.

    A restart "sudo systemctl restart EspruinoHub.service" gets it running normally though.

    I have looked at the logs and tried some config changes but I have found no fix yet.


  • I have looked at the logs and tried some config changes but I have found no fix yet.

    I guess maybe it starts and then something happens to bluetooth later on in the boot. You could try adding a 30 second delay to the startup script (or even EspruinoHub itself?).

    @PuckU is that working with the new OS? I need to have a look and see what's wrong with the versions - it shouldn't really be a big deal to install

  • Thanks @Gordon, a sleep 30 command in start.sh did the trick.
    Sorry for the delays in responding here, things are busy at work.

    I am going to install again on a fresh new Zero 2 W, I will follow the tutorial for EspriunoHub and Node-RED and let you know if there are any errors here.


  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

EspruinoHub and Raspberry Pi OS (Legacy), let's have a go!

Posted by Avatar for PuckU @PuckU