puckjs, v199 - unable to connect and slow

Posted on
  • @Gordon: following the discussion in "Massive Bluetooth speed improvement" thread:

    laptop: MacBook Pro 2017, macOS 10.13.5, Chrome 67

    PuckJS CB34

    • firmware v199 cutting edge - got prompt, no communication (Settings | Console)
    • firmware v199 release - "No Prompt found, got undefined"

    PuckJS FC05

    • firmware v199 cutting edge - webIDE connection ok, but slow in webIDE (39.19 sec UART example)

    both PuckJS with new batteries, near the laptop

  • When was the last time you rebooted? Worth a try...

    Also, are you downloading/uploading anything over WiFi? Often Bluetooth LE and WiFi use the same aerials and so repetitive WiFi traffic seriously impacts Bluetooth LE performance.

    I remember trying to give a talk while streaming my display over WiFi and it was a complete disaster. The second I moved to a cable everything worked faultlessly.

  • I do a hard reset every time after a firmware upload.

    no uploads/downloads while testing (checking in Activity Monitor | Network).

    wonder why I get only a ">erial1" on PuckJS CB34 if I try connecting via BlueFruit iOS app UART)

  • wonder why I get only a ">erial1" on PuckJS CB34 if I try connecting via BlueFruit iOS app UART)

    Do you have things wired up to your Puck.js? Generally it'd only be saying that (I guess it's trying to transmit Serial1) if the UART was enabled - see http://www.espruino.com/Puck.js#serial-c­onsole

    If you've got stuff wired up to it (especially if that stuff is producing a changing signal on D29) then that could explain pretty much all your issues.

  • I have nothing wired to any of the Pucks.

    PuckJS FC05

    • still slow first time today.
    • hard reset -> speedy. works great for now. 😋
      LATER EDIT - after 10 minutes, reconnect via webIDE, slow again. hard reset. speedy again.

    PuckJS CB34

    • drained a new battery to 2.26V
    • put a new battery. hard reset. still no connection 🤯
    • self-test - blink green.
    • weird as the MDBT has some discolouration on the shield (battery leak?) - it was in the silicone case all the time

  • That is very strange - any sign of the battery leaking?

    Is it possible it got wet somehow? The case is pretty water resistant but if it got damp and then left in the case, it'd just be sitting powered up in humid conditions for weeks which would be a disaster.

    Anyway, I bet that's your problem. Chances are the rest of the contacts are that corroded, which means the UART pin probably got pulled up to 3.3v on boot but is more or less floating - when the UART is on it'll drain the battery very quickly - and even more so if it's receiving random data all the time.

  • no battery leakage signs. also it was stored in another plastic case with no damage signs whatsoever.

    any tips on how to debug the problem ? I dont want to have a puck brick :/

  • uploaded v199 cutting edge and now I got a:

    <- Serial1
  • Can you try the long-press on boot thing to clear out saved flash memory? That's usually the issue with PM_EVT_ERROR_UNEXPECTED.

    Do you have any isopropyl alcohol (isopropanol)? I'd suggest going over the whole Puck.js with that and a toothbrush (obviously with the battery out). It's usually pretty good at cleaning up contacts, and might solve your Serial1 issue.

  • did a thorough cleaning with isopropyl alcohol (99.6%) and no luck:

    WARNING: No result found for "process.env" - just got ""
    ERROR: [notify_error] Unable to retrieve board information. Connection Error?
    Device found {"portName":"Puck.js cb34"}
    [success] Connected to Web Bluetooth, Puck.js cb34 (No response from board)
  • ...just had this PUnable to retrieve board information`` in a similar setup but connecting to a PICO and trying to flash... It was a malfunctioning / spotty connection... that lead to all kinds of issues... It found the device, but could not properly / continuously communicate and stay connected. Wire connectivity is different from wireless, but in the end in the application layer - from where this message comes - it is the same. Fixing/replacing my cable and making sure it is completely plugged in both sides fixed the issue for me. But as said, I do not know what exactly to suggest for wireless situation... may be checking with BLE from a phone - to at least figure out which side has the issue?

  • @allObjects laptop works fine with another puck (fc05) with v199.

    the only thing that I tried some time ago (2-3 months) was to make a serial connection. maybe I fried something then ?

    as @Gordon said, maybe it is stuck randomly in Serial mode. wish the self-test would have more info/tests 😋

  • The self-test does come up green though?

    If you did end up connecting a high voltage to D29 I guess that could have caused problems. You could try shorting D29 to GND, which would ensure that if it was working at all it wouldn't auto-initialise the serial port. That should help with battery usage.

    However the bad connection may be related to the corrosion. If you search for the device with your laptop (or the Web Bluetooth screen) do you see a high signal strength - or is it quite low compared to the other Puck.js?

  • self-test: green (5 flashes, middle LED)

    shorting D29 to GND - still got the <- Serial 1 in webIDE

    both Pucks show -65dbm RSSI in Bluetooth Explorer (apple app)

  • Hi @Gordon,

    I upgraded two of my Puck from 1v97 to 1v99, uploaded a code and saved it.
    1) Device1 does not contain any code, all the times I save the code and restart it the code is missing.
    2) Device2 doesn't contained any code for the first 2 saves, after that somehow it succeeded to save it and is working as expected.

    Any ideas ?

  • Hi - please can you post in a new thread and I'll try and help out there? @tbd's connection problems don't seem related at all other than that he used 1v99?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

puckjs, v199 - unable to connect and slow

Posted by Avatar for tbd @tbd