WIZnet WIZ550io

Posted on
of 5
  • Glad to hear it's looking good :) Been busy at work recently...

  • The CC3000 is behaving very nicely now too, even under some stress. Has been running for the last few days with no issues at all :)

  • Do I understand this right now, that only the CC3000 work's fine and the WIZ550io has actually problems? My first try today with the WIZnet library failed so far :-( DHCP dosen't work, http.get() doesn't work and http.createServer() neither. :-(

  • I have had no problems with the wiz550io (since the big wiznet fixes a while back), ave have found it more reliable than the cc3k. I was working with a build of the firmware from last week, and server worked fine. There was an issue with get, but that should be fixed now.

    Someone else was having trouble making dhcp work recently, but said it worked when he specified the IP

  • I've just wired this up and tried again with 1v69. Everything still works perfectly for me - DHCP, http get, server, etc.

    What exactly fails when you do eth.setIP()? What does it say?

    And does eth.getIP() work for you? what does that say? It might be that the module is wired up wrong.

    What is the IP range on your network? The chip automatically sets its IP to on bootup, and I wonder whether if you're outside of the 192.168 range, the netmask might stop DHCP from working properly.

    You could try manually setting the IP to something in your range with something like eth.setIP({ip:""}), and then you could kick off DHCP with eth.setIP().

  • Ditto. All working for me and definitely more reliable than cc3k IMO. You do have to use the special WZZnet build, though. Could that be the problem ?

  • Ok, i tried everything again. At first i flash the espruino with this the newest version


    For information: my home network setup works with 192.168.1.x range. My Synology has normally the ip address, but i read your advice with the default chip address and change it to I guess now, there are no collisions anymore.

    Well, first step: this is the output for getIP()


    so, i tried to connect the DHCP with eth.setIP(); after 5 minutes no response in the WEBIDE, just a blinking cursor after.

    Next step: reset the espruino board and try to set a fix IP (


    This works, eth.getIP() returns a good looking json object. Now, it's possible to ping the ip from my terminal:

    64 bytes from icmp_seq=723 ttl=128 time=4.091 ms
    64 bytes from icmp_seq=724 ttl=128 time=3.910 ms
    64 bytes from icmp_seq=725 ttl=128 time=4.205 ms
    64 bytes from icmp_seq=726 ttl=128 time=4.107 ms

    Fine, now a http.get(); request to my local webserver with default port 80

    >require("http").get("­1", function(res) {
    :    res.on('data', function(data) { console.log(data);    });
    :  });

    Again no response after this comment. Just a blinking cursor on my WEBIDE.

    Also to set the ip to and eth.setIP(); doesn't work.

    I'm out of idea's :-(

    ps: i add also my wire configuration. the picture is little taken from the side, so it looks shifted, but the cables are set by B2-B5 on the espruino board.

    1 Attachment

    • espruino-wiznet.jpg
  • This sounds silly - but the link lights are on, right?

  • Other thing is - that's not the same WIZnet board that I have here :)

    Do you have a link to where you bought it from? The board I have says 'WIZ550io Ver 1.0' on it.

  • Just to add - looks a lot like the rev 1.1 : http://www.wiznet.co.kr/Sub_Modules/en/p­roduct/Product_Detail.asp?cate1=&cate2=&­cate3=&pid=1196

    @DrAzzy, which one do you have? I wonder if WIZnet have changed something between revisions :(

  • I have the 1.0

  • @DrAzzy: yes, the link lights works perfectly. They are flashing, if a ping occurs.
    @Gordon: i have revision 1.1, should i be happy or not to have the common version? :-)

    generally it's really hard with my espruino start :-) Two tries, two problems,.. buuuuuut JS > cpp :-)

  • You're saying the link lights actually react to pings, despite that you're not successfully setting the IP address? That's strange indeed! Check your router (usually they provide a way to list connected clients) and see if the WizNET adapter is listed (look for the MAC address)... that'd help narrow down what's going on - though I'm not sure if it's actionable.

    Also - Have you checked that those connections are all okay? ? Sometimes those breadboards are flaky.

  • BTW: thanks for all this response :-)

    @DrAzzy: if i set the ip manually, i can ping this ip address. This works as describe above. Unfortunately, my home router (apple airport extreme) doesn't show the client connections or don't find it yet. But after set the ip manually, i can create a routing table and the device is listed:

    Routing tables:
    Destination        Gateway            Flags        Refs      Use   Netif Expire
    default          UGSc           12        1     en1        0:8:dc:1d:4f:18    UHLWI           0      115     en1   1181

    So i test now another breadboard, same issue.

  • Only thing I can think of is that Wiznet must have changed something in v1.1 that broke the drivers in the Espruino :-(

  • I've just fired off an e-mail to WIZnet and we'll see if they can think of anything.

    @possmann it's a shame you're having problems, but you are trying to do something quite advanced with it. I guess if you were just using normal SPI/Serial/etc you wouldn't be having a great deal of trouble.

    Unfortunately if WIZnet change the way their board works and don't tell me there's very little I can do until I know about it :(

  • No problem! Thanks for all the help and response. And i know, it's not easy for you to handle all these things. I will wait and hope for good news.

  • I've just fired off an e-mail to WIZnet and we'll see if they can think of anything.

    @Gordon: do you have an update or feedback from wiznet?

  • Thanks for reminding me about this... I never did get a reply to the e-mail. I've just prodded him again and posted on their forum

  • Hello Guys,
    I'm James from WIZnet.
    I saw the post which Gordon wrote on our forum site.
    Hi Gordon, do you remember me? We have met at the office of APC Hero in Cambridge.

    Anyway, let me tell what the difference is between Rev 1.0 and 1.1 of WIZ550io.
    There is no difference except those header pin's pitch was changed.
    The gap of two header pin rows is too wide to plug in a breadboard and many customers request to make it short a little, so we made the revised one, Rev 1.1.
    Except that, there is no change. All parts are same. Schematic is same. But Routing is changed a little because hardware dimension was changed.

    I am thinking why WIZ550io didn't work properly.
    According to possmann's post, he did try to get IP address from DHCP server because His Synology has the same IP address,, which WIZ550io has as the default, right?
    But he couldn't get IP address from DHCP server and his command, eth.getIP() returned all 0's.

    1. To solve this problem, I need the captured packets with wireshark.exe.
    2. I guess possmann called eth.getIP() in too short time after reset whole system. If there is no problem in Espruino's DHCP library, I recommend he wait for more time.
    3. Anyway, if you capture all the packets between WIZ550io and DHCP server, it will help us analyze the reason.

    And for the second issue.
    Possman said that he set WIZ550io with fixed IP address, after reset Espruino then it worked well, but it didn't work again after http.get(), Right?

    1. As he told before, he already has a system having IP address, So there are two devices, his Sysnology and WIZ550io, within the same network.
      This may make IP conflict.
    2. Try to eth.setIP() with IP address which is not being used. If he can succeed http.get() command, this is the reason why his WIZ550io didn't work properly after http.get().

    Please try to solve IP conflict first. This is more easy issue.

    Let me know your test result.

    Thank you.


  • @javakys yes, I remember! thanks replying here...

    As I understand it, @possmann has already changed his Synology's IP address to so there shouldn't be a conflict...

    It's good to know that there is no real difference in the boards. I only blamed the board because we have two users here (I'm afraid I can't remember the second one) with rev 1.1 that are having problems - and everyone's rev 1.0 seems to work fine.

    It may just be a coincidence though... I guess any WIZX550io that gets bought now will be a rev 1.1, so it's likely that anyone now having problems will be having them with a rev 1.1

  • Humm...
    I will do some more test with both of them and Espruino board soon.
    But as I need a few days to get Espruino board from Adafruit, I may be able to answer next week at earliest.
    Could you wait for me until then?

  • Wow, thanks for ordering one! I'm sure we can wait :)

    I don't suppose Joachim left you with one? I think I gave you one (or two) of the prototypes, and he should have a bunch of his own now because he bought the big starter kit on KickStarter...

  • Hello Gordon,
    sorry I missed your many e-mails - shame on me.
    Yes, we have some (enough) Espruino Boards here and I will set up more tests tomorrow morning immediately.
    If you like we can send you some v1.1 modules tomorrow (with FedEx) - just send me your current postal address by e-mail - you will have them in hand asap.

    Thanks for your nice work on the Ethernet I/F using our Hardwired TCP/IP Chip / Module.
    We will keep track here and fight the Bug, best regards, Joachim.

  • Thanks - e-mail sent. Hopefully we'll get this sorted soon!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

WIZnet WIZ550io

Posted by Avatar for Pat @Pat