Avatar for Fram

Fram

Member since Apr 2020 • Last active Aug 2020
  • 4 conversations
  • 26 comments

Just a new owner on a smart Bangle.js... and proud of that !

Most recent activity

    • 22 comments
    • 1,370 views
  • in Bangle.js
    Avatar for Fram

    Hi everyone !
    @Gordon and @DrBard : my soldering iron is low power Antex (CS18 / 18W) with a thin tip (0.5mm).
    If you can do a video for this upgrade, thank you because, unfortunately, I dind't took the time to do so.
    Francis

    • 12 comments
    • 664 views
  • in Bangle.js
    Avatar for Fram

    @Gordon You are welcome !

  • in Bangle.js
    Avatar for Fram

    Hi everyone !
    I confirm that this issue is SOLVED !
    I let my battery run out of power, chosen the analog clock as the default clock and...
    The Bangle.js starts normally and is no more blocked on « Searching for GPS time ».
    Thank you Gordon for the Analog Clock update (0.11->0.12) that solved the problem.
    Francis

  • in Bangle.js
    Avatar for Fram

    BTW there is a new release for the Analog Clock:

    0.11: shift face down for widget area, maximize face size, 0 pad single digit date, use locale for date
    0.12: Fix regression after 0.11

    I updated my app (0.11->0.12) and I am waiting for my battery to run out to see if this issue is solved.
    F.

  • in Bangle.js
    Avatar for Fram

    Hi everybody !
    Poor goat... The fact that BLE was available seems to be sufficient to connect the Bangle.js to Chrome (with your favorite computer) and set the time with the Set Bangle.js time button from the Bangle.js App Loader page.
    That saved me... and the goat !
    Francis

  • in Bangle.js
    Avatar for Fram

    Hi everyone
    @Gordon and @Lixas thank you for your answers.

    this should help you if you are stuck
    https://www.espruino.com/Bangle.js#reset­ting-without-loading-any-code

    Sorry, it didn't work. I tried everything: the watch stayed blocked on « Searching for GPS time ».

    To my understanding - BLE is turned on by default, but gets disabled
    when boot sequence gets loaded into memory (according to main settings
    file) vie boot0.js file

    It seems you are right since I updated the date/time with App Loader that unblocked the watch. But as I let the BLE on, it is to be verified.

    That's odd - just tried here - install default apps, add analog clock,
    remove morph - and restarted, and it's fine. Searching for GPS time
    appears but disappears after a second or two.

    I agree, I do the same test this morning (after GPS update) and it worked.
    But, yesterday, I had ran out of battery and the GPS date/time was empty !

    Do you have extra widgets installed? I guess it's possible that
    Bangle.js runs out of memory while trying to start up and can't finish
    loading the clock.

    No, no more extra widgets that the "regular" ones (my apps:

    • Bootloader (v0.14)
    • Morphing Clock (v0.03)
    • About (v0.04)
    • Default Alarm (v0.06)
    • Heart Rate Monitor (v0.01)
    • Spirit Level (v0.01)
    • Tabata (v0.01)
    • Pomodoro (v0.01)
    • Compass (v0.01)
    • Open Location / Plus Codes (v0.01)
    • GPS Info (v0.03)
    • App Manager (v0.02)
    • Analog Clock (v0.11)
    • Simple Clock (v0.04)
    • Mixed Clock (v0.04)
    • Dev Clock (v0.09)
    • OpenStreetMap (v0.02)
    • Battery Level Widget (v0.05)
    • Bluetooth Widget (v0.04)
    • GPS Recorder (v0.07)
    • Default Launcher (v0.02)
    • Settings (v0.15)
      )
      Francis
  • in Bangle.js
    Avatar for Fram

    Context: the battery ran out and the GPS date/time had been lost.
    I connected my watch to App Loader and made all the updates (mainly Settings).
    I reboot the watch after the updates and…
    My watch stayed blocked on « Searching for GPS time ». No way to exit through button 3, no way to access the settings through button 2.
    Fortunately, as the bluetooth was on, I successfully updated the date/time through the « Set Bangle.js Time » button. Then, the exit through button 3 worked showing the Analog Clock.
    If I reboot, I meet the same problem: the watch stay blocked on « Searching for GPS time » until I update the date/time with App Loader.
    No problem with the other clocks I have: Simple Clock, Mixed Clock, Dev Clock and Morphing Clock.
    After reboot, the message « Searching for GPS time » is shown a second then the watch appears and all the buttons are running.
    My chance was the bluetooth was on. But, if not, how to do with the Analog Clock that doesn’t start after the « Searching for GPS time » question ?
    I precise that the GPS is not on and there is no way to make it run after boot (I let the watch outside and the « Searching for GPS time » was always here).
    Francis

  • in Bangle.js
    Avatar for Fram

    Hi everyone
    @skm Cool ! Good job as your piezo is smaller than mine (27mm) !
    You can enjoy the sound of the Bangle.js from now.
    Francis

Actions