Avatar for user92368

user92368

Member since Jul 2018 • Last active Jul 2018
  • 1 conversations
  • 6 comments

Most recent activity

  • in Puck.js, Pixl.js and MDBT42
    Avatar for user92368

    No worries. Just a few minutes after I took the above photo, I started it in the boot-loader mode and then I could see the device as DfuTarg. I flashed it with latest firmware espruino_1v99_puckjs.zip using nRF Toolbox. After that, it is now working properly.

    I suppose its fine now. I'll continue working on it. I'll let you know if anything happens again. And thank you for offering a replacement.

    Thanks.

  • in Puck.js, Pixl.js and MDBT42
    Avatar for user92368

    Yes, I can see other devices nearby and I'm able to pair with them. But I can't see DfuTarg or Puck.js xxxx.

    I've attached a photo of the device. I can't see any visible issues with the white bar next to the chip.

  • in Puck.js, Pixl.js and MDBT42
    Avatar for user92368

    Yes, then I suppose I have the latest bootloader. I actually ordered this one last week on 17th July. I bought it from shop.espruino.com: Invoice No.: ES-00224 Order ID: #301; if that helps.

    Steps I followed.

    1. Battery out
    2. Press and hold the reset button
    3. Insert the battery. Green LED lits
    4. Release the button immediately, the Green LED brightens up.
    5. I used my Android phone with nRF Connect app to scan.
    6. But still, I'm not able to see the device on the app.

    Does this mean that the Bluetooth trans-receiver is damaged?

  • in Puck.js, Pixl.js and MDBT42
    Avatar for user92368

    I've reset the device many times. Shouldn't it clear any pairing/bonding information on it?

    The self-test is working fine, the green LED is blinking five times.

    I've turned off the Bluetooth on my MacBookAir and on my phone and tried connecting it from another device. But still, it isn't showing up on Bluetooth scans?

    Did I accidentally damaged the Bluetooth trans-receiver?

    It was in its case when it suddenly disconnected from my MacBookAir and since then I haven't been able to connect.

    Update: I kept it untouched for a while. And then when I tried picking it up, all three LEDs went up and second later all LEDs turned themselves off on after the other. :(

  • Avatar for user92368

    When I try to put it in boot loader mode, the green LED stays lit instead of red one. Does that mean anything? I try to release button as soon as I put back the battery. The battery is fresh new from packaging, not even a day old.

  • Avatar for user92368

    I had just bought it. It was all working fine, suddenly it lost connection and since then I'm unable to connect to Puck. I was working on some NRF/NFC related code. I tried resetting. The reset procedure completed successfully with red light blinking. But still, I'm not able to connect. Both my phone and PC is unable to discover the Puck during the scan. I also tried self-test by releasing button when all three LEDs are lit. It shows blinking green indicating all is well.

    I tried resetting many times but still when I scan using MacBook or on my android phone, I can't find the Puck device.

    And also, I'm not able to switch to bootloader mode. I tried pressing the button and released it just after I inserted the battery. Instead of red led, the green led is lit. How do I switch to bootloader mode?

    Have I accidentally damaged the Puck? I don't think so because the self-test is working fine.

    Thanks.

Actions