• I had just bought it. It was all working fine, suddenly it lost connection and since then I'm unable to connect to Puck. I was working on some NRF/NFC related code. I tried resetting. The reset procedure completed successfully with red light blinking. But still, I'm not able to connect. Both my phone and PC is unable to discover the Puck during the scan. I also tried self-test by releasing button when all three LEDs are lit. It shows blinking green indicating all is well.

    I tried resetting many times but still when I scan using MacBook or on my android phone, I can't find the Puck device.

    And also, I'm not able to switch to bootloader mode. I tried pressing the button and released it just after I inserted the battery. Instead of red led, the green led is lit. How do I switch to bootloader mode?

    Have I accidentally damaged the Puck? I don't think so because the self-test is working fine.


  • When I try to put it in boot loader mode, the green LED stays lit instead of red one. Does that mean anything? I try to release button as soon as I put back the battery. The battery is fresh new from packaging, not even a day old.

  • If the puck is paired, it doesn’t advertise any more. So if one device is auto connecting- they will stop it. And pulling the battery it might auto connect on re-power up. So turn off Bluetooth on all devices you have connected to.

    For the boot loader mode it needs to be a particular length of time to hold the button down - it’s a kind of tricky timing thing.

  • I've reset the device many times. Shouldn't it clear any pairing/bonding information on it?

    The self-test is working fine, the green LED is blinking five times.

    I've turned off the Bluetooth on my MacBookAir and on my phone and tried connecting it from another device. But still, it isn't showing up on Bluetooth scans?

    Did I accidentally damaged the Bluetooth trans-receiver?

    It was in its case when it suddenly disconnected from my MacBookAir and since then I haven't been able to connect.

    Update: I kept it untouched for a while. And then when I tried picking it up, all three LEDs went up and second later all LEDs turned themselves off on after the other. :(

  • I've reset the device many times. Shouldn't it clear any pairing/bonding information on it?

    Yes, when you hold down the button all the way through the red blinking it will delete any pairing data.

    I believe the bootloader is working fine. It's just a newer bootloader on the new batch of Pucks (which it seems like you have - I'll update the documentation). The green LED should get slightly brighter when you release the button?

    Could you try the steps outlined for the firmware update? nRF Connect should see a DfuTarg device and when you connect the light should go from green to blue. If you can do that then we'll know Bluetooth is working ok.

  • Yes, then I suppose I have the latest bootloader. I actually ordered this one last week on 17th July. I bought it from shop.espruino.com: Invoice No.: ES-00224 Order ID: #301; if that helps.

    Steps I followed.

    1. Battery out
    2. Press and hold the reset button
    3. Insert the battery. Green LED lits
    4. Release the button immediately, the Green LED brightens up.
    5. I used my Android phone with nRF Connect app to scan.
    6. But still, I'm not able to see the device on the app.

    Does this mean that the Bluetooth trans-receiver is damaged?

  • Yes, you'd definitely have one of the newest ones then.

    That doesn't look promising then. And you see other Bluetooth devices in range on your phone, just not something called DfuTarg? The bootloader won't appear as Puck.js abcd.

    Does the aerial (the white thing) on the edge of the device look ok, or is it cracked?

  • Yes, I can see other devices nearby and I'm able to pair with them. But I can't see DfuTarg or Puck.js xxxx.

    I've attached a photo of the device. I can't see any visible issues with the white bar next to the chip.

    1 Attachment

    • IMG_20180727_161235.jpg
  • That does all look fine to me. Do you have another CR2032 battery you could check with just in case?

    But if not I'll arrange to send you a new one. Would it be possible to send me the old one back with the cheapest untracked post you can get, and with a something like 'gift' and $5 on the customs form?

  • No worries. Just a few minutes after I took the above photo, I started it in the boot-loader mode and then I could see the device as DfuTarg. I flashed it with latest firmware espruino_1v99_puckjs.zip using nRF Toolbox. After that, it is now working properly.

    I suppose its fine now. I'll continue working on it. I'll let you know if anything happens again. And thank you for offering a replacement.


  • Great, glad it's going again! I wonder why that was though - it is extremely strange behaviour.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Puck] Unable to connect. Device became undiscoverable from both Macos and Android

Posted by Avatar for user92368 @user92368