battery went flat but cant set time

Posted on
  • Help! My battery went flat. Once I got some charge back into the battery it came up with Thursday 7 Oct 20548 as the date. Managed to get a fix for the GPS and rebooted but am not seeing the 'Searching for GPS' message. Am on firmware. I seem to remember there was a way to set the time from the App Loader but cant find it.

  • Installed GPS Time from App Loader. The app came up with the correct time as if GPS had remembered the fix from before, so I was able to set the time from that without waiting for a fix. On rebooting v2.0.160 I only see a message that says bluetooth in the bottom right hand corner around the time it would have said 'Searching for GPS'.

  • Ok, thanks - looks like there's an issue with the new firmwares. They try and remember the time between reboots but it looks like if the watch goes flat they don't reset to 1970, so the watch doesn't try and get GPS time. I'll get a fix in for that.

    But you're saying that after installing GPS Time app and going to it and setting the time, the clock then stopped working?

  • Battery went flat. Recharged but on power up date was set to 20548 as the year. Tried a BTN1+BTN2 reset but noticed I did not see the 'Searching for GPS' message. Decided to start up the GPS using my app, got a GPS and could see the time was correct on the GPS fixes so assumed that the time was now stored in the GPS. Did another reset. No 'Searching for GPS' message and clock still incorrect. Search for a way to set the Bangle Date/Time manually but could not find the button on the launcher. Then installed GPSTime and got a fix. Pressed SET () and reset GPS. On start up: no 'Searching for GPS' message BUT clock was now set, which will have been set by action (). Hope that makes sense. I'm up an running again. Happy to stay on 2.08.160.

  • I think if you update to the latest Espruino firmware now, the problem is fixed.

  • Updated to 2.08.167 - but still not seeing the "searching for GPS" message. Do see the word BLUETOOTH in bottom left of screen around about the time I have got used to seeing the message. Would "checking GPS time" be a better message during bootup. My understanding is that it is checking the GPS clock.

  • Updated to 2.08.167 - but still not seeing the "searching for GPS" message

    Did you completely flatten the watch?

    Because if the watch had the wrong time and rebooted, it'll still keep the wrong time. It has no way to know if the time is right or not. You'll have to manually set it.

    However with the most recent update, the watch should hopefully never get to the state where it has the wrong time again.

    Would "checking GPS time" be a better message during bootup.

    It says Searching for GPS time at the moment. I guess checking GPS time might be marginally better but honestly I don't think it makes a big difference to how users would understand it.

    Also I think given the recent update, that message is now extremely unlikely ever to be displayed, so I think it's a non-issue now

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

battery went flat but cant set time

Posted by Avatar for HughB @HughB