• Sun 2020.01.05

    I am attributing the following to Microsoft and Windows, not Espruino.

    See end of #15 post - work around steps


    I'm having to perform the aforementioned steps as often as every five minutes. Sometimes have been able to code for an hour before a lockup.

    I am experiencing a ton of 'Failed Connect' issues with the MDBT42Q breakout board, where code files that worked reliably before, seem problematic since the last Nov 2019 Windows10 update.

    Windows10 Nov 2019 update - version 1903 - build 17763.914 Feature update to Windows 10

    Is anyone else experiencing what appears to be MDBT42Q BLE issues with Windows10?

  • Works just fine on my machine. I was on the latest Win10 (I guess 1903) till end of december, worked OK. Updated to the insiders-slow-preview (10.0.19041.1) to get WSL2, works now. Didn't have problems before. Don't have problems now. MDBT42Q, DS-D6 smart-watch-band, E73 module from aliex, Bangle since friday. It just works.

    I remember I had to mess with bonding, but not in the last couple of months.
    What about you machine's drivers?

    Wild guess: you didn't drop your MDBT42Q module? Don't know how fragile the ceramic antenna might be. Or any other way to damage it? Mechanical, ESD, could be a lousy solder joint?
    Do you have other bluetooth module to check with your computer. Or other computer / phone / tablet to check the module? Or grab a usb drive, boot to linux, and try it that way?

  • Sun 2020.01.05

    Thanks for that.

    'you didn't drop your MDBT42Q module?'

    My precious Espruino's? How dare you ;-)

    'Do you have other bluetooth module'

    Not yet. waiting . . .

    No, everything has been on a tabletop in tact while pounding out code. Have even stripped down to bare lines of code. Facing due East to block the Earth's magnetic field flux lines while wearing a tin foil hat isn't working either. The only thing that really stands out is the update, as it failed with a 'Blue' screen on reboot. Had a heck of a weekend back then, just to get it back up and running. And that's around the time connectivity started to be an issue. It might be that Windows10 still hasn't caught up with updates/drivers as I see the log is still filling up.

    All the ideas you have suggested have been floating around in my mind. Too many combinations at the moment. Was hoping for a simple validation from someone else. Still will plug away at the ideas in #2

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Anyone now having 'Failed Connect' issues, where it worked reliably before, with MDBT42Q on Windows10 since last Nov 2019 Win update?

Posted by Avatar for Robin @Robin