is it a web ide issue ?? esp32 connection

Posted on
  • I am unable to connect to the esp32 with the web ide.
    Just shows up:

    Connected to COM9 (No response from board)

    Putty works very well but it shows a warning:

    WARNING: setsockopt(SO_REUSPORT) failed

  • Fri 2018.11.23

    Hello @Barney,

    What version of Espruino has been flashed?

    What version of the IDE?     IDE >> Settings >> About

    Which IDE?     Chrome/Native/Web

    What PC O/S?     Mac/Win10/Linux

    Is there any additional detail listed in the console output?     IDE >> Settings >> Console     towards the end of the listing

    With that, others might get a more general idea of what may be occurring.

  • i tried the V2.0 and the cutting edge 2.00.94.
    The IDE Version is 0.70.6 on Windows 10 as Chrome App.

    I recieve weird symbols on the left side of my ide like: "§² uã(»¸aø".

    And the Console Log is:

    Set Slow Write = true
    [object Object]
    Connected [object Object]
    ERROR: RECEIVE ERROR: {"connectionId":1,"error":"frame_error"}­
    Disconnect callback...
    WARNING: [notify_warn] Disconnected
    Got ""
    No Prompt found, got undefined - issuing Ctrl-C to try and break out
    Still no prompt - issuing another Ctrl-C
    WARNING: No result found for "process.env" - just got ""
    ERROR: [notify_error] Unable to retrieve board information. Connection Error?
    Device found {"bitrate":9600,"bufferSize":4096,"conne­ctionId":1,"ctsFlowControl":false,"dataB­its":"eight","name":"","parityBit":"no",­"paused":false,"persistent":false,"recei­veTimeout":0,"sendTimeout":0,"stopBits":­"one"}
    [success] Connected to COM9 (No response from board)
    Connected to COM9 (No response from board)

  • ok got it. It seems the connection baud rate is to low :-) got it on 115200 from 9600 and now it works.

  • Yet another reason for us to do­ues/1535 I guess. This hits the vast majority of people using ESP8266/ESP32 :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

is it a web ide issue ?? esp32 connection

Posted by Avatar for Barney @Barney