NDEF support

Posted on
  • I have an npm for creating and parsing NFC NDEF messages. https://www.npmjs.com/package/ndef Unfortunately it's multiple files so I can't just require it on the Puck. What's the best way to make this npm compatible with the Puck?

  • You possibly can - although you might have size issues. In the ide, create a project. This will make a sub folder modules. Put all of your dependencies in there and the in the ide source require the top level, which should then pull in everything else....

  • Coincidentally there is a discussion on modules here


  • .removed

  • @AntiCat the NDEF code is all JavaScript, so it should work. This npm will generate the NDEF bytes and I'll use NRF to write it, similar to the way libfreefare was used. I need to update that documentation.

    @Wilberforce thanks for the link. I'll work on getting this converted.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

NDEF support

Posted by Avatar for don @don