[SOLVED] "nano.specs: No such file or directory"

Posted on
  • Hi guys,

    I just tried to compile Espruino for Pico. Cross compilation seems OK but after a while I got:

    CC src/jsnative.o
    CC src/jsparse.o
    CC src/jspin.o
    CC src/jsinteractive.o
    CC src/jsdevices.o
    CC src/jstimer.o
    CC src/jsi2c.o
    CC src/jsspi.o
    CC src/jshardware_common.o
    CC gen/jswrapper.o
    gen/jswrapper.c: In function 'jswGetBuiltInJSLibrary':
    gen/jswrapper.c:1859:48: warning: unused parameter 'name' [-Wunused-parameter]
     const char *jswGetBuiltInJSLibrary(const char *name) {
    LD espruino_1v95.237_pico_1r3.elf
    arm-none-eabi-gcc: error: nano.specs: No such file or directory
    make: *** [espruino_1v95.237_pico_1r3.elf] Error 1

    Any idea?

  • Did you use source scripts/provisio.sh PICO_R1_3 to set up the compiler, or did you use your own?

    Looks like you may have used something else? https://stackoverflow.com/questions/2693­1979/gnu-arm-nano-specs-not-found

  • I used gcc-arm-none-eabi-5_4-2016q3 that was already on my machine under /usr/local
    Then I updated my $PATH with

    export PATH=/usr/local/gcc-arm-none-eabi-5_4-20­16q3/bin:$PATH

    and finally run

    make clean &&  BOARD=PICO_R1_3 RELEASE=1 make

    Now if I type source scripts/provision.sh PICO_R1_3 it just prints ARM. by calling make it then just tells me the same error with nano.specs

    I don't really understand what I missed. Do you suggest to remove+reinstall the complete toolchain?

  • It's complaining about the option --specs=nano.specs on the Linker command-line, and for whatever reason I guess the compiler you have doesn't have them in.

    The provision script checks for GCC before installing it, and in this case I guess it finds it so does nothing. Maybe ensure that it's not in your path, then run provision and it should pull a new compiler into a local folder under Espruino and temporarily set your path.

    It'd be a good way to check if that is the problem or not as it doesn't install anything globally.

  • I had another (old) toolchain installed in /usr/bin previously installed with apt-get .... :-/
    Just removed it, run source scripts/provision.sh PICO_R1_3, which actually installed the correct toolchain and after that I just could compile for my Pico. Thanks for the support Gordon!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[SOLVED] "nano.specs: No such file or directory"

Posted by Avatar for Jean-Philippe_Rey @Jean-Philippe_Rey