Third party 'espruino-cli' tool is dead...

Posted on
  • Sad to say, but look like Command line tool is dead for me, I've spent 5 h or so trying to fix it..

    I've been using command line. I prefer my own editor and I'm not a fan of copying large chunks of code from my editor into web IDE...

    Updated npm packages and tried to connect like always, but got this:­2e66350f20a393d73c0caa3ffda4

    Seemed like espruino-cli I decided to update espruino-cli but I got this:­01d83d871b1e0b8997d0b386146a

    Please help!

    I've opened issues­s/issues/66 ,­

  • Looks like the serialport module won't install for you. You must have changed something - any idea what? Did you install a new node version?

    Can you try 'npm install serialport' and see if it completes without errors? If not perhaps you could contact the node serialport project and ask for help?

  • Ok, I got confused - this is about gzip's espruino-cli after all. I have similar problems when installing it and I think it's to do with espruino-cli using an out of date serialport module (1.2.5) when we're up to at least version 4.0 now.

    Try sudo npm install -g espruino and use the espruino tool and not espruino-cli. That's the one I actually maintain, and contains a whole bunch of extra features. It's basically got all the Web IDE's backend packaged into a CLI.

  • yes, updated node and npm...

    Inspired by your suggestion I decided to reinstall espruino and espruino-cli, I believe there is something wrong with espruino-cli itself.

    Anyways, a clean install of espruino npm package and fixing XCode has solved it.
    As I noticed espruino package goes with espruino-cli and installing espruino-cli by itself creates havoc. Not mentioning that node-gyp has its own problems with Xcode

    Thank you for help!

  • @ancienthero any tips to fix the node-gpy Xcode problems ?

  • @tbd Yes, after hours of trial and error, this finally worked for me:

    Install Xcode
    Run sudo xcode-select -s /Applications/­er

    unfortunately it requires to install Xcode (5GB or so).

    here is full thread:­s/569

  • It seems that Node.js has been pushing ahead with NAPI modules (that don't need a recompile for each version of Node.js) - so hopefully at some point in the next year we won't have this nightmare to worry about :(

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Third party 'espruino-cli' tool is dead...

Posted by Avatar for ancienthero @ancienthero