Build error in

Posted on
  • Just did a fresh pull and tried to build BANGLEJS2 and it failed with:

    CC obj/libs/tensorflow/tensorflow/lite/micr­o/
    arm-none-eabi-gcc: error: unrecognized command line option '-fmacro-prefix-map=libs/tensorflow/='
    make: *** [Makefile:842: obj/libs/tensorflow/tensorflow/lite/micr­o/] Error 1

    I commented out TENSORFLOW and it builds fine.

  • old gcc probably, use provision script to get working compiler

  • Just did a clean clone, and a BANGLEJS2, followed by make clean && BOARD=BANGLEJS2 RELEASE=1 make
    Still get the error

  • did you run provision like . scripts/... with dot and space to load environment changes into current shell?

  • You can see it does work in the online build at­ions so something is presumably up with your system.

    As I recall, provision won't install a compiler if you already have one on your path, so you're probably still using an old compiler ad @fanoush suggested

  • Yes, this seems to have caused me headaches before... I will remove my compiler and let the provision script do its thing.. thanks you

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Build error in

Posted by Avatar for yngv126399 @yngv126399